Bug 90196 - Bad allocation
Summary: Bad allocation
Status: RESOLVED DUPLICATE of bug 81378
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.3.5.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-03-24 15:08 UTC by Chris Lambert
Modified: 2015-05-02 18:18 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screen shot of error (1.07 MB, application/vnd.oasis.opendocument.graphics)
2015-03-24 15:08 UTC, Chris Lambert
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Lambert 2015-03-24 15:08:17 UTC
Created attachment 114305 [details]
Screen shot of error

Bad allocation error on save.  I have attached a couple of screenshots and can provide actual files if it would help.  File sizes are large and problem seemed to occur after 15 or 20 pages.  As you can see here, 41 pages is the limit.  Created new files in DRAW from scratch and problem re-occurred each time.  This was my daughter's final year portfolio submission to the London College of Fashion yesterday, so timing of this bug could not have been worse.  Would be very grateful if you could please advise.
Comment 1 Julien Nabet 2015-03-24 20:18:11 UTC
First make backup of your work.

What's the size of the odg file?
What's the size of all the images you want to include?

If you hadn't mention it was a portfolio, I would have suggested about compressing images but...

You can try different memory settings in menu Tools/Options/Memory

Also, since you're short of time, someone could help you by giving a try to 4.4.1 LO version (or pre release version 4.4.2 RC1)
Comment 2 Robinson Tryon (qubit) 2015-03-29 16:05:39 UTC
(In reply to Julien Nabet from comment #1)
> First make backup of your work.
> 
> What's the size of the odg file?
> What's the size of all the images you want to include?

Status -> NEEDINFO
Comment 3 Chris Lambert 2015-03-29 19:13:10 UTC
I made a number of attempts, the smallest file was 19MB and the largest was 52MB when the error was detected.

I wanted to load a total of 89 A3 sized images.  These images ranged from 500KB to 15MB.
Comment 4 Julien Nabet 2015-03-29 19:44:32 UTC
Chris: thank you for your feedback, have you tried to change the default settings of memory (see comment1)?
Also, you may monitor memory consumption with process monitor Windows tool.
Comment 5 Chris Lambert 2015-03-29 20:44:33 UTC
(In reply to Julien Nabet from comment #4)
> Chris: thank you for your feedback, have you tried to change the default
> settings of memory (see comment1)?
> Also, you may monitor memory consumption with process monitor Windows tool.

Julien,

I must confess I'm not an expert at these things.  So here is what I've done.  I've changed cache settings from factory default to the following:
Graphics cache - 30MB
Per object - 6MB
Number of objects - 30

Please note that I am now using LibreOffice 4.4.1.2.  This version appeared to perform better initially but eventually bailed out at 72 slides and c.75MB.

Opened this file again and added several of the largest images I could find; one per slide.  There are now 89 slides now with one image per slide.  The file size is 155MB.  Although the laptop was having to work a bit at times, the application did not crash.

Thanks

Chris
Comment 6 Julien Nabet 2015-03-29 20:49:31 UTC
Thank you Chris for your feedback.
Since I don't have more questions, I'd put back the status to UNCONFIRMED.
Comment 7 raal 2015-04-13 19:13:16 UTC
Looks similar to bug 81378?
Comment 8 raal 2015-05-02 18:18:42 UTC
Info from Chris> I would say the bug 90196 and 81378 are the same.  Could not figure out how to add this comment direct to the bug reporting system, therefore have emailed you direct.

Closing as duplicate.

*** This bug has been marked as a duplicate of bug 81378 ***