Download it now!
Bug 81378 - Permanent Crashes and Content Loss in Presentations ("Bad allocation" warning and crash)
Summary: Permanent Crashes and Content Loss in Presentations ("Bad allocation" warning...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: x86-64 (AMD64) Windows (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 90196 90715 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-07-15 08:58 UTC by thorsten.brandau
Modified: 2017-01-05 11:42 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
backtrace info when exporting an impress odp to PDF (90.14 KB, text/plain)
2014-08-05 06:26 UTC, superurbi
Details
odp test file (5.13 KB, text/html)
2014-08-05 06:36 UTC, superurbi
Details
Computer details used (4.95 KB, text/plain)
2014-08-05 06:37 UTC, superurbi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description thorsten.brandau 2014-07-15 08:58:11 UTC
I prepare regulary presentations with Libreoffice. The presentations are not too large (50 - 300 MB) but contain (obviously) a lot of picture, most of them in JPG Format.

On a very frequent basis (like 50 times a day) Libreoffice crashes

- When adding pictures
- When copying multiple pages with pictures
- When saving
- When "save as"
- When "reduce size of presentation"

It basically makes the program unusal.

Furthermore, the repair function removes a number of pictures which have to be readded everytime.

Secondly, Libreoffice looses pictures after saving. The connection is broken and only spaceholders are shown. When pictures have shadows, often only the shadows are shown.

After adding a couple of pictures, typically "filter not found" is shown (which happens by the way also in writer). I have to close soffice.bin and restart to add more picture.

It seems to get worse with every version.

Sometimes "Bad Allocation" is shown, various library not found messages (more seldom but never twice the same), and sometimes you can even select menus, but cannot do anything anymore (save, close, move pictures...). Sometimes it just closes without comment.

I was bearing for it since OpenOffice 1.0 for a long time, but it seems as this problem never gets addressed, this is why I file the bug report now.
Comment 1 bfoman (inactive) 2014-07-15 17:38:41 UTC
(In reply to comment #0)
> I was bearing for it since OpenOffice 1.0 for a long time, but it seems as
> this problem never gets addressed, this is why I file the bug report now.

Please be advised that this report won't help to solve it neither without precise steps to reproduce for every issue (you reported a lot of them here - general rule is 1 bug = 1 report). Also attaching 50-300 MB file is not possible. Therefore please split this report into separate issues (if they are not filed already) and help the project by providing backtraces when LibreOffice crashes for each of them. This will confirm the bugs and help to pinpoint where are the problems. Using WinDbg is not a black magic and will help a lot potential developers.
Additional read:
https://wiki.documentfoundation.org/How_to_get_a_backtrace_with_WinDbg
Also please do not forget to attach precise info about your system and LibreOffice configuration. Maybe some problems are specific to your environment or settings. 
Last but not least please remember that LibreOffice is powered by a team of volunteers and good bug reports help tremendously in making the fixing process go smoother.
Comment 2 thorsten.brandau 2014-07-16 06:54:28 UTC
Thank you for your comments. Due to IT restrictions I may not install a debugger in any case. However, it is very simple to reproduce the behaviour:

- Save a large presentation
- Typically at this point one or two pictures have vanished, i.e. only a placeholder is shown
- Save again
- LibreOffice Impress crashes with "Bad Allocation"

Similar:

- Drag and Drop pictures in the presentation (JPG or PNG)
- After 4 or 5 typically a message "Filter not found" is displayed
- Now other pictures have vanished
- Click around in the slides or save 
- Impress crashes with "Bad Allocation"

Similar:
- Do a "Compress Presentation" with a large presentation (starts usually around 100 MB)
- Compression hangs

There are some faults usually happening in the listed order/frequence:
1. "Bad Allocation" with closing of Impress
2. Program hangs
3. Random Error Message and Program closes

The repair function typically looses a couple of images after repair.

Other ways to reproduce:
- Copy a large presentation
- Move slides from one presentation to another by drag and drop
- "Bad Allocation" or silent close of the program

The crashes are very, very obivous. For a number of version similar things happend very frequently in Writer files when adding a larger number of images (typically JPEG), then the import dialoge for a file pops up instead of including the images.

I believe this is ONE bug, not several, as it happes in all office parts. From what I see I believe that there is a serious memory handling problem with the import filters, which seem to be used for all parts.

As those bugs got worse in the forthcoming of StarOffice/OpenOffice/LibreOffice during its OpenSource live, I was giving good faith that Developers can impossibly miss it. However, having seen that currently between each versions are differences in stability (the one used below is worse as the version before).

My tested configurations are
- Windows 7 X64 Professional and Home Premium
- Intel Core I7 and i5
- 8GB Ram
- Discs between 500 and 1000 MB
- Some configurations with SSD
- All service packs included
- Files access locally and via network
Comment 3 Cor Nouws 2014-07-16 08:43:39 UTC
Hi Thorsten,

Is it OK to mark this party as duplicate of bug 46447 ?
Thanks,
Cor
Comment 4 thorsten.brandau 2014-07-16 09:05:41 UTC
Hi Cor,

this might well be. From my experience however the files do not vanish mandatory. If you close and reopen the file (make sure not to save!) it happens irregularily that some of the images reappear and others vanish. Some of them are in the file still existing, somethimes they are lost. I am pretty sure the problem is in the filters as this is pretty persistent over all OpenOffice and LibreOffice versions when handling files with lots of pictures. In Impress however, this is basically making it unusable. In Writer it is pretty annoying but usually there are less pictures involved.

It seems to be even worse currently, I just spend three full days just getting a presentation that worked ready and could only succeed by giving up and removing slides, exporting to PDF and using the PDF for presentation. The Impress file did never show up completly again. BTW: when exporting to PDF Impress tends to crash on the second export, too, so it very much seems as a general problem with filters.
Cheers

T
Comment 5 superurbi 2014-08-05 06:26:43 UTC
Created attachment 104055 [details]
backtrace info when exporting an impress odp to PDF
Comment 6 superurbi 2014-08-05 06:36:05 UTC
Created attachment 104056 [details]
odp test file
Comment 7 superurbi 2014-08-05 06:37:05 UTC
Created attachment 104057 [details]
Computer details used
Comment 8 superurbi 2014-08-05 06:37:49 UTC
It got stuck when exporting to PDF....
Comment 9 superurbi 2014-08-05 06:45:16 UTC
Comment on attachment 104056 [details]
odp test file

Download from this link:
https://drive.google.com/folderview?id=0B1WCyZarWspXRzVBU01OOGtFVzQ&usp=sharing
Comment 10 Buovjaga 2014-11-26 13:10:40 UTC
Exported that Google Drive hosted odp to pdf just fine. Changing to UNCONFIRMED.

Win 7 64-bit Version: 4.5.0.0.alpha0+
Build ID: b144f0ac8695dd62a2053b4e88212d0b109c9a41
TinderBox: Win-x86@51-TDF, Branch:MASTER, Time: 2014-11-25_00:14:54
Comment 11 raal 2014-12-10 08:21:06 UTC
LO 4.3.4, win7.
I can export presentation from comment 9 to PDF without crash. 

I used this presentation and added new pictures and I can confirm "Bad allocation" warning and crash.
Steps to reproduce
 - open presentation from comment 9
 - menu Insert -> Picture -> Photo album
 -  select lots of photographs
 - import -> "Bad allocation" warning and crash
Comment 12 thorsten.brandau 2014-12-23 17:02:26 UTC
Hi All,

I was working for some days on a report were most of my time was waiting for LibreOffice recovering from the image bugs. Today, I upgraded during work to the latest release 4.3.5 and tell you what: I am very, very happy.

The bug is quite seldom. Not vanished, but seldom. I could work all day on the report, copy, past, move etc. graphics, between files etc. without a single crash.

The bad news: It is not gone. After moving more graphics from one file to another (the session with the files was open all day) and when finally exporting to PDF - Bad Allocation error.

If worked after recovering, although the last changes before crash were not saved.

If the bug is restricted to PDF Export, I may get around it by using a PDF printer, but it would be nice if that one gets fixed, too.

I would love to send you the test document, but due to the confidential nature this will not be possible...
Comment 13 raal 2015-04-21 18:39:27 UTC
*** Bug 90715 has been marked as a duplicate of this bug. ***
Comment 14 raal 2015-05-02 18:18:42 UTC
*** Bug 90196 has been marked as a duplicate of this bug. ***
Comment 15 Armin Le Grand 2015-11-12 14:37:17 UTC
Tried on win7, LO .
Can load doc from comment 9, can export to PDF, all content there. Added slides and pics, works well. Used slidesorter to rearrange, works well. Changed slides toobar width (to make re-render slides, you can see one after the other getting sharp), woorks well. Same with slide sorter. Used slideshow and presenter in various modes, works well. Used save as (takes time), worked well. Used reaload, works well.
Ended office, crash in the debugger (not visible without).
Office restart, load, export PDF, works well, no data lost.
It may be that with the 32bit versions (e.g. win) there was a problem in-between with graphics swapping in/out, not too long ago, but that is fixed.

@thorsten: Did you use a 32bit version of LO? Have you tried a current version (5)? Have you tried the 64bit win version?
Comment 16 thorsten.brandau 2015-11-12 15:50:04 UTC
@Armin:
I am using LO under windows installing whatever I am downloading when going to the homepage. I don't see if it is X32 or X64, but I would suppose it is the 32bit version.
Currently using 5.0.2 which is somewhat more stable, but still crashes quite frequently.
Comment 17 Cor Nouws 2015-11-12 16:43:43 UTC
(In reply to thorsten.brandau from comment #2)

> My tested configurations are
> - Windows 7 X64 Professional and Home Premium
> - Intel Core I7 and i5
> - 8GB Ram
> - Discs between 500 and 1000 MB
> - Some configurations with SSD
> - All service packs included
> - Files access locally and via network

Maybe superfluous question: did you try with a fresh user profile?
Any influence from setting of Tools > Options > General > View .. Hardware acceleration and alike (?)
More memory .. Tools > Options > General > Memory ?

thanks!
Cor
Comment 18 thorsten.brandau 2015-11-12 17:31:58 UTC
@Cor:
Yes, several times. Depending on the version it gets worse or better. But it never goes away.
Comment 19 Cor Nouws 2015-11-12 17:47:59 UTC
(In reply to thorsten.brandau from comment #18)

> Yes, several times. Depending on the version it gets worse or better. But it
> never goes away.

Several times what ?
Comment 20 thorsten.brandau 2015-11-12 18:06:14 UTC
@cor
New profile, change of acceleration settings, increasing memory settings, change number of objects to keep in memory.... tried to tweak around here quite a bit. Problems are on different machines (windows, linux) pretty much alike with the documents we work here with. Although the linux version seems to be more stable.
Comment 21 QA Administrators 2017-01-03 19:36:12 UTC Comment hidden (obsolete)
Comment 22 bernie 2017-01-04 23:00:13 UTC
Works for me in Impress Version: 5.1.6.2
Comment 23 Buovjaga 2017-01-05 11:42:34 UTC
raal: you were able to reproduce the crash in comment 11. Is it gone for you now?