Bug 90236 - VIEWING: Crash when using Help and Navigator is set to Active Window
Summary: VIEWING: Crash when using Help and Navigator is set to Active Window
Status: RESOLVED DUPLICATE of bug 88360
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.1.2 release
Hardware: x86-64 (AMD64) All
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace, regression
Depends on:
Blocks:
 
Reported: 2015-03-25 20:02 UTC by Gordo
Modified: 2015-03-31 08:14 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
backtrace (10.45 KB, text/plain)
2015-03-25 20:02 UTC, Gordo
Details
OSX backtrace (76.25 KB, text/plain)
2015-03-30 07:36 UTC, Matthew Francis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gordo 2015-03-25 20:02:21 UTC
Created attachment 114352 [details]
backtrace

1. New Text Document.
2. Have Navigator open (I have it independently docked on left).
3. Help -> LibreOffice Help.
4. In Document (Untitled 1), change to Active Window in Navigator.
Result:
Navigator shows headings, bookmarks, etc from help.
5. In Help window, go to Find tab.
6. Enter something (I chose "formatting").
7. Double click on one of the items in the list.
Result:
Crash.  AutoRecovery when application restarted.

Version: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Comment 1 A (Andy) 2015-03-25 22:03:37 UTC
Reproducible with LO 4.4.1.2, Win 8.1
Comment 2 Matthew Francis 2015-03-30 07:36:03 UTC
Created attachment 114455 [details]
OSX backtrace

Also crashes on OSX with a pretty identical looking backtrace
Comment 3 Matthew Francis 2015-03-30 07:38:03 UTC
Setting to Platform: All, although this isn't reproducible on Linux (which seems to use the system web browser for help)
Comment 4 Matthew Francis 2015-03-30 07:42:22 UTC
Apparently the choice of inbuilt help or not is controlled by ./autogen.sh --with-help, and it may not be built by distribution packagers (or just not installed by default?) on Linux, hence the difference. So this probably could be reproduced on Linux if configured correctly
Comment 5 Matthew Francis 2015-03-30 08:23:11 UTC
I can't reproduce this on 4.3, so it appears to be a regression.

Unfortunately the bibisect trees are built --without-help, but I'll have a go at bisecting it manually
Comment 6 Matthew Francis 2015-03-31 08:14:32 UTC
Same cause as bug 88360

*** This bug has been marked as a duplicate of bug 88360 ***