Bug 90269 - "Insert – Special Character..." does not show the correct font when using graphite font features
Summary: "Insert – Special Character..." does not show the correct font when using gra...
Status: RESOLVED DUPLICATE of bug 56363
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevEval
Depends on:
Blocks:
 
Reported: 2015-03-26 20:39 UTC by Pierre C
Modified: 2016-08-14 13:04 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
texm in font name (2.68 KB, image/png)
2015-04-02 08:42 UTC, Pierre C
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pierre C 2015-03-26 20:39:40 UTC
Step to reproduce

1 Create a new doc with writer

2 Choose font : Linux Libertine G:texm=1

3 Type some text

4 Click on insert special chart 

=> The preselected font is Sergoe UI

Expected behaviour :

it should be : Linux Libertine G:texm=1 or at least Linux Libertine G

Pierre
Comment 1 Buovjaga 2015-04-02 07:50:47 UTC
No such problem for me with Linux Libertine G.

What is texm=1?
Do you really use LibreOffice version 3.6? Please test with 4.4.x and report here.

Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists. Change to RESOLVED WORKSFORME, if the problem went away.

Win 7 Pro 64-bit, LibO Version: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Locale: fi_FI

Version: 4.5.0.0.alpha0+
Build ID: 8c3cf9dd48e40604867d3a28bddaccd65142df17
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-03-27_15:15:18
Locale: fi_FI
Comment 2 Pierre C 2015-04-02 08:42:38 UTC
Created attachment 114546 [details]
texm in font name

What the font selector should be
Comment 3 Pierre C 2015-04-02 08:43:14 UTC
@Beluga

I think you did not follow exactly step 2 to reproduce the bug

You must see "Linux Libertine G:texm=1" in your font selector.

To do so you have to *manually* add ":texm=1" after the font name. 

So that you can use graphite's special features

If you want to know what texm = 1 is for, just type :

SO_4^2^- 

If nothing happens, then texm is not active. If something happens, then try to do the same without this feature.
Comment 4 Pierre C 2015-04-02 08:46:12 UTC
@Beluga.

Of course I don't use LibreOffice 3.6 but the bug is present in this version. And is still present in latest master, 4.4 and 4.3

If I remember well. 3.6 is the libreoffice version that firstly include graphite features
Comment 5 Buovjaga 2015-04-02 09:54:54 UTC
Reproduced. Pre-selected font in special char. was Tahoma.

Lowering priority as this is just an annoyance: https://wiki.documentfoundation.org/images/0/06/Prioritizing_Bugs_Flowchart.jpg

Win 7 Pro 64-bit Version: 4.5.0.0.alpha0+
Build ID: 8c3cf9dd48e40604867d3a28bddaccd65142df17
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-03-27_15:15:18
Locale: fi_FI
Comment 6 Pierre C 2015-04-02 10:08:28 UTC
Thanks Beluga for reproducing the bug.

yes it is just an annoyance, but it should be easy to solve, maybe an easyhack candidate here ?
Comment 7 Matthew Francis 2015-04-07 05:56:17 UTC
In fact, LO has supported this feature from the beginning. The issue is present in both OOo and LO 3.3.0

-> Version: Inherited from OOo
Comment 8 Robinson Tryon (qubit) 2015-12-13 11:21:33 UTC Comment hidden (obsolete)
Comment 9 Pierre C 2016-08-14 13:03:33 UTC

*** This bug has been marked as a duplicate of bug 56363 ***