Download it now!
Bug 90333 - LibreOffice Dictionaries Path Cannot Be Changed
Summary: LibreOffice Dictionaries Path Cannot Be Changed
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.3.0 target:6.2.0.1 target:6.1.5
Keywords: bibisected, bisected, implementationError, regression
: 111883 113593 121403 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-03-29 20:58 UTC by bugzilla
Modified: 2019-02-26 16:44 UTC (History)
14 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bugzilla 2015-03-29 20:58:24 UTC
I'm trying to change the default Writer dictionaries path, to allow them to be shared more easily with other computers.

The process at first appears to work using - Tools > Options > Paths > Dictionaries > Edit > Add > Select Path > Click on radio button > OK.

Double-checking the settings immediately after shows the original and the new path listed correctly. However after closing Writer and re-starting, the alternate dictionary path is always missing.

All the other paths (autocorrect, templates etc) DO work ok - it's just the Dictionaries path that refuses to retain the new setting.

I've reproduced this on LO 4.3.6, 4.4.0 and 4.4.1 on Win7 and XP.
Comment 1 Buovjaga 2015-04-04 16:13:07 UTC
Reproduced in all tested versions, except 4.2.0.
I didn't have to close LibO, it was enough to OK from the Options dialog and go back to check.

Win 7 Pro 64-bit, Version: 4.4.2.2
Build ID: c4c7d32d0d49397cad38d62472b0bc8acff48dd6
Locale: fi_FI

Version: 4.5.0.0.alpha0+
Build ID: 8c3cf9dd48e40604867d3a28bddaccd65142df17
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-03-27_15:15:18
Locale: fi_FI

Ubuntu 14.10 64-bit 
Version: 4.2.0.4
Build ID: 05dceb5d363845f2cf968344d7adab8dcfb2ba71

Version: 4.3.5.2
Build ID: 3a87456aaa6a95c63eea1c1b3201acedf0751bd5
Comment 2 Matthew Francis 2015-04-14 14:32:12 UTC
This doesn't seem to have ever worked since it was implemented in the below commit (including in 4.2.0.4 - you have to close the outer options dialog and reopen to see the issue).
Adding Cc: to timar74@gmail.com; Any chance you could take a look at this one? Thanks

commit aecd2510e53ea6457dd4f4fa032d82b7dd6178ef
Author: Andras Timar <atimar@suse.com>
Date:   Thu Aug 8 07:22:57 2013 +0200

    fdo#36558 Allow custom paths for user dictionaries
    
    Change-Id: I7c1e473fb1e874c137cf47a169fd78bf7a842d4e
Comment 3 j.maciejczyk 2015-11-17 13:52:28 UTC
The bug is still present in 5.0.2
Comment 4 Robinson Tryon (qubit) 2015-12-10 10:23:00 UTC Comment hidden (obsolete)
Comment 5 Xisco Faulí 2016-09-26 15:47:37 UTC
Adding Cc: to Andras Timar
Comment 6 bugzilla 2018-07-03 11:23:34 UTC
This bug is still present with LO 6.0.5.2
Comment 7 himajin100000 2018-07-03 13:48:54 UTC Comment hidden (obsolete)
Comment 8 himajin100000 2018-07-03 13:50:51 UTC
ah reproduced for some reason.
Comment 9 himajin100000 2018-07-03 13:55:25 UTC
It seems happening if the default path is listed in the last position, I mean if I left the radio button for the original/default path selected even after adding a new path.

but I don't know what's causing this issue.
Comment 10 himajin100000 2018-07-06 14:45:03 UTC
after resetting profile, what I see is as the reporter says, rather than my comment 9
Comment 11 himajin100000 2018-08-06 08:28:33 UTC
https://opengrok.libreoffice.org/xref/core/cui/source/options/optpath.cxx?r=d4073045#809

after successfully saving the user value, the code seems to throw an exception, bybassing code to save the writable value.

if I comment-out the following line,

Impl->m_xPathSettings->setPropertyValue(sCfgName + POSTFIX_USER, aValue);

the following line correctly saves the "writable" value, but this line also throws an exception. so SAL_INFO placed after this line in try block, that logging will not work.

pImpl->m_xPathSettings->setPropertyValue(sCfgName + POSTFIX_WRITABLE, aValue);

info:salhelper.thread:4024:4008:salhelper/source/thread.cxx:21: launch configmgrWriter
warn:cui.options:4024:4008:cui/source/options/optpath.cxx:831: caught: class com::sun::star::uno::Exception msg: configmgr inappropriate property value

* line number would not be exactly the same as mine, due to some modifications(not fix) on my side.
Comment 12 himajin100000 2018-08-06 08:31:45 UTC
so if I use the official nightly builds, and click the radio button for non-default path, which is used for writable path, it will not appear on next launch of LibreOffice.

I have to completely withdraw my stamement, sorry , condition was completely reversed!
Comment 13 himajin100000 2018-08-06 08:32:34 UTC
typo:
withdraw my stamement in comment 9
Comment 14 himajin100000 2018-11-04 10:13:55 UTC
Self-Reminder:
please note that it would be more difficult to reproduce this bug if you are building your own libreoffice with OSL_DEBUG_LEVEL > 1.

https://opengrok.libreoffice.org/xref/core/cui/source/options/optpath.cxx?r=dfaa7d4d#174
Comment 15 himajin100000 2018-11-23 22:49:14 UTC
I suspect that the following line should be 

https://opengrok.libreoffice.org/xref/core/framework/source/services/pathsettings.cxx?r=8dc6c96a#672

xProps->setPropertyValue(aResubstPath.sPathName, css::uno::Any(OUString("")));

in order to make 

https://opengrok.libreoffice.org/xref/core/configmgr/source/access.cxx?r=80f990b8#1491

value.hasValue() true.

but in this case the dialog for the path selection where radio buttons exists showed three items with an empty string.

want someone's feedback.
Comment 16 Caolán McNamara 2018-11-27 14:25:20 UTC
uno::Any(OUString("") works and uno::Any does not because the Dictionaries element is not allowed to be nillable, but the code seems to assume it is. https://gerrit.libreoffice.org/#/c/64115/ lets it work I think.
Comment 17 Commit Notification 2018-11-28 08:30:01 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/f913bdf712b9e03506b1278e1142283af92125b1%5E%21

tdf#90333 Dictionaries Path Cannot Be Changed

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Caolán McNamara 2018-11-28 08:52:14 UTC
backport to 6-2 in gerrit
Comment 19 Commit Notification 2018-11-28 10:30:20 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/ce7bb69f8205bcbe36cba4c53bd110e07ef3e05d%5E%21

tdf#90333 Dictionaries Path Cannot Be Changed

It will be available in 6.2.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 himajin100000 2018-12-07 00:18:01 UTC
*** Bug 111883 has been marked as a duplicate of this bug. ***
Comment 21 himajin100000 2018-12-07 08:50:00 UTC
*** Bug 121403 has been marked as a duplicate of this bug. ***
Comment 22 Xisco Faulí 2018-12-13 10:27:38 UTC
*** Bug 113593 has been marked as a duplicate of this bug. ***
Comment 23 Commit Notification 2018-12-14 15:43:04 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

https://git.libreoffice.org/core/+/546eadd66ebc319ad8c627186b47c5ead0747009%5E%21

tdf#90333 Dictionaries Path Cannot Be Changed

It will be available in 6.1.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 24 bugzilla 2019-02-26 16:44:00 UTC
Yippee!  Dictionary path setting confirmed as remembered.
Checked using LibreOffice v6.1.5.2 on Linux MintC 19.1 and Win 7.

Good work, thanks to all.