Download it now!
Bug 90376 - Dragging toolbar doesn't clean up after itself
Summary: Dragging toolbar doesn't clean up after itself
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.5.0.0.alpha0+ Master
Hardware: Other All
: highest minor
Assignee: Not Assigned
URL:
Whiteboard: target:6.2.0 target:6.1.3 target:6.0.7
Keywords: bibisected, bisected, regression
: 93275 114244 (view as bug list)
Depends on:
Blocks: Toolbars VCL-Scheduler
  Show dependency treegraph
 
Reported: 2015-03-31 16:42 UTC by Yousuf Philips (jay) (retired)
Modified: 2018-10-17 09:25 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot (257.93 KB, image/png)
2015-03-31 16:42 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2015-03-31 16:42:14 UTC
Created attachment 114502 [details]
screenshot

I noticed if i dragged a floating toolbar that it would not clean up after itself.

This is a regression as it doesnt happen like this in 4.4 daily.

Version: 4.5.0.0.alpha0+
Build ID: 704cf81ebef60a3f9d3f5f78ed24a1fe30c98f92
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2015-03-28_23:41:41

Version: 4.4.3.0.0+
Build ID: 3eba5eb1774ab621a1f0f4dcc7e82cce6c025b0a
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:libreoffice-4-4, Time: 2015-03-27_10:16:19
Comment 1 Buovjaga 2015-04-08 17:23:41 UTC
Reproduced.

Win 7 Pro 64-bit Version: 4.5.0.0.alpha0+
Build ID: 8c3cf9dd48e40604867d3a28bddaccd65142df17
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-03-27_15:15:18
Locale: fi_FI
Comment 2 Matthew Francis 2015-04-15 01:53:27 UTC
This began at the below commit.
Adding Cc: to tobias.madl.dev@gmail.com; Could you possibly take a look at this one? Thanks

(Note: To reproduce, drag the internal part of an undocked toolbar window, not the outer window manager decoration)

    commit 5748d6bad2e16673bed50374a7d8e1f4ba0fc7fc
    Author:     Tobias Madl <tobias.madl.dev@gmail.com>
    AuthorDate: Mon Mar 9 16:08:09 2015 +0000
    Commit:     Tobias Madl <tobias.madl.dev@gmail.com>
    CommitDate: Mon Mar 9 16:08:09 2015 +0000
    
        Scheduler: wrong priority order
    
        Change-Id: Ia2a50922fdfe07ff452bcc78b973d5d4943a128c
Comment 3 Michael Meeks 2015-05-16 17:34:09 UTC
Might also be interesting to Tomaz.
Comment 4 tommy27 2015-07-22 20:08:39 UTC
I'm not seeing it under Win8.1 x64 using LibO 5.1.0.0.alpha1+ (x64)
Build ID: 591238e8a4f1164adb51d3bada0cd90c3e7c655e
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-07-22_00:03:41
Locale: en-US (it_IT)

would you please guys retest if it's gone for good?
Comment 5 tommy27 2015-07-23 08:46:54 UTC
... but I see it again under Win7 x64 using LibO 5.1.0.0.alpha1+ (x64)
Build ID: e92a8b92072284fd7c37d7bb3e1e8fe72a185f35
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-07-22_21:46:26
Locale: it-IT (it_IT)

I'll retest later on the Win8.1 machine.
Comment 6 Buovjaga 2015-07-23 09:07:41 UTC
Yeah I see it still.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+ (x64)
Build ID: e92a8b92072284fd7c37d7bb3e1e8fe72a185f35
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-07-22_21:46:26
Locale: fi-FI (fi_FI)
Comment 7 tommy27 2015-07-23 18:12:09 UTC
retested again as promised in comment 5
I confirm the bug is present in Win7x64 but is not present in Win8.1x64
so not all the Windows versions are affected
Comment 8 Maxim Monastirsky 2015-08-08 19:03:51 UTC
*** Bug 93275 has been marked as a duplicate of this bug. ***
Comment 9 Javi Barroso 2015-08-09 19:58:11 UTC
At Debian Sid (5.0.1~rc1-1) this bug happens again

Regards,
Comment 10 Robinson Tryon (qubit) 2015-12-13 11:12:23 UTC Comment hidden (obsolete)
Comment 11 Muhammet Kara 2017-09-18 17:39:55 UTC
I couldn't reproduce this with current master on Debian Stretch / Pardus 17.

Version: 6.0.0.0.alpha0+
Build ID: afeff9102c2935139de4efd40fd2286dce396706
CPU threads: 8; OS: Linux 4.9; UI render: default; VCL: gtk3; 
Locale: tr-TR (en_US.UTF-8); Calc: group
Comment 12 Yousuf Philips (jay) (retired) 2017-09-18 18:10:16 UTC
Yes it doesnt happen on gtk3

Version: 6.0.0.0.alpha0+
Build ID: dd5868409ae430f9c9ffea18ea7e287a65cfa2ab
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); Calc: group

but does on gtk2

Version: 6.0.0.0.alpha0+
Build ID: 7315f325ff7ada3d6bd85a471058fdaeaff8cdb0
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-09-17_06:58:21
Locale: en-US (en_US.UTF-8); Calc: group
Comment 13 Maxim Monastirsky 2017-12-16 21:33:28 UTC
*** Bug 114244 has been marked as a duplicate of this bug. ***
Comment 14 Buovjaga 2017-12-17 09:18:34 UTC
Still repro on Win 7

Version: 6.1.0.0.alpha0+ (x64)
Build ID: 77adb770164fd703a31d8e828d777a4f827a5407
CPU threads: 4; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2017-12-17_03:10:29
Locale: fi-FI (fi_FI); Calc: CL
Comment 15 Commit Notification 2018-08-27 06:14:35 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=afd49c198769b5e7fc01a68ce7a6847aa0d0ddd8

tdf#90376 revert the dock windows' Idles to Timers

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2018-09-20 15:45:04 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e3a745f7604b084a7bb5fb6f18d5b50b5e137a98&h=libreoffice-6-1

tdf#90376 revert the dock windows' Idles to Timers

It will be available in 6.1.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 BogdanB 2018-09-27 04:26:38 UTC
Fixed in 6.2

Version: 6.2.0.0.alpha0+
Build ID: 66232248ff55639052ddb76918d555e21dc9c46b
CPU threads: 4; OS: Linux 4.15; UI render: GL; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-09-20_19:40:04
Locale: ro-RO (ro_RO.UTF-8); Calc: threaded
Comment 18 Commit Notification 2018-10-16 09:01:50 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8fe6de4886e2b44c73a423bae41e15011b2be055&h=libreoffice-6-0

tdf#90376 revert the dock windows' Idles to Timers

It will be available in 6.0.8.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Commit Notification 2018-10-17 08:25:01 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "libreoffice-6-0-7":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=710fcc32b6371be86ab05414aa7b09a1079c24ae&h=libreoffice-6-0-7

tdf#90376 revert the dock windows' Idles to Timers

It will be available in 6.0.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.