Download it now!
Bug 90484 - FILEOPEN: Name Conflict - Name cannot be the same as a built-in name.
Summary: FILEOPEN: Name Conflict - Name cannot be the same as a built-in name.
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.4.2.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
: 96170 (view as bug list)
Depends on:
Blocks: XLSX-Corrupted
  Show dependency treegraph
 
Reported: 2015-04-06 19:36 UTC by AdamD.
Modified: 2017-11-29 04:27 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Name cannot be the same as a built-in name (25.97 KB, image/png)
2015-04-06 19:36 UTC, AdamD.
Details
Sample affected file. (12.00 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2015-04-07 20:34 UTC, AdamD.
Details
names in LO (96.37 KB, image/png)
2015-04-08 20:36 UTC, raal
Details
excel 2010 name manager (32.42 KB, image/png)
2015-04-08 20:39 UTC, raal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description AdamD. 2015-04-06 19:36:13 UTC
Created attachment 114653 [details]
Name cannot be the same as a built-in name

Running the release version (did not see in the version list):
4.4.2.2
Build ID: c4c7d32d0d49397cad38d62472b0bc8acff48dd6
Locale: en_US

The file in questions is an Excel-created .xlsx (2007/2013), which contains filter-enabled columns. If the file is opened in Calc, and a filter is applied, and the file is saved, it appears to alter some internal names of the file. When re-opening the file again in Excel, you're prompted to rename them: "Name cannot be the same as a built-in name. Old name: _FilterDatabase_0". I have attached an example of one of these messages.

Naming it something else, such as "asdf", works fine, until the file is opened, filtered, and saved in Calc again. Upon opening in Excel again, you're hit again with the same issue, and a different name is again required. Calc appears to be mangling something in the file structure.

LibreOffice 4.3.6.2 does not exhibit this behavior with the same file.
Comment 1 AdamD. 2015-04-06 19:37:30 UTC
This may actually be FILESAVE, not FILEOPEN.
Comment 2 raal 2015-04-07 16:25:23 UTC Comment hidden (obsolete)
Comment 3 AdamD. 2015-04-07 20:34:55 UTC
Created attachment 114678 [details]
Sample affected file.

The attached Test File.xlsx is currently in it's 'inconsistent' state; if you open with Excel, it will prompt to rename to those items. I noticed that sometimes it does not always do it, and may take 2-3 openings before it happens. This file had been last saved with LibreOffice Calc.
Comment 4 AdamD. 2015-04-07 20:37:14 UTC
After speaking about this with the person internally who brought up the issue, it seems that it's not only the filtered columns which causes this. They have received the prompts with no filters applied. However, setting these filters appears to be one method I have used to repeatedly trigger it.
Comment 5 raal 2015-04-08 19:55:42 UTC
(In reply to AdamD. from comment #3)
> Created attachment 114678 [details]
> Sample affected file.

What's the password of the  file?
Comment 6 AdamD. 2015-04-08 19:56:22 UTC
I'm sorry, I forgot to put that in. It's "testfile".
Comment 7 raal 2015-04-08 20:36:49 UTC
Created attachment 114691 [details]
names in LO

As you can see in Name manager these names exist. You can delete them and then you can open file in excel without message.
Comment 8 raal 2015-04-08 20:39:02 UTC
Created attachment 114692 [details]
excel 2010 name manager

excel's bug / even after rename, excel doesn't delete _FilterDatabase_0 (new_name)
Comment 9 raal 2015-04-08 20:40:37 UTC
Closing as notabug.
Comment 10 Buovjaga 2015-12-01 10:10:42 UTC
*** Bug 96170 has been marked as a duplicate of this bug. ***