Bug 90505 - Enable access to .uno:Polygon in Writer and Calc
Summary: Enable access to .uno:Polygon in Writer and Calc
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.5.0.0.alpha0+ Master
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevEval
Depends on:
Blocks: UNO-Command
  Show dependency treegraph
 
Reported: 2015-04-07 20:12 UTC by Yousuf Philips (jay)
Modified: 2016-08-08 14:39 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) 2015-04-07 20:12:56 UTC
There are four polygon uno commands - .uno:Polygon_Unfilled, .uno:Polygon, .uno:Polygon_Diagonal_Unfilled, .uno:Polygon_Diagonal - and .uno:Polygon is available in Impress and Draw, but not for Writer and Calc.
Comment 1 Robinson Tryon (qubit) 2015-04-17 20:04:57 UTC
(In reply to Jay Philips from comment #0)
> There are four polygon uno commands - .uno:Polygon_Unfilled, .uno:Polygon,
> .uno:Polygon_Diagonal_Unfilled, .uno:Polygon_Diagonal - and .uno:Polygon is
> available in Impress and Draw, but not for Writer and Calc.

Sounds pretty reasonable (status -> NEW). Does this need attention by anyone in particular (who should be in cc?)

Status -> NEW
Comment 2 Yousuf Philips (jay) 2015-04-17 23:00:42 UTC
(In reply to Robinson Tryon (qubit) from comment #1)
> Sounds pretty reasonable (status -> NEW). Does this need attention by anyone
> in particular (who should be in cc?)

Not sure who to CC, so i've set it to needDevEval. I would assume this should be something minuscule to fix as .uno:Polygon_Unfilled is available.
Comment 3 Robinson Tryon (qubit) 2015-12-13 11:21:23 UTC Comment hidden (obsolete)
Comment 4 Gülşah Köse 2016-01-07 12:36:41 UTC
(In reply to Yousuf (Jay) Philips from comment #0)
> There are four polygon uno commands - .uno:Polygon_Unfilled, .uno:Polygon,
> .uno:Polygon_Diagonal_Unfilled, .uno:Polygon_Diagonal - and .uno:Polygon is
> available in Impress and Draw, but not for Writer and Calc.

It seems fixed opengrok.libreoffice.org/xref/core/sw/uiconfig/swriter/toolbar/drawbar.xml#28
Comment 5 Yousuf Philips (jay) 2016-01-19 09:36:12 UTC
(In reply to Gülşah Köse from comment #4)
> It seems fixed
> opengrok.libreoffice.org/xref/core/sw/uiconfig/swriter/toolbar/drawbar.xml#28

The issue isnt with .uno:Polygon being in the toolbar xml, it is that if it is in the toolbar, its not accessible/functional.
Comment 6 Gülşah Köse 2016-02-28 22:08:10 UTC
Fixed in 89646