Bug 90509 - DrawingML: OOXML Triangles become Isosceles trapezoids
Summary: DrawingML: OOXML Triangles become Isosceles trapezoids
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
4.4.3.2 release
Hardware: Other All
: medium normal
Assignee: Andras Timar
URL:
Whiteboard: target:5.0.0
Keywords: regression
Depends on:
Blocks:
 
Reported: 2015-04-08 00:05 UTC by Luke
Modified: 2016-04-24 16:36 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Word 2013 .DOCX (18.50 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2015-04-08 00:05 UTC, Luke
Details
Word 2003 format (39.00 KB, application/msword)
2015-04-08 00:06 UTC, Luke
Details
Screenshot comparing Word 2013 vs One Drive vs Writer 4.5 (227.53 KB, image/png)
2015-04-08 23:06 UTC, Luke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2015-04-08 00:05:58 UTC
Created attachment 114683 [details]
Word 2013 .DOCX

Steps to reproduce:
1. Open Smart Art2013.docx
2. Smart Art2013.doc
3. Compare

The two documents should look identical.
Comment 1 Luke 2015-04-08 00:06:29 UTC
Created attachment 114684 [details]
Word 2003 format
Comment 2 Julien Nabet 2015-04-08 13:46:35 UTC
On which LO version are you + which env?
Comment 3 Julien Nabet 2015-04-08 19:04:31 UTC
Luke: the second attachment contains indeed trapezoid not triangles.
I uncompressed the docx (since it's just a zip) and these 2 files contain "trapezoid" (after reformating xml):
drawing1.xml:19:        <a:prstGeom prst="trapezoid">
drawing1.xml:98:        <a:prstGeom prst="trapezoid">
drawing1.xml:177:        <a:prstGeom prst="trapezoid">
layout1.xml:156:              <dgm:shape type="nonIsoscelesTrapezoid" xmlns:r="http://schemas.openxmlformats.org/officeDocument/2006/relationships" r:blip="">
layout1.xml:171:              <dgm:shape type="nonIsoscelesTrapezoid" xmlns:r="http://schemas.openxmlformats.org/officeDocument/2006/relationships" r:blip="" hideGeom="1">
layout1.xml:196:          <dgm:shape type="trapezoid" xmlns:r="http://schemas.openxmlformats.org/officeDocument/2006/relationships" r:blip="">

Also, I opened the first attachment, saved it in docx, there are still triangles when reopening the new file.

All these tests have been made on pc Debian x86-64 with master sources (future 5.0.0) updated today.
Comment 4 Luke 2015-04-08 23:06:13 UTC
Created attachment 114693 [details]
Screenshot comparing Word 2013 vs One Drive vs Writer 4.5

They're probably using the trapezoid container because you can represent a triangle by drawing a trapezoid with a shared vertex. If you want to verify what the document should look like, you can use free service: One Drive.

When I converted the 2013 doc to 2003, Word warns that the vector graphics will be converted to bitmaps, so it's no surprise that the .doc doesn't have any issues with conversions.
Comment 5 Luke 2015-05-15 23:08:08 UTC
Julien, 
This example comes from a default clip art that comes with Word 2013 and is a Native word doc. It's not even a graphic that I created.

Are you having trouble reproducing this issue? Just open attachment 114683 [details] in Writer 4.4+ and compare the results to Word or OneDrive.

Did I sufficiently answer your question?
Comment 6 Julien Nabet 2015-05-16 08:35:12 UTC
I'll give it a new try when the build on my machine be over.
Thank you for your feedback.
Comment 7 A (Andy) 2015-05-16 10:36:07 UTC
Different shapes are for me reproducible with LO 4.4.3.2, Win 8.1:
If I open the doc and docx attachment with LO then the doc and docx look different as seen in the attached screenshot.
If I open both files with WORD then they are equal (like the doc in LO).

If I save the doc file as a docx in LO then this docx looks like the doc file in LO and in WORD -> therefore no issue.
Comment 8 Andras Timar 2015-05-21 13:49:34 UTC
It is OK 4.2, so it is a regression. I think it is related to bug 91429, the adjustment parameters are not correctly used.
Comment 9 Andras Timar 2015-05-23 16:11:27 UTC
The fix for bug 91429 fixed this bug as well.
Comment 10 Luke 2015-05-23 22:52:48 UTC
Verified fixed in Version: 5.1.0.0.alpha1+
Build ID: 5122f3c5459d9b4053485241292728cd770cbaf8

Excellent work, Andras. Thank you!
Comment 11 Jean-Baptiste Faure 2016-04-24 16:36:57 UTC
Version set from comment #7.

Best regards. JBF