Bug Hunting Session
Bug 90567 - Insert/add comment with right click on Writer
Summary: Insert/add comment with right click on Writer
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: ux-advise (show other bugs)
Version:
(earliest affected)
4.5.0.0.alpha0+ Master
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-04-11 14:43 UTC by Julien Nabet
Modified: 2015-12-27 18:26 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Julien Nabet 2015-04-11 14:43:10 UTC
On pc Debian x86-64 with master sources updated yesterday, I noticed that Calc had the option "Insert comment" when there was no comment on a cell and had the options "Delete comment"/"Show comment"/"Hide comment" if there's a comment.

Current behaviour:
no comment management with right click on Writer (or missed it?).

Expected behaviour:
Comment management present in right click dialog on Writer
Comment 1 Julien Nabet 2015-04-11 14:43:35 UTC
ux-team: thought you might be interested in this one.
Comment 2 Heiko Tietze 2015-04-11 18:38:42 UTC
Agreed, consistency is one of the major goals of usability. However, if we include all functionality into the context menu we clutter this list (LO fresh: 11 top-level entries in Writer, 10 in Calc plus comment stuff). So I would rather recommend to remove the comment functions from all context menus and have access to it from either the the sidebar or the toolbar. This could be integrated with 'track changes' perhaps.
Comment 3 Heiko Tietze 2015-04-11 18:42:18 UTC
See #87695 for ideas on improvements to new track changes sidebar tab.
Comment 4 Yousuf Philips (jay) (retired) 2015-04-12 07:50:54 UTC
(In reply to Julien Nabet from comment #0)
> On pc Debian x86-64 with master sources updated yesterday, I noticed that
> Calc had the option "Insert comment" when there was no comment on a cell and
> had the options "Delete comment"/"Show comment"/"Hide comment" if there's a
> comment.

Yes a comment is a feature of a spreadsheet cell.

> Current behaviour:
> no comment management with right click on Writer (or missed it?).

Are you referring to right-clicking on the selected area of a comment in a document or right-clicking on a comment in the comment column on the right?

Presently there is a right-click context menu when on a comment, which gives you options to delete it. I've suggested that we add some additional buttons to the comments for delete and reply (bug 89232 comment 6).
Comment 5 Julien Nabet 2015-04-12 07:57:57 UTC
(In reply to Jay Philips from comment #4)
> (In reply to Julien Nabet from comment #0)
...
> > Current behaviour:
> > no comment management with right click on Writer (or missed it?).
> 
> Are you referring to right-clicking on the selected area of a comment in a
> document or right-clicking on a comment in the comment column on the right?
> 
> Presently there is a right-click context menu when on a comment, which gives
> you options to delete it. I've suggested that we add some additional buttons
> to the comments for delete and reply (bug 89232 comment 6).
In fact, I was talking about selecting a word or group of words then right click on them.
BTW, indeed, I hadn't noticed the deleting options when right clicking on comment :-)
Comment 6 Yousuf Philips (jay) (retired) 2015-04-12 08:36:44 UTC
(In reply to Julien Nabet from comment #5)
> In fact, I was talking about selecting a word or group of words then right
> click on them.

If comments were exclusively linked to words in a document, then it might make sense to have the option to delete the comment from the context menu, but you can have comments that overlap each other so right clicking in the overlapping area wouldnt know which comment would be managed, which is why comment management is left to the comment column. In Calc, a cell can only have a single comment.

> BTW, indeed, I hadn't noticed the deleting options when right clicking on
> comment :-)

:D

So i would recommend closing this.
Comment 7 Julien Nabet 2015-04-12 08:41:23 UTC
Ok for deleting comments but for adding/insert comments? (by definition, you can't have in comments column since the comment doesn't exist in this case)
Comment 8 mahfiaz 2015-04-12 08:54:41 UTC
Right now I don't find a way to get to edit existing comment when one cannot use mouse (blind people), this could be fixed with context menu, so I'd like to have opinions about this.


Delete option for overlapping comments could be fixed by having a submenu under delete with short comment text, but I'd still prefer not to have it).

Also I think we shouldn't remove comment options from Calc cells' context menu (under the banner of consistency).


Julien, I hope you have discovered the shortcut for inserting comment.
Comment 9 Yousuf Philips (jay) (retired) 2015-04-12 09:01:18 UTC
(In reply to Julien Nabet from comment #7)
> Ok for deleting comments but for adding/insert comments? (by definition, you
> can't have in comments column since the comment doesn't exist in this case)

I had initially thought of the same thing a long time ago as MSO and Google Docs provide easy access to add a comment and hyperlink from the context menu, but at that time, there wasnt easy access to insert a comment from the toolbar, which there is now.

(In reply to mahfiaz from comment #8)
> Right now I don't find a way to get to edit existing comment when one cannot
> use mouse (blind people), this could be fixed with context menu, so I'd like
> to have opinions about this.

It would be good to get input about this issue from an a11y user.

> Also I think we shouldn't remove comment options from Calc cells' context
> menu (under the banner of consistency).

Definitely.
Comment 10 Robinson Tryon (qubit) 2015-04-17 20:01:00 UTC
(In reply to Julien Nabet from comment #1)
> ux-team: thought you might be interested in this one.

ux-advise: Status -> NEw
Comment 11 Julien Nabet 2015-12-27 18:26:45 UTC
No need to let it rot, let's close this one