Download it now!
Bug 90602 - Paste As Nested Table OR Section Rows
Summary: Paste As Nested Table OR Section Rows
Status: RESOLVED DUPLICATE of bug 37156
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Tables-Enhancements
  Show dependency treegraph
 
Reported: 2015-04-14 05:57 UTC by tholral
Modified: 2019-12-13 11:09 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tholral 2015-04-14 05:57:10 UTC
When pasting an entire table X into another table Y, the contents of table X are distributed across all of table X's cells instead of being nested.

While there is already a way to arrange tables in neat columns using sections, nested tables are the only way to arrange them in rows. The only way to nest one table when pasting into another as far as I know is to manually recreate another table within table Y with the same dimensions as table X and paste into that one. This is too tedious when I am making large changes to a document!

If there were a way to convert section columns to rows and vice-versa, it would be even better.
Comment 1 tholral 2015-04-14 05:58:59 UTC
(In reply to tholral from comment #0)
distributed across all of table X's cells instead of being nested.
That should be "table Y." Oops.
Comment 2 Yousuf Philips (jay) (retired) 2015-04-17 19:17:15 UTC
Hello tholral,

Thank you for submitting the bug. I can confirm that the bug is available in master on Linux.

The problem seems to stem from the fact that libreoffice doesnt select the entire table as a whole and instead selects the table cells, so when its pasted, it pastes the cells.

The one way to work around this problem is to paste special as RTF, but the table will be inserted at its original size (bug 90682), so you then have to go into the table properties and set the table's width to relative 100%.

Version: 4.5.0.0.alpha0+
Build ID: 25c25f855169c98c30f3f7868fd1ad430e159ddc
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2015-04-14_08:59:23
Comment 3 László Németh 2019-12-13 11:09:14 UTC
There is a quick workaround: set the cursor in a non-starting position in the cell, for example, press Enter or space in an empty cell before choosing paste.

Note: this workaround is not obvious, so the plan is to add a new option for nesting tables in Paste Special...

*** This bug has been marked as a duplicate of bug 37156 ***