Bug Hunting Session
Bug 90644 - Incorrect or confusing Help Link
Summary: Incorrect or confusing Help Link
Status: RESOLVED DUPLICATE of bug 83603
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.3.6.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks:
 
Reported: 2015-04-16 06:34 UTC by Jochen
Modified: 2016-12-20 13:31 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jochen 2015-04-16 06:34:23 UTC
When clicking on Help icon (blue book, questionmark) I am getting routed to https://help.libreoffice.org/scalc/.uno:HelpIndex?Language=en-US&System=UNIX&Version=4.3#bm_id3149178 (or swriter accordingly). Took me a moment to figure out where to get information from wiki. Instead, users should be routed to same page than using F1 (which works fine), i.e. app specific help home page.
Comment 1 Robinson Tryon (qubit) 2015-04-19 18:33:38 UTC
(In reply to Jochen from comment #0)
> When clicking on Help icon (blue book, questionmark) I am getting routed to
> https://help.libreoffice.org/scalc/.uno:HelpIndex?Language=en-
> US&System=UNIX&Version=4.3#bm_id3149178 (or swriter accordingly).

Hi,
Testing with 4.3.6.1 on Ubuntu 14.04, I see a life preserver as my link to the Help, which takes me to something very similar:
https://help.libreoffice.org/swriter/.uno%3AHelpIndex?Language=en-US&System=UNIX&Version=4.3#bm_id3149178

> ...users
> should be routed to same page than using F1 (which works fine), i.e. app
> specific help home page.

I'm not sure that this is "incorrect," as described in the Summary. It might be more helpful to have targeted information about the particular component. This sounds like a question for UX-advise to consider.
Component -> UX-advise
Status -> NEW
Comment 2 Buovjaga 2015-04-21 09:52:05 UTC
Blue book w/ questionmark is KDE.
I confirm this even with installed help. In Calc, help menu goes to general help, F1 goes to Calc-specific help.

Kubuntu 14.10
Version: 4.4.2.2
Build ID: 40m0(Build:2)
Locale: en_US
Comment 3 Yousuf Philips (jay) (retired) 2015-04-25 01:33:28 UTC
So i tested Help > LibreOffice Help and that linked to

https://help.libreoffice.org/scalc/.uno:HelpIndex?Language=en-US&System=UNIX&Version=5.0#bm_id3149178

and pressing F1 without help installed linked to

https://help.libreoffice.org/scalc/SC_HID_SC_WIN_GRIDWIN?Language=en-US&System=UNIX&Version=5.0#bm_id3155335

Checking 3.3 and the menu linked to

https://help.libreoffice.org/scalc/start?Language=en&System=UNIX

and pressing F1 linked to

https://help.libreoffice.org/scalc/58818?Language=en&System=UNIX#bm_id3155335

Not sure what to think of this, but a dev would have to look at the F1 part as it should link to the same thing as the menu entry has F1 listed as its keyboard shortcut.
Comment 4 Robinson Tryon (qubit) 2016-08-25 05:26:48 UTC Comment hidden (obsolete)
Comment 5 Gabor Kelemen 2016-12-20 13:31:33 UTC

*** This bug has been marked as a duplicate of bug 83603 ***