Download it now!
Bug 90745 - EDITING: formula autocorrection
Summary: EDITING: formula autocorrection
Status: CLOSED DUPLICATE of bug 57210
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.4.1.2 release
Hardware: All All
: low enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: AutoCorrect-Complete
  Show dependency treegraph
 
Reported: 2015-04-20 14:35 UTC by Matthew Millar
Modified: 2016-10-19 23:10 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matthew Millar 2015-04-20 14:35:25 UTC
Improve UX by enhancing the formula error correction handler to autocorrect constants according to the context of a formula.
Comment 1 Matthew Millar 2015-04-20 14:37:50 UTC
The particular formula autocorrection I'm interested in is:
- Automatically removing numerical seperator marks from a calculation; e.g. thousand markers: =2*1,302 would be autocorrected to =2*1303.

This can be easily identified and corrected according to the context of the forumla.
i.e. there isn't another reason a comma would be included in this formula, since it doesn't comprise of a more complicated statement.
Comment 2 Robinson Tryon (qubit) 2015-04-23 14:10:07 UTC
(In reply to Matthew Millar from comment #1)
> - Automatically removing numerical seperator marks from a calculation; e.g.
> thousand markers: =2*1,302 would be autocorrected to =2*1303.

Jay: Something for UX to discuss, or a decision to be made on more technical level?
Comment 3 raal 2015-04-23 15:24:44 UTC
2*1,302 = 2,604
in my country is "," delimiter, so should be language specific. Also empty " " is used as visual delimiter (1 302)

Comma is also delimiter in functions. 

Do you expect silent autocorrect, error warning like in excel or error sign on cell like in excel ?
Comment 4 Matthew Millar 2015-04-23 15:50:25 UTC
(In reply to raal from comment #3)
> Do you expect silent autocorrect, error warning like in excel or error sign
> on cell like in excel ?

The appearance of the autocorrection can probably be according to a classification of percentage of accuracy, e.g. calculated accuracy of interpretted intension;
perhaps:
>98% - autocorrect with a comment-styled indicator
>94% - autocorrect with a flash and comment-styled indicator
>90% - autocorrect with a dialog to confirm

Example:
=if(A2=A1,1.2)
Possible scenerios:
1.2 was intended; - place comma before or after 1.2?
1,2 was intended;

Note: It would be necessary to ensure the autocorrection only executes after a user edit and on constants, not variables.
Comment 5 Yousuf Philips (jay) (retired) 2015-04-27 00:05:03 UTC
Qubit: I believe this is a technical issue.
Comment 6 Joel Madero 2015-10-17 17:07:59 UTC
This is a reasonable request -

Currently if you do "=2*1,000" you get an error which isn't anticipated. Of course corner cases would have to be looked at and locales dealt with appropriately.

That being said, please note that enhancements are almost entirely tackled by volunteers. Thus we give no ETA or guarantee that the suggestion will ever be implemented (it's up to a volunteer finding it to be interesting). This particular one does not seem all that exciting so it might be awhile (or never really) before it's considered by a volunteer.

Thanks for the suggestion.
Comment 7 Eike Rathke 2016-05-31 12:34:18 UTC
If the function parameter separator is comma it takes precedence over a comma group separator. Effectively an input of =2*1,000 is sequenced as {2}{*}{1}{,}{000} which is an invalid expression so generates an error. If the parameter separator is semicolon the sequence is {2}{*}{1,000} and the number 1000 accepted. Also note that auto-correction depends on context, =2*1,234 would need different treatment than =SUM(2*1,234) where it is actually two arguments to SUM.

If you desperately need that auto-correction often just use semicolon as function parameter separator (Tools-Options-Calc-Formula-Separators).

Implementation of such a feature likely ranks at the very low end.
Comment 8 Eike Rathke 2016-05-31 15:45:01 UTC

*** This bug has been marked as a duplicate of bug 57210 ***