Bug 90785 - relative font size (style:font-size-rel) has no effect
Summary: relative font size (style:font-size-rel) has no effect
Status: RESOLVED DUPLICATE of bug 90804
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.1.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2015-04-22 14:09 UTC by Joe Smith
Modified: 2015-08-16 00:11 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample document (10.37 KB, application/vnd.oasis.opendocument.text)
2015-04-22 14:10 UTC, Joe Smith
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joe Smith 2015-04-22 14:09:01 UTC
Creating a style with relative font size +6pt has no effect.

Open the attached bug doc.

Expected: 1st pp 12pt, 2nd pp 18pt, 3rd pp 18pt

Correct behavior with LO 4.3.6.2 (the current Fedora package);

With LO 4.4.1.2: 2nd pp 12pt, should be same as 3rd paragraph

The setting is stored in the document:

<style:style ...
  <style:text-properties ... style:font-size-rel="6pt" ...
</style:style>

and is handled correctly by LO 4.3.6.2 and AOO 4.1.1, but NOT by LO 4.4.1.2
Comment 1 Joe Smith 2015-04-22 14:10:02 UTC
Created attachment 115006 [details]
Sample document
Comment 2 Buovjaga 2015-04-25 13:45:12 UTC
5.0 bad, 4.2 good. Marking as regression.

Win 7 Pro 64-bit Version: 5.0.0.0.alpha1+ (x64)
Build ID: f3375fa07f27bd2ade519af3c07d69040d10eaa9
TinderBox: Win-x86_64@42, Branch:master, Time: 2015-04-22_23:38:50
Locale: fi_FI

Ubuntu 15.04 64-bit 
Version: 4.2.7.2
Build ID: 933c0aa564ec4f8883ed5732c866db48dca4dac5
Comment 3 Matthew Francis 2015-08-16 00:10:57 UTC
Fixed in commit 7f4230675c6c78ebea8b6db3f3612e3ef6fb23df

*** This bug has been marked as a duplicate of bug 90804 ***