Download it now!
Bug 90877 - Chart colors change on OOXML round trip
Summary: Chart colors change on OOXML round trip
Status: RESOLVED DUPLICATE of bug 90876
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.5.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks: OOXML-Chart
  Show dependency treegraph
 
Reported: 2015-04-26 09:33 UTC by Luke
Modified: 2015-12-17 08:59 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Original Word 2013 Chart (14.84 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2015-04-26 09:33 UTC, Luke
Details
Original on the Left, round-trip on the right (140.04 KB, image/png)
2015-04-26 09:35 UTC, Luke
Details
Original on the Left, round-trip on the right (161.69 KB, image/png)
2015-04-26 09:37 UTC, Luke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2015-04-26 09:33:36 UTC
Created attachment 115115 [details]
Original Word 2013 Chart

Steps to reproduce:
1. In Word create a bar chart
2. Save
3. Open in Writer
4. Save as DOCX
5. Close 
6. Open the new file in Writer

Note how the colors of the bars have all changed. In Calc, the colors stay on the series.
Comment 1 Luke 2015-04-26 09:35:07 UTC
Created attachment 115116 [details]
Original on the Left, round-trip on the right
Comment 2 Luke 2015-04-26 09:37:51 UTC
Created attachment 115117 [details]
Original on the Left, round-trip on the right
Comment 3 raal 2015-04-26 10:05:48 UTC
I can confirm with Version: 5.0.0.0.alpha1+
Build ID: e9fbe1f7cd28de2a9da8089d89e903406165eb56
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-04-25_00:20:28

No problem in LO 4.3.3 -> regression

@Luke, what's your version of LO? If <5, then change field Version accordingly.
Comment 4 Luke 2015-04-26 21:26:24 UTC
Adding Markus as he's in the midst of fixing up the OOXML chart import/export code.
Comment 5 Markus Mohrhard 2015-05-03 04:42:57 UTC

*** This bug has been marked as a duplicate of bug 90876 ***
Comment 6 Robinson Tryon (qubit) 2015-12-17 08:59:17 UTC
Migrating Whiteboard tags to Keywords: (bibisectRequest)
[NinjaEdit]