Bug 90912 - Print selection of table with SUM function gives "Expression is faulty"
Summary: Print selection of table with SUM function gives "Expression is faulty"
Status: RESOLVED DUPLICATE of bug 121962
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-04-28 12:25 UTC by gorgonz
Modified: 2018-12-15 15:43 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
odt with table and sum function (13.94 KB, application/vnd.oasis.opendocument.text)
2015-04-28 12:25 UTC, gorgonz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description gorgonz 2015-04-28 12:25:15 UTC
Created attachment 115162 [details]
odt with table and sum function

Seen in OpenSUSE 13.1 64bit
LibreOffice is Version: 4.3.7.2, Build-ID: 430m0(Build:2)

- create a table with multiple lines and fill one column with numbers, 
- use the SUM function for one column
- select the table and press print (with dialog)

You can see the error in the small preview already Preselected option is to print the whole document, where everything is ok (also in preview).

Now change to option "only selected text" and you will see, that the sum function is calculated to "fehlerhafter Ausdruck" which should be something like "malformed expression" in the english language. This is the text, that will be printed too.

Hints: 

- If you switch again to option "whole document" and back to "selected", then the expression will be calculated.

- Could not see the effect with a fresh document and 3 columns. So i will add the example odt
Comment 1 Buovjaga 2015-04-28 13:01:31 UTC
The error message was only in the print preview (Range: Selection). I tried printing to PDF and it did not print the error message.

Win 7 Pro 64-bit Version: 5.0.0.0.alpha1+ (x64)
Build ID: f0edb677f09ad338e22ac3b5d91497b4479e0b3c
TinderBox: Win-x86_64@42, Branch:master, Time: 2015-04-27_01:54:20
Locale: fi_FI
Comment 2 QA Administrators 2016-09-20 09:32:44 UTC Comment hidden (obsolete)
Comment 3 Timur 2018-12-07 16:17:59 UTC
Repro 6.3+. Looks inherited. 
Some workaround is to change options again to get numbers.
Comment 4 Samuel Mehrbrodt (CIB) 2018-12-15 15:43:04 UTC
This has been fixed with the commits pushed for bug 121962.

*** This bug has been marked as a duplicate of bug 121962 ***