Download it now!
Bug 121962 - Exporting document to pdf via command line produces wrong table sum
Summary: Exporting document to pdf via command line produces wrong table sum
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Samuel Mehrbrodt (CIB)
URL:
Whiteboard: target:6.3.0 target:6.2.0.1
Keywords:
: 63570 90912 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-12-07 15:01 UTC by Samuel Mehrbrodt (CIB)
Modified: 2019-03-13 15:07 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
bugdoc.odt (14.62 KB, application/vnd.oasis.opendocument.text)
2018-12-07 15:01 UTC, Samuel Mehrbrodt (CIB)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Samuel Mehrbrodt (CIB) 2018-12-07 15:01:05 UTC
Created attachment 147351 [details]
bugdoc.odt

1) Run "libreoffice --convert-to pdf bugdoc.odt"

Expected:
The pdf should have a "0" in the yellow table cell

Actual:
The pdf has "Expression faulty" in the yellow table cell.

Note that the result is fine when you use PDF export via UI. This only happens when converting via command line (seen on both Linux and Windows).
Comment 1 Oliver Brinzing 2018-12-08 13:54:47 UTC
reproducible with lo 6.1.4.1
Comment 2 Samuel Mehrbrodt (CIB) 2018-12-11 07:46:58 UTC
What I found out / note to self:
Error condition gets set at https://opengrok.libreoffice.org/xref/core/sw/source/core/bastyp/calc.cxx#1141

Then the DBL_MAX value is assigned here: https://opengrok.libreoffice.org/xref/core/sw/source/core/table/swtable.cxx#2314

and the "expression faulty" string get set here: https://opengrok.libreoffice.org/xref/core/sw/source/core/table/swtable.cxx#2323
Comment 3 Commit Notification 2018-12-11 15:15:13 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/d0e30c11740ba22af5f6a8156dd00dad8c378b2a%5E%21

tdf#121962 Don't treat closing bracket as invalid syntax

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Cor Nouws 2018-12-12 20:55:06 UTC
looks similar to bug 63570 ...
Comment 5 Commit Notification 2018-12-12 23:42:42 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/47180e4b83b5371d4006789261937de05e47a076%5E%21

tdf#121962 Don't treat closing bracket as invalid syntax

It will be available in 6.2.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2018-12-15 14:02:16 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/2bc1d00af6863d5c92389f1f4a99d2ab9bb73f81%5E%21

tdf#121962 Update fields after layout has been calculated

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Samuel Mehrbrodt (CIB) 2018-12-15 14:09:49 UTC
*** Bug 63570 has been marked as a duplicate of this bug. ***
Comment 8 Samuel Mehrbrodt (CIB) 2018-12-15 15:43:04 UTC
*** Bug 90912 has been marked as a duplicate of this bug. ***
Comment 9 Commit Notification 2018-12-16 00:30:52 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

https://git.libreoffice.org/core/+/d9f02548f29678b8b7fc3a6c714ab144bd728005%5E%21

tdf#121962 Update fields after layout has been calculated

It will be available in 6.1.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2018-12-16 00:31:02 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/cc49b1ef721db5943d3d59c7a8018752a2e4abf9%5E%21

tdf#121962 Update fields after layout has been calculated

It will be available in 6.2.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2019-02-13 11:46:03 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

https://git.libreoffice.org/core/+/2ab2280f21fa491154e17c303dc70fcf059123b3%5E%21

Revert "tdf#121962 Update fields after layout has been calculated"

It will be available in 6.1.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.