Download it now!
Bug 91081 - LO crash when popup dialog closed immediately after opening with ESC key
Summary: LO crash when popup dialog closed immediately after opening with ESC key
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.0.0.0.alpha0+ Master
Hardware: Other All
: high critical
Assignee: Philippe Jung
URL:
Whiteboard: target:5.0.0
Keywords:
Depends on:
Blocks:
 
Reported: 2015-05-04 15:28 UTC by Philippe Jung
Modified: 2015-05-06 10:59 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Jung 2015-05-04 15:28:42 UTC
This problem impacts at least calc and writer:

Open a contextual menu, select an action that opens a popup dialog.
For example:
- scalc -> insert image -> right click -> hyperlink
- writer -> insert text -> select it -> right click -> Paragraph

Press ESC immediately

LO crashes.

This is linked to Focus handler still registered on a "disposed" component.
Comment 1 Philippe Jung 2015-05-04 15:35:45 UTC
Fix proposal: https://gerrit.libreoffice.org/#/c/15626/
Comment 2 m.a.riosv 2015-05-04 21:16:21 UTC
Hi Philippe, thanks for reporting.

Seems a duplicate, please if you are not agree, reopen it.

*** This bug has been marked as a duplicate of bug 90435 ***
Comment 3 Philippe Jung 2015-05-05 05:29:35 UTC
Not the same bug. I would not be able to reproduce step 3 of the given bug as I systematically crash after step 2
Comment 4 Philippe Jung 2015-05-05 05:30:14 UTC
Fix in gerrit.
Was related to FocusHandler
Comment 5 Commit Notification 2015-05-05 11:38:12 UTC
Philippe Jung committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=aa87af58b195af94ea5b9dcb01faf09e01e76e1b

tdf#91081 Fix LO crash after dialog closing by ESC

It will be available in 5.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Philippe Jung 2015-05-05 12:20:28 UTC
Tested with Hyperlink popup in scalc and with Paragraph popup in Writer.
Without fix: 100% reproducible crash.
With fix: no crash.
Comment 7 Laurent BP 2015-05-06 09:58:10 UTC
Test in Calc: Format > Cells
No more crash with this fix
Set as verified
Comment 8 Michael Meeks 2015-05-06 10:57:30 UTC
*** Bug 91100 has been marked as a duplicate of this bug. ***
Comment 9 Michael Meeks 2015-05-06 10:59:12 UTC
*** Bug 91073 has been marked as a duplicate of this bug. ***