Bug Hunting Session
Bug 91100 - Closing Word count crashes writer
Summary: Closing Word count crashes writer
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.0.0.alpha0+ Master
Hardware: x86-64 (AMD64) Linux (All)
: high critical
Assignee: Not Assigned
URL:
Whiteboard: target:5.0.0 target:6.2.0
Keywords: bibisected, bisected, haveBacktrace, regression
Depends on:
Blocks: VclPtr
  Show dependency treegraph
 
Reported: 2015-05-05 17:54 UTC by David
Modified: 2018-06-13 14:24 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
bt with debug symbols (10.05 KB, text/plain)
2015-05-05 19:55 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David 2015-05-05 17:54:50 UTC
I don't know when this problem would have first started, but I just compiled version 5.0.0.0.alpha1 Build ID 259820af718fe15ea5080711f77918dad8f14fbb and am experiencing a crash whenever the word count box is closed.  The user directory was reset.  

Simply create a new writer document.  Then select Tools | Word Count.  Select Close and the program crashes every time.  Issue will cause loss of unsaved data and is also an important feature and is also a regression, so it's been marked as a blocker.
Comment 1 Julien Nabet 2015-05-05 19:55:45 UTC
Created attachment 115366 [details]
bt with debug symbols
Comment 2 Matthew Francis 2015-05-06 08:31:23 UTC
This began at the below commit.
Adding Cc: to michael.meeks@collabora.com; Could you possibly take a look at this one? Thanks

commit e8b97a52c96df9c8e8055407b1e40ed7cb9cfc67
Merge: 2b0be6c 0cde74f
Author: Michael Meeks <michael.meeks@collabora.com>
Date:   Tue Apr 28 11:41:31 2015 +0100

    Merge remote-tracking branch 'origin/feature/vclptr'
    
    Resolve several thousand lines of conflicts.
Comment 3 Michael Meeks 2015-05-06 10:57:30 UTC
Thanks ! can't reproduce on master - I assume a duplicate as below; if it recurrs with a recent master for you - please un-mark it as a duplicate =)

*** This bug has been marked as a duplicate of bug 91081 ***
Comment 4 Matthew Francis 2015-05-06 12:03:37 UTC
@mmeeks: bug 91081 is fixed but I can still reproduce this one on a fresh (dbgutil) master build as of 0a6012912f76a6fca7c6aac081b4b2940b8d055c
Comment 5 Michael Meeks 2015-05-06 12:38:06 UTC
Ah yes; silly me - didn't look carefully enough at the trace. Looks simple enough to me - though I still can't reproduce it without my patch - but this should fix this =) needless to say, testing appreciated.
Comment 6 Commit Notification 2015-05-06 12:39:38 UTC
Michael Meeks committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8c4bbc0a0ddb1ea8051f0be5a42ef128cf7d891e

tdf#91100 - don't Notify focus changes after dispose.

It will be available in 5.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Julien Nabet 2015-05-06 21:17:23 UTC
On pc Debian x86-64 with master sources updated today:
commit 45ed509f71aeef52cb86cc3d88aa2bcf86334bb7
Author: Juergen Funk <juergen.funk_ml@cib.de>
Date:   Wed May 6 14:12:15 2015 +0200
+ enable-dbgutil

I don't reproduce this.
Comment 8 Julien Nabet 2015-05-06 21:43:55 UTC
*** Bug 91118 has been marked as a duplicate of this bug. ***
Comment 9 Robinson Tryon (qubit) 2015-12-17 09:03:48 UTC Comment hidden (obsolete)
Comment 10 Commit Notification 2018-06-13 14:24:47 UTC
Zdeněk Crhonek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5db29ca06b56bb235b0e8dfd0956715730f9cf0d

uitest-Word Count;tdf#68347 tdf#91100 tdf#58050 tdf#56975 tdf#56975

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.