Bug Hunting Session
Bug 91144 - Crash on selecting custom animation and clicking OK with automatic preview enabled
Summary: Crash on selecting custom animation and clicking OK with automatic preview en...
Status: RESOLVED DUPLICATE of bug 91426
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.0.0.0.alpha0+ Master
Hardware: x86-64 (AMD64) Windows (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: VclPtr
  Show dependency treegraph
 
Reported: 2015-05-07 16:53 UTC by Buovjaga
Modified: 2015-05-22 13:48 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Backtrace of crash (12.72 KB, text/plain)
2015-05-14 17:19 UTC, Buovjaga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Buovjaga 2015-05-07 16:53:00 UTC
1. Type some text.
2. Add custom animation to text.
3. Automatic preview enabled.
4. Select Entrance, Moderate, Spin in.
5. Crashes on OK.

Windows-only.

Win 7 Pro 64-bit Version: 5.0.0.0.alpha1+ (x64)
Build ID: 6e78bf76f3a10b43475e1bd801bdcbb9ce62f668
TinderBox: Win-x86_64@42, Branch:master, Time: 2015-05-07_00:45:19
Locale: fi-FI (fi_FI)

Ubuntu 15.04 64-bit 
Version: 5.0.0.0.alpha1+
Build ID: 4c07124cf4f7684d271d0e71a095c67e0f988e45
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2015-05-04_04:47:48
Locale: en-US (en_US.UTF-8)
Comment 1 Buovjaga 2015-05-07 16:54:05 UTC
Dennis confirmed crash on IRC with 64-bit Win build of 5.0 from today.
Comment 2 Buovjaga 2015-05-07 17:00:11 UTC
Also, 4.4 doesn't crash..

Win 7 Pro 64-bit, Version: 4.4.3.2
Build ID: 88805f81e9fe61362df02b9941de8e38a9b5fd16
Locale: fi_FI
Comment 3 Buovjaga 2015-05-14 17:19:32 UTC
Created attachment 115606 [details]
Backtrace of crash

Win 7 Pro 64-bit Version: 5.0.0.0.alpha1+
Build ID: 9de1d53a2ce3ee7036b4688b373db7b2235af4d9
TinderBox: Win-x86@39, Branch:master, Time: 2015-05-14_00:07:12
Locale: fi-FI (fi_FI)
Comment 4 Michael Meeks 2015-05-21 15:07:16 UTC
*** Bug 91381 has been marked as a duplicate of this bug. ***
Comment 5 Michael Meeks 2015-05-21 15:30:00 UTC
Couldn't reproduce; but found when I exited impress I got a related crash and fixed that - also another issue from code reading around your trace.

Thanks !
Comment 6 Buovjaga 2015-05-22 08:06:57 UTC
(In reply to Michael Meeks from comment #5)
> Couldn't reproduce; but found when I exited impress I got a related crash
> and fixed that - also another issue from code reading around your trace.
> 
> Thanks !

I'm afraid it is still crashing.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 83eb114394879cbfd073322a51c47d02553c1fcf
TinderBox: Win-x86@39, Branch:master, Time: 2015-05-22_06:33:51
Locale: fi-FI (fi_FI)
Comment 7 Michael Meeks 2015-05-22 13:46:22 UTC
Rather a similar trace to 91426 I guess - from the automatic preview using the directx canvas. Thanks !

*** This bug has been marked as a duplicate of bug 91426 ***
Comment 8 Michael Meeks 2015-05-22 13:48:13 UTC
Both traces have:

00bcde80 5d4a244e c3b7c807 0bf2aac0 00bcdeec vcllo!OutputDevice::disposeOnce+0x41 [c:\cygwin\home\tinderbox\master\vcl\source\outdev\outdev.cxx @ 204]
00bcde9c 57fc6860 0bf2aac0 00bcdec0 57fc38b6 vcllo!SystemChildWindow::~SystemChildWindow+0x3e [c:\cygwin\home\tinderbox\master\vcl\source\window\syschild.cxx @ 137]
00bcdea8 57fc38b6 00000001 00bcded0 0bf2aac0 directx9canvaslo!SystemChildWindow::`scalar deleting destructor'+0x10
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

or somesuch.