Bug Hunting Session
Bug 91381 - Crash when closed Animation Dialog
Summary: Crash when closed Animation Dialog
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.0.0.0.alpha0+ Master
Hardware: x86-64 (AMD64) All
: medium major
Assignee: Not Assigned
URL:
Whiteboard: target:5.1.0 target:5.0.0.0.beta2
Keywords: haveBacktrace
Depends on:
Blocks: VclPtr
  Show dependency treegraph
 
Reported: 2015-05-19 12:03 UTC by baffclan
Modified: 2016-10-25 19:24 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Backtrace of crash (12.39 KB, text/plain)
2015-05-20 13:17 UTC, Buovjaga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description baffclan 2015-05-19 12:03:10 UTC
Steps to Reproduce:
1. Start LibO-Dev
2. Make a New Impress Presentation
3. Insert Animation, Menu - Insert - Animated Image
4. Appear Animation Dialog 
5. Press ESC key on Animation Dialog


daily/master/Win-x86@62-merge-TDF/2015-05-16_03.18.47

Version: 5.0.0.0.alpha1+
Build ID: 6664859e1e8b3f8b7db8c931b8d0335510c20ce0
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-05-16_03:18:47
Locale: ja-JP (ja_JP)
Comment 1 Julien Nabet 2015-05-19 19:54:35 UTC
On pc Debian x86-64 with master sources updated today, 5f653490a40850886f94c9fd6b381b4bed1de58a, I don't reproduce this.

It could be related to VclPtr problems. Could you give a try to an even more recent version? (at least from this one:5f653490a40850886f94c9fd6b381b4bed1de58a)
Comment 2 baffclan 2015-05-20 12:08:59 UTC
(In reply to Julien Nabet from comment #1)
> It could be related to VclPtr problems.
I think so, too.

> Could you give a try to an even more recent version?

Reproduce with Version: 5.0.0.0.alpha1+ / Windows7(x64)

daily/master/Win-x86@62-merge-TDF/2015-05-20_09.42.31

Version: 5.0.0.0.alpha1+
Build ID: 55828bef6926a0eec446ca0b8503f656cc5c4a7f
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-05-20_09:42:31
Locale: ja-JP (ja_JP)
Comment 3 Julien Nabet 2015-05-20 12:11:53 UTC
Thank you for your feedback.
Comment 4 Buovjaga 2015-05-20 13:17:50 UTC
Created attachment 115750 [details]
Backtrace of crash

Reproduced.

Win 7 Pro 64-bit Version: 5.0.0.0.alpha1+
Build ID: 2a886adb500fe481e1ea61573551b19e99c55b8b
TinderBox: Win-x86@39, Branch:master, Time: 2015-05-20_00:31:51
Locale: fi-FI (fi_FI)
Comment 5 Julien Nabet 2015-05-20 14:23:56 UTC
Considering the bt, it can't be Windows only.
Comment 6 Michael Meeks 2015-05-21 15:07:16 UTC
Thanks =)

*** This bug has been marked as a duplicate of bug 91144 ***
Comment 7 Commit Notification 2015-05-21 15:30:25 UTC
Michael Meeks committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=99938e7bc8a305dcc9733adbe635e25a38afed31

tdf#91381 - fix a couple of animation related lifecycle issues.

It will be available in 5.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Buovjaga 2015-05-22 08:08:07 UTC
This was not a duplicate, but the crash is now gone.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 83eb114394879cbfd073322a51c47d02553c1fcf
TinderBox: Win-x86@39, Branch:master, Time: 2015-05-22_06:33:51
Locale: fi-FI (fi_FI)
Comment 9 baffclan 2015-05-22 11:07:02 UTC
Thanks for fixing this.

Wfm on Windows 7 Pro x64
Version: 5.1.0.0.alpha1+
Build ID: edcd1d5a9c88455fd1d52ab25815fc8d439f31ec
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-05-22_00:02:07
Locale: ja-JP (ja_JP)
Comment 10 Commit Notification 2015-05-22 14:30:19 UTC
Michael Meeks committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=94f8754f8e69bc0e5f06dc271fc286eaa0e0c339&h=libreoffice-5-0

tdf#91381 - fix a couple of animation related lifecycle issues.

It will be available in 5.0.0.0.beta2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.