Bug 91150 - Including additional Adobe open source fonts
Summary: Including additional Adobe open source fonts
Status: RESOLVED DUPLICATE of bug 79022
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: ux-advise (show other bugs)
Version:
(earliest affected)
5.0.0.0.alpha0+ Master
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Fonts-Bundled
  Show dependency treegraph
 
Reported: 2015-05-07 23:44 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-11-04 11:53 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2015-05-07 23:44:50 UTC
Presently, LibO bundles Adobe's Source Sans Pro font, but Adobe has also released a monospace variant (Source Code Pro) in 2012 and a serif variant (Source Serif Pro) in 2014. So are we intending to also bundle those as well?
Comment 1 Tomaz Vajngerl 2015-05-08 02:28:50 UTC
We already bundle "Source Code Pro" and we don't bundle "Source Serif Pro" because it doesn't yet support italics.

I myself would rather go with Noto family or Droid family and remove "Open Sans" (it is just a variation of "Droid Sans" - same as "Noto Sans" but without an "Open Serif" pair).
Comment 2 Francisco 2015-05-08 03:32:04 UTC
(In reply to Tomaz Vajngerl from comment #1)
> I myself would rather go with Noto family or Droid family and remove "Open
> Sans" (it is just a variation of "Droid Sans" - same as "Noto Sans" but
> without an "Open Serif" pair).

It is true that Noto and Open Sans are barely the same, though the second, if I remember correctly, has a bigger glif base. However, Droid Sans is different, even though the look similar. Simply print some long text with both and compare.
Comment 3 Adolfo Jayme 2015-05-08 13:03:08 UTC
Jay, this was already discussed with UX, and was decided to go with WONTFIX (use search, please!). Besides, there is the concern of unnecessarily increasing installation footprint without adding much value. Bundling Noto (and removing Open Sans), for example, would be a better move, as it would allow us to support many more languages.

*** This bug has been marked as a duplicate of bug 79022 ***