Download it now!
Bug 91421 - Spell checker seems not to work at all; installation as "default" mode today.
Summary: Spell checker seems not to work at all; installation as "default" mode today.
Status: RESOLVED DUPLICATE of bug 91172
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Linguistic (show other bugs)
Version:
(earliest affected)
4.4.3.2 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-05-21 07:43 UTC by Aphreally
Modified: 2015-06-26 07:06 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Test cases for current release SpellCheck operation (1.24 MB, application/vnd.oasis.opendocument.text)
2015-05-21 07:43 UTC, Aphreally
Details
The SpellChecker worked perfectly (I think) with this file (11.47 KB, application/vnd.oasis.opendocument.text)
2015-05-26 07:07 UTC, Aphreally
Details
This file, the SpellChecker did nothing (started from Windows context menu, unlike the one before which was started from the LibreOffice main menu) (10.54 KB, application/vnd.oasis.opendocument.text)
2015-05-26 07:10 UTC, Aphreally
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aphreally 2015-05-21 07:43:12 UTC
Created attachment 115762 [details]
Test cases for current release SpellCheck operation

The spellchecker used to work automatically for me in previous versions, though (I think) not with the last 2 or 3 releases.
Generally I can do without it, but it's handy, and I wanted to use it for a special reason today.  I couldn't see how to make it work, and I think it's a bug.  Others seem to have the same problem, or a similar problem, so I believe it's a wide-spread issue - - -
Anyway, I composed a test file while trying out the feature with the new release installation, and it's attached. (By the way, spell checker has worked on this description, so it works in some contexts!)
Comment 1 Buovjaga 2015-05-25 11:07:46 UTC
Did you by any chance create the document with the Windows explorer context menu? If yes, then there is already a report for that, bug 91172
Comment 2 Aphreally 2015-05-26 05:18:28 UTC
Hi.
After reporting this "unintended feature" as a bug (because it seemed to me to be a general problem - it still does) I've continued to work with some pretty important (to me) files.  I can't remember exactly the path I used at first creation of the newer files - but seriously, don't think that should matter one scrap.
My files include some older ones for modification - probably first generated by some version of Microsoft Office - which I retain in ".doc" format.  At least one of those shows the occasional spelling error (what!!) (even with new modifications), but usually doesn't care about rubbish spelling.  Bad luck for me if I don't see it!
Newer files: I've started some from the Windows context menu (maybe not the other possible ways).  Those I intend to use only on my own system I keep in ".odt" format - but I begin some in ".odt" format and then very soon save them in ".doc" format.  Spellchecker doesn't seem to work any way.

I think the spellchecker doesn't work because it's inner pointers are either not properly pointing, or are pointing to something irrelevant - - -

Anyway, LibreOffice has stopped being able to open files just now (probably a counter or pointer overflow (but what would I know!?), so I'm about to re-boot.

(By the way, I'm using a system with 4GB physical memory, which is more than a 32-bit OS needs, so I don't think that's the problem!)

All the best - hope someone can fix this!
Comment 3 Aphreally 2015-05-26 07:07:12 UTC
Created attachment 116037 [details]
The SpellChecker worked perfectly (I think) with this file
Comment 4 Aphreally 2015-05-26 07:10:06 UTC
Created attachment 116038 [details]
This file, the SpellChecker did nothing (started from Windows context menu, unlike the one before which was started from the LibreOffice main menu)
Comment 5 Buovjaga 2015-05-26 07:46:27 UTC
This should help you fix the [None]-problem in your existing files, paraphrasing myself from the bug report I referred to:
When created with context menu, it says [None] in the status bar for language. Have to select a language from Tools - Lang - For all text. Then spellcheck works.
Comment 6 Aphreally 2015-05-27 02:20:08 UTC
Thanks Beluga for your help on this - if I need the spell checker I'll do what you say.

Of course it doesn't fix the problem, which is real. As I said a short while ago, "I think the spellchecker doesn't work because it's inner pointers are either not properly pointing, or are pointing to something irrelevant - - -", then said I had to reboot because "LibreOffice has stopped being able to open files - - -".

The other programs I was using before the re-boot were working fine, it was just LibreOffice that seemed ill.  When I did restart, everything was good again with LibreOffice (which I took as confirmation of my opinion).

I was going to say yesterday (not as a bug report, but just describing my experience [about what I regard as a general malfunction that will probably take a lot of work to fix, and I don't know enough to try]) that I've noticed quite a few "pointer problems" etc. while using the Word Processor.

These include the cursor being somewhere else than I expect during or after typing an amendment - just an annoyance, not a real problem.

Another problem is with good and consistent formatting of automatic paragraph numbering (which IS a real problem), even though I've been extremely careful with amendments along the way, and carefully treating the whole automatically numbered section before I close the file.

It looks lovely when I close the file.  But on reopening the file, the numbering is right but the sizes are wrong, for example, or everything seems OK except that all the automatic paragraph numbers on all 3 levels are "bold" when I thought they would be (as they should have been) not bold.

Again just my opinion, but it seems that parameters used by the file at reopening time are not what they should have been set at, or are not where they should be - when at file closing time they made everything look OK.

Anyway I'm not a rich person, and haven't yet made a donation - I will when either of these issues suddenly come right in some revised release without "breaking" something else - - -

Best wishes!
Comment 7 Buovjaga 2015-05-27 13:51:54 UTC
I will set this to NEEDINFO, while we wait for your further experiences.

If you get the [None] language issue for new documents created otherwise than Windows explorer context menu, this can be set back to UNCONFIRMED.

If you consistently observe the issue happening only when creating from the Windows explorer context menu, this can be closed as RESOLVED DUPLICATE of bug 91172.
Comment 8 Aphreally 2015-06-07 23:50:32 UTC
I'm not chasing any further along this track - - -
If the bug (however you define it - I don't care) is fixed, I'll see it in the release fixing it.
In my opinion it shouldn't matter what path you use to open a new file, the program should behave in the same way on the opened file, at the first edit and at any later edit.
If it doesn't, that says something about internal linkages, I would have thought - not that I know the correct programming terminology.
Best wishes, & thank you.
Comment 9 Buovjaga 2015-06-26 07:06:47 UTC

*** This bug has been marked as a duplicate of bug 91172 ***