Bug 91549 - LibreOffice forgets state of OpenGL options
Summary: LibreOffice forgets state of OpenGL options
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.0.0.0.alpha0+ Master
Hardware: All All
: high critical
Assignee: Not Assigned
URL:
Whiteboard: target:5.0.2
Keywords: bibisected, bisected, regression
: 91631 (view as bug list)
Depends on:
Blocks: VclPtr
  Show dependency treegraph
 
Reported: 2015-05-23 21:23 UTC by Michael
Modified: 2015-12-17 09:12 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael 2015-05-23 21:23:32 UTC
1) Open Writer
2) Go to Tools->Options->View
3) Under Graphics Output, check "Use OpenGL for all rendering" and "Force OpenGL even if blacklisted"
4) Press OK
5) Go back to Tools->Options->View
6) Notice that the two boxes are unchecked

Expected result: checking those boxes should be remembered after pressing OK and returning to that screen

(It can work in reverse too; if you use an older version of LO to enable those boxes, then load a broken LO, you'll find that unchecking them doesn't stick.)

Bibisected in 5.0 branch:

$ git bisect log
# bad: [c0fbc9b85ec523099dceb0f4f778fb10042efbd7] 2015-05-19: source-hash-158b50763962f66515062300e265839828463efa
# good: [e4b0a61cedc6ac0e65a4a110fd83edd8295f4856] 2014-11-20: source-hash-d273a60bfdbf9bb7623bed38667ec0647753157c
git bisect start 'c0fbc9b85ec523099dceb0f4f778fb10042efbd7' 'oldest'
# good: [935d2b58beb350acf647a664a1e97376503b8acb] 2015-02-18: source-hash-dd4bd0ee74fae3d7e3a16e018021da173152571b
git bisect good 935d2b58beb350acf647a664a1e97376503b8acb
# good: [7e67865d7214e3089ffceeaac1ba916f03ac21c0] 2015-04-04: source-hash-b326270fb921b3c2e7fff2da76ebae33adcaef3d
git bisect good 7e67865d7214e3089ffceeaac1ba916f03ac21c0
# good: [9ccc3e23269eebdb13eaa34c7231b7b9f6035c90] 2015-04-26: source-hash-3a96d8ead86dc210085f09076fd270f247442f0a
git bisect good 9ccc3e23269eebdb13eaa34c7231b7b9f6035c90
# bad: [54e8e3308771ab73b9de0e52bdef20826f428fab] 2015-05-07: source-hash-6e78bf76f3a10b43475e1bd801bdcbb9ce62f668
git bisect bad 54e8e3308771ab73b9de0e52bdef20826f428fab
# skip: [0f7da7628876aad0c28a577a70d6a660dfa1ab4e] 2015-05-01: source-hash-5a24b94662414fb9470be9c5d9c8b28c6ad42b5b
git bisect skip 0f7da7628876aad0c28a577a70d6a660dfa1ab4e
# bad: [18c79871a724a95167d0cce88a6be2df138dc964] 2015-05-02: source-hash-393c51cee8bc3de5a2a9f4e04161c59e8712f631
git bisect bad 18c79871a724a95167d0cce88a6be2df138dc964
# bad: [06421cdb5e5880c2f8232a04f521a341edf08de3] 2015-04-29: source-hash-2932d2db599c09ecce3faa2d627e9ee4f251183a
git bisect bad 06421cdb5e5880c2f8232a04f521a341edf08de3
# good: [1042e18eb884e17cbdd170a589d3c6db21455c01] 2015-04-27: source-hash-f0edb677f09ad338e22ac3b5d91497b4479e0b3c
git bisect good 1042e18eb884e17cbdd170a589d3c6db21455c01
# good: [af526ee52f2c296e0f17bc385d4001b9322818e7] 2015-04-28: source-hash-4fee05e680217e876210b341f904df9441a0b7cd
git bisect good af526ee52f2c296e0f17bc385d4001b9322818e7
# first bad commit: [06421cdb5e5880c2f8232a04f521a341edf08de3] 2015-04-29: source-hash-2932d2db599c09ecce3faa2d627e9ee4f251183a
Comment 1 MM 2015-05-23 23:45:04 UTC
Unconfirmed with v4.4.3.2 under mint 17.1 x64.
Confirmed with v5.0.0.0 B1 under mint 17.1 x64.

Indeed a regression.
Comment 2 Alex Thurgood 2015-05-29 07:29:05 UTC
*** Bug 91631 has been marked as a duplicate of this bug. ***
Comment 3 Alex Thurgood 2015-05-29 07:29:54 UTC
Also confirmed on 

Version: 5.1.0.0.alpha1+
Build ID: 8cbb94a2b79dcaf9675125da800b64a85bae52dc
Locale : fr-FR (fr.UTF-8)

OSX 10.10.3
Comment 4 sergio.callegari 2015-07-13 21:18:40 UTC
Confirmed on linux with 5.0.0.3
Comment 5 Cor Nouws 2015-08-04 08:50:15 UTC
This is not a Writer specific setting
Comment 6 Michael Heyns 2015-08-06 04:12:42 UTC
Confirmed on Arch Linux, running LibreOffice 5.0.0 release.
Comment 7 Hideki Saito 2015-08-11 00:02:37 UTC
For the workaround (for those experiencing havoc on their screen for these settings to be on), you can set UseOpenGL and ForceOpenGL to off for /org.openoffice.Office.Common/VCL in advanced config, which the changes seem to stick.
Comment 8 Matthew Francis 2015-08-31 04:29:56 UTC
Appears to be fixed on 5.1 master as of the below commit. I guess the mechanism is that failing to destruct the dialog means the change isn't committed?

I don't see a backport to 5.0 yet


commit 47c41f4c03db2e876301760415db1e937d00f551
Author: Caolán McNamara <caolanm@redhat.com>
Date:   Tue Jul 7 14:16:42 2015 +0100

    VclPtr: no dialog loaded from a .ui ever actually destructed
    
    Change-Id: I51a0596049a43cbc80f914f3d8491c2125c8109e
Comment 9 Michael Meeks 2015-08-31 07:18:47 UTC
Pushed to 5-0 with my sign-off (urk) would like to see a CI build complete first:

https://gerrit.libreoffice.org/18158 VclPtr: no dialog loaded from a .ui ever actually destructed
Comment 10 Michael Meeks 2015-08-31 09:59:18 UTC
So - assuming Caolan's patch does this =) this is fixed - that's a nasty one; thanks Caolan and Matthew for chasing.

We have a clang plugin to ensure that all of our VclPtr member references were disposeAndClear'd or disposed - but of course it doesn't apply to the builder which is not itself an OutputDevice derived type.
Comment 11 Michael Stahl (CIB) 2015-09-15 17:49:21 UTC
was pushed to libreoffice-5-0 as commit
d3f5b205e4600bfa2ca062f404bb8e58b657c621
Comment 12 Robinson Tryon (qubit) 2015-12-17 09:12:27 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]