Bug 91601 - Opened document not getting focus
Summary: Opened document not getting focus
Status: RESOLVED DUPLICATE of bug 89912
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.2.7.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: notBibisectable, regression
Depends on:
Blocks:
 
Reported: 2015-05-25 08:31 UTC by Mikeyy - L10n HR
Modified: 2015-12-17 10:59 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mikeyy - L10n HR 2015-05-25 08:31:50 UTC
Let me start with this:
No, it's not duplicate of bug 48300.

It's regression, working in 4.1.6, not working in 4.3, I think I tested it with 4.2.7 and it wasn't working, so regression is somewhere in 4.2 branch.

To reproduce:
1. If you have any LibreOffice windows open, close them.
2. Open windows explorer and navigate to folder where you have more then one LibreOffice file. I'm testing with Calc ODS files.
3. Open any one file. LO will open it and bring focus to that file.
4. Switch back to windows exporer (via ALT-TAB or status bar), DON'T minimize opened LO window.
5. Open any other file.

EXPECTED RESULT:
Last opened file should be opened in foreground, visible.

ACTUAL RESULT:
Last opened file opens in background, windows explorer window is still on top of it.

You can test it also with opening files from e-mail program, like Thunderbird, it will produce same result.
Comment 1 raal 2015-05-25 09:05:20 UTC
Works for me with 4.4.3.2, win7 with two monitors - first monitor explorer, second monitor LO

Reproducible with 4.4.3.2, win7 with two monitors - first monitor explorer and LO
Comment 2 Mikeyy - L10n HR 2015-05-25 13:31:46 UTC
(In reply to raal from comment #1)
> Works for me with 4.4.3.2, win7 with two monitors - first monitor explorer,
> second monitor LO

It works because LO brings second file window in front of first file window, but never in front of any other opened programs.

You can test it with 1 monitor, just don't maximise windows explorer window, keep it small so you can see what's happening behind it. You will notice that new file open, but not in front of explorer window.

Anyway, bringing in two monitors just complicates things and should not be focused on.
Comment 3 tommy27 2015-09-19 06:29:21 UTC

*** This bug has been marked as a duplicate of bug 89912 ***
Comment 4 Robinson Tryon (qubit) 2015-12-17 10:59:21 UTC
Migrating Whiteboard tags to Keywords: (notBibisectable)
[NinjaEdit]