Bug 91607 - DIN Regular used as fallback font for UI (see comment 6)
Summary: DIN Regular used as fallback font for UI (see comment 6)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.4.3.1 rc
Hardware: x86-64 (AMD64) macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 124187 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-05-25 11:00 UTC by Armin
Modified: 2019-07-05 15:55 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
character window (26.47 KB, image/png)
2015-05-25 11:00 UTC, Armin
Details
character window (57.50 KB, image/png)
2015-05-25 11:01 UTC, Armin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Armin 2015-05-25 11:00:04 UTC
Created attachment 116009 [details]
character window

The dialog boxes are missing labels and text. Ui components are not aligned correctly (see attachment). The application crashes very often - especially when I am using track changes. The whole thing feels unstable. Is it because I'm using the wrong java version?

I'm using the 4.4.3 version on OSX Yosemite 10.10.3 running JRE 1.8.0_25-b127 (Oracle).
Comment 1 Armin 2015-05-25 11:01:15 UTC
Created attachment 116010 [details]
character window
Comment 2 Julien Nabet 2015-05-25 19:38:50 UTC
For the test, could you rename your LO directory profile (see https://wiki.documentfoundation.org/UserProfile#Mac_OS_X) and give it a new try?

Also, do you confirm you use x86 32 bits and not x86-64? Indeed, LO installers for Macos is 64 bits only?
Comment 3 Armin 2015-05-26 06:25:17 UTC
Yes, I'm using the 64bit version. I corrected that.
I renamed (and also removed) the user profile but it didn't change anything.

Two things I have noticed:
* Sometimes (every 3rd-6th time) LibreOffice starts up with a correctly rendered start screen. All the other windows and GUI elements will be rendered correctly too.
* I'm experiencing the same problem with OpenOffice.
Comment 4 Alex Thurgood 2015-05-29 08:23:05 UTC
I can not reproduce this with 

Version: 4.4.3.2
Build ID: 88805f81e9fe61362df02b9941de8e38a9b5fd16
Locale : fr_

OSX 10.10.3

I have Java 1.8_45, but that shouldn't make any difference.
I don't see the graphics corruption you show in your screenshot.
Comment 5 Adolfo Jayme Barrientos 2015-05-31 10:14:53 UTC
Armin: you’ve described a bunch of unrelated issues in a single bug report, which makes it unmanageable. I’ll focus on the font alignment issue in this comment.

The issue is caused because you’ve configured a different UI typeface for OS X. (Understandable, because Apple made a huge mistake when shoving Helvetica Neue down its users’ throats). Apple does NOT support these “unofficial” configurations, and OS X does not expect the especifically-adapted default font to be changed for any other. The metrics obviously differ. And we are unable to guarantee a correct alignment for every font out there.

So, in a nutshell, that part of your bug report is “NOTOURBUG”.

Oh – and for the record, LibreOffice is a C++ application that does not depend on Java, except for parts of Base; so there’s likely no correlation. You can run the program without Java.
Comment 6 Armin 2015-06-01 04:52:25 UTC
Hi Adolfo,

I mentioned the crashes as they might be related to the button/font issue. Maybe both problems were symptoms of the same cause. Of course this might not be the case. The missing labels are the most tangible issue and I agree to focus on that one.

Suspecting the change of the system font to be the culprit was a well educated guess. Unfortunately I never changed my system's font. I'am not using San Francisco, or Fira Sans or anything like that. I'm using the plain vanilla Helvetica Neue.

*However*, on a closer look I realized that LibreOffice isn't using my system font.
"Libre Office->View->Use system font for user interface" is checked, but the setting is ignored (see also: Bug 91400).

Occassionally LibreOffice is using Arial - then the GUI renders correctly. 
Most of the time it wants to load another font for the GUI (see attachment).
I tried to identify the typeface and decided to remove a font called "DIN" from my system. Now everything is rendered in Arial.
This seems to have fixed the problem for me.
Comment 7 Adolfo Jayme Barrientos 2015-06-01 12:04:54 UTC
Armin: thank you so much for the additional details.

So this [1] is failing in the Mac. LibreOffice is not detecting the UI font and is apparently falling back to one of those ugly lists of hardcoded fonts?

[1]: http://opengrok.libreoffice.org/xref/core/unotools/source/config/fontcfg.cxx#249
Comment 8 Julien Nabet 2015-06-01 20:19:24 UTC
(In reply to Armin from comment #6)
...
> *However*, on a closer look I realized that LibreOffice isn't using my
> system font.
> "Libre Office->View->Use system font for user interface" is checked, but the
> setting is ignored (see also: Bug 91400).
> ...
See tdf#87016 for more explanation about this point.
Comment 9 Armin 2015-06-04 09:17:11 UTC
(In reply to Adolfo Jayme from comment #7)

This sounds plausible. But I don't know why it would fall back to the (maybe malformed) "DIN Regular" font. It isn't even listed in the code.
Comment 10 QA Administrators 2017-01-03 19:57:31 UTC Comment hidden (obsolete)
Comment 11 Buovjaga 2018-06-16 12:39:25 UTC
(In reply to Adolfo Jayme from comment #7)
> Armin: thank you so much for the additional details.
> 
> So this [1] is failing in the Mac. LibreOffice is not detecting the UI font
> and is apparently falling back to one of those ugly lists of hardcoded fonts?
> 
> [1]:
> http://opengrok.libreoffice.org/xref/core/unotools/source/config/fontcfg.
> cxx#249

Adolfo: you set this to NEW at this point. Were you able to confirm this?
Armin: is this still a problem for you?
Comment 12 Armin 2018-06-18 19:17:24 UTC
> Armin: is this still a problem for you?

I tried, but I was unable to reproduce this bug in LibreOffice 6.0.42

I have heard that LibreOffice isn't trying to use the system font on OSX anymore. Maybe that resolved some issues. Looking at Bug 91400 there still seem to be some issues with the hardcoded fallback fonts, though.
Comment 13 Buovjaga 2018-06-18 19:27:31 UTC
Ok, let's set to WFM
Comment 14 Adolfo Jayme Barrientos 2019-07-05 15:55:36 UTC
*** Bug 124187 has been marked as a duplicate of this bug. ***