Bug 91668 - FILESAVE: PPTX image transparency not retained
Summary: FILESAVE: PPTX image transparency not retained
Status: RESOLVED DUPLICATE of bug 127085
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.3.5.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 113152 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-05-27 16:37 UTC by Mark Hung
Modified: 2019-10-22 14:48 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample file with transparent image. (20.14 KB, application/vnd.oasis.opendocument.presentation)
2015-05-27 16:37 UTC, Mark Hung
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Hung 2015-05-27 16:37:51 UTC
Created attachment 116075 [details]
Sample file with transparent image.

Saving attached file as Office 2007 / 2009 / 2010 pptx, original transparency (85%) get lost.
Comment 1 tommy27 2015-06-02 07:27:55 UTC
confirmed under Win8.1 x64 using LibO 5.1.0.0 alpha+, 4.4.1.2 and 4.3.5.2 so it's not a new bug.

I haven't tried older LibO release so I can't tell if it ever worked.
Comment 2 tommy27 2015-06-02 07:37:35 UTC
@Mark
take a look at Bug 77283

do you have MS PowerPoint to see if the PPTX created by LibO is correctly viewed or not?

is this really a FILESAVE issue (in this case PowerPoint should not be able to show the transparency) or a FILEOPEN issue limited to LibO?
Comment 3 Mark Hung 2015-06-02 09:10:53 UTC
@tommy. 

I can't find tdf#77283.
Lost of transparency was observed in PowerPoint 2007, so I guess that it is a FILESAVE issue.
Comment 4 tommy27 2015-06-02 09:13:40 UTC
sorry bad typing
I meant Bug 77823
Comment 5 tommy27 2015-06-02 09:14:40 UTC
oopsss... I did it again...

I meant Bug 72823
Comment 6 Mark Hung 2015-06-02 09:35:32 UTC
The attached file of tdf#72823 is created with Powerpoint. It shall be a FILEOPEN issue.
Comment 7 QA Administrators 2016-09-20 09:46:39 UTC Comment hidden (obsolete)
Comment 8 Mark Hung 2016-09-21 15:49:46 UTC
Still reproducible

Version:5.2.1.2
Build ID:31dd62db80d4e60af04904455ec9c9219178d620
CPU Thread:8; OS Ver:Windows 6.2
Locale:zh-TW (zh_TW);
Comment 9 tommy27 2016-12-18 07:40:14 UTC
still repro in 5.4.0.0.alpha0+
Build ID: 690cf2a5ac87d3d05c45a86944e7f6b0adf12cf2
CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-12-15_18:59:20
Locale: it-IT (it_IT); Calc: group
Comment 10 Xisco Faulí 2017-10-16 18:50:36 UTC
*** Bug 113152 has been marked as a duplicate of this bug. ***
Comment 11 Alex ARNAUD 2017-10-17 08:55:37 UTC
Dear all,

I still repro on LibreOfficeDev 6.0 built the 2017-10-13.

Best regards.
Comment 12 QA Administrators 2018-10-18 02:48:34 UTC Comment hidden (obsolete)
Comment 13 Kees-Jan Timmer 2019-04-23 19:27:58 UTC
Using:
Versie: 6.2.2.2 (x64)
Build ID: 2b840030fec2aae0fd2658d8d4f9548af4e3518d
CPU-threads: 4; Besturingssysteem: Windows 10.0; UI-render: standaard; VCL: win; 
Locale: nl-NL (nl_NL); UI-taal: nl-NL

This bug is still present.

1. Create a new presentation.
2. Insert a .jpg picture on a slide
3. Set Transparency of the picture to 75% (or whatever..)
4. Save file as .pptx
5. Exit LO
6. Reopen file with LO
7. Transparency is gone.

btw, maybe this is Related? 

Change Brightness or Contrast of a picture.
Save as pptx.
Reopen file.
The slide opens with the picture in the right brigtness/contrast, but the % of brightness and contrast are both set to 0%.
So the original picture is gone, and you cannot return to the original picture.

btw. Saving as .odp and reopening .odp.. Both brightness%, contrast% and transparency% are retained correctly, and you can easily return to original picture.

But I have to cooperate with people who are using pptx's....
Comment 14 Xisco Faulí 2019-10-22 14:48:13 UTC
No longer reproducible in

Version: 6.4.0.0.alpha1+
Build ID: de4839e66d3d195315729b95cc144cdab96b6e74
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

Likely fixed by bug 127085

*** This bug has been marked as a duplicate of bug 127085 ***