Download it now!
Bug 127085 - PPTX: FILESAVE: Transparency is lost after RT
Summary: PPTX: FILESAVE: Transparency is lost after RT
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Tamás Zolnai
URL:
Whiteboard: target:6.4.0 target:6.3.2 target:6.2.8
Keywords: bibisected, bisected, regression
: 91668 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-08-21 14:47 UTC by Xisco Faulí
Modified: 2019-10-22 14:48 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2019-08-21 14:47:53 UTC
Steps to reproduce:
1. Open attachment 127327 [details] from bug 100830
2. Save it as PPTX
3. Open the generated file

-> Transparency of shape is lost

Reproduced in

Version: 6.4.0.0.alpha0+
Build ID: 2bed8af91fc2654b9ed2432f969d32d5741a529b
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

[Bug found by office-interoperability-tools]
Comment 1 Xisco Faulí 2019-08-21 14:49:57 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=ae3aabdb951643af8d2f7aee9c9f900245e5b384

author	Tamás Zolnai <tamas.zolnai@collabora.com>	2019-05-06 20:52:16 +0200
committer	Tamás Zolnai <tamas.zolnai@collabora.com>	2019-05-07 20:20:02 +0200
commit	ae3aabdb951643af8d2f7aee9c9f900245e5b384 (patch)
tree	127b131199dd266b16467b796d2734caad1eff49
parent	ba84300b82844921c4421a468e290aeca68fa694 (diff)
PPTX: Fix import / export of image transparency

Bisected with bibisect-linux64-6.3

Adding Cc: to Tamás Zolnai
Comment 2 Xisco Faulí 2019-08-21 15:31:58 UTC
attachment 91955 [details] from bug 72567 is also affected by the same problem
Comment 3 Commit Notification 2019-08-22 15:22:35 UTC
Tamás Zolnai committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/505cbb9c3d2771a12c989515663cc1eb73dd0c2f%5E%21

tdf#127085: FILESAVE: Transparency is lost after RT

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2019-08-29 07:41:50 UTC
Tamás Zolnai committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/4719c2360a5fa347707d47db7e3e85a5f1dd267a%5E%21

tdf#127085: FILESAVE: Transparency is lost after RT

It will be available in 6.3.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Xisco Faulí 2019-09-02 06:47:54 UTC
Verified in

Version: 6.4.0.0.alpha0+
Build ID: 41cd3e8e817c8c33a13608e62eeb06ce2c6977e4
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Tamás Zolnai, thanks for fixing this issue!
Comment 6 Commit Notification 2019-09-02 06:50:16 UTC
Tamás Zolnai committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/136ab631a3d2f7cfa22ca7b657e1c54c9d022b66%5E%21

tdf#127085: FILESAVE: Transparency is lost after RT

It will be available in 6.2.8.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Xisco Faulí 2019-10-22 14:48:13 UTC
*** Bug 91668 has been marked as a duplicate of this bug. ***