Download it now!
Bug 91772 - CRASH: DRAW: when export named no file extension.
Summary: CRASH: DRAW: when export named no file extension.
Status: RESOLVED DUPLICATE of bug 91782
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
5.0.0.0.beta1
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2015-05-31 13:55 UTC by sawakaze
Modified: 2015-05-31 20:35 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Set no file extension name and format is "All Formats" screen capture (111.34 KB, image/png)
2015-05-31 13:55 UTC, sawakaze
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sawakaze 2015-05-31 13:55:31 UTC
Created attachment 116194 [details]
Set no file extension name  and format is "All Formats"  screen capture

Hi 
After following steps, LibreOfficeDev5 beta1+ Draw Crushed

(1) Open Draw.
(2) File > Export ...
  --> Open Export Dialog
(3) Set no file extension name
    format is "All Formats" (See Attachment)
(4) Press save button 
 --> Crash

confirmed env...
Version: 5.0.0.0.beta1+
Build ID: 9d1b2de23ee39b22948424876d7e5c43913326b4
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:libreoffice-5-0, Time: 2015-05-31_07:07:44
Locale: ja-JP (ja_JP.UTF-8)

Addtional info
(i) If format is not "All Formats" (ex. png, jpg .etc), not crash.
(ii) If file name is existing extension, i.e. "test.png", not crash.  

Regards 
Sawakaze.
Comment 1 MM 2015-05-31 15:03:03 UTC
Confirmed with v5.0.0.0 b1 under ubuntu 14.04 x64.
Unconfirmed with v4.4.3.2 under ubuntu 14.04 x64.

Set as regression.
Windows doesn't have the 'all formats', so linux only ? Or is mac also affected ?
Comment 2 Julien Nabet 2015-05-31 20:29:57 UTC
On pc Debian x86-64 with master sources updated today, I could reproduce this.

Here's the main part of bt:
Program received signal SIGSEGV, Segmentation fault.
0x00002aaae3656cf6 in PSWriter::WritePS (this=0x7fffffff19f0, rGraphic=..., rTargetStream=..., pFilterConfigItem=0x7fffffff1cd0)
    at /home/julien/compile-libreoffice/libreoffice/filter/source/graphicfilter/eps/eps.cxx:428
428	    pVDev->SetMapMode( pMTF->GetPrefMapMode() );
(gdb) bt
#0  0x00002aaae3656cf6 in PSWriter::WritePS(Graphic const&, SvStream&, FilterConfigItem*) (this=0x7fffffff19f0, rGraphic=..., rTargetStream=..., pFilterConfigItem=0x7fffffff1cd0) at /home/julien/compile-libreoffice/libreoffice/filter/source/graphicfilter/eps/eps.cxx:428
#1  0x00002aaae3661181 in GraphicExport(SvStream&, Graphic&, FilterConfigItem*) (rStream=..., rGraphic=..., pFilterConfigItem=0x7fffffff1cd0)
    at /home/julien/compile-libreoffice/libreoffice/filter/source/graphicfilter/eps/eps.cxx:2861
#2  0x00002aaab1f5a186 in GraphicFilter::ExportGraphic(Graphic const&, rtl::OUString const&, SvStream&, unsigned short, com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> const*) (this=0x2aaab2912c40 <rtl::Static<(anonymous namespace)::StandardGraphicFilter, (anonymous namespace)::theGraphicFilter>::get()::instance>, rGraphic=..., rPath="", rOStm=..., nFormat=2, pFilterData=0x7fffffff2228) at /home/julien/compile-libreoffice/libreoffice/vcl/source/filter/graphicfilter.cxx:2148
#3  0x00002aaad0d5b0d5 in (anonymous namespace)::GraphicExporter::filter(com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> const&) (this=
    0x70b82b0, aDescriptor=uno::Sequence of length 3 = {...}) at /home/julien/compile-libreoffice/libreoffice/svx/source/unodraw/UnoGraphicExporter.cxx:1052
#4  0x00002aaaafccd948 in ExportDialog::GetGraphicStream() (this=0x7025ce0) at /home/julien/compile-libreoffice/libreoffice/svtools/source/filter/exportdialog.cxx:477
#5  0x00002aaaafcd1a8b in ExportDialog::updateControls() (this=0x7025ce0) at /home/julien/compile-libreoffice/libreoffice/svtools/source/filter/exportdialog.cxx:888
#6  0x00002aaaafccfd4f in ExportDialog::ExportDialog(FltCallDialogParameter&, com::sun::star::uno::Reference<com::sun::star::uno::XComponentContext> const&, com::sun::star::uno::Reference<com::sun::star::lang::XComponent> const&, bool, bool) (this=0x7025ce0, rPara=..., rxContext=
    uno::Reference to (cppu::ComponentContext *) 0x77cd00, rxSourceDocument=uno::Reference to (SdXImpressDocument *) 0x2bdedc0, bExportSelection=false, bIsPixelFormat=false)
    at /home/julien/compile-libreoffice/libreoffice/svtools/source/filter/exportdialog.cxx:698
#7  0x00002aaaafcc87ef in VclPtr<ExportDialog>::Create<FltCallDialogParameter&, com::sun::star::uno::Reference<com::sun::star::uno::XComponentContext> const&, com::sun::star::uno::Reference<com::sun::star::lang::XComponent>&, bool&, bool&>(FltCallDialogParameter&, com::sun::star::uno::Reference<com::sun::star::uno::XComponentContext> const&, com::sun::star::uno::Reference<com::sun::star::lang::XComponent>&, bool&, bool&) () at /home/julien/compile-libreoffice/libreoffice/include/vcl/vclptr.hxx:139
#8  0x00002aaaafcc729e in (anonymous namespace)::SvFilterOptionsDialog::execute() (this=0x708d900)
    at /home/julien/compile-libreoffice/libreoffice/svtools/source/filter/SvFilterOptionsDialog.cxx:258
Comment 3 Julien Nabet 2015-05-31 20:35:20 UTC
After having applied the same patch as the one I tried for tdf#91782, it seems that by default format when letting "All format" is "eps".

So this one is in fact a dup of tdf#91782

*** This bug has been marked as a duplicate of bug 91782 ***