Download it now!
Bug 91829 - DRAW: Layout, Controls and Dimension Lines need improvement
Summary: DRAW: Layout, Controls and Dimension Lines need improvement
Status: RESOLVED DUPLICATE of bug 90244
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
5.0.0.0.alpha0+ Master
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-06-03 12:44 UTC by Philippe Jung
Modified: 2018-01-11 10:26 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Inkscape Layers Panel (34.53 KB, image/png)
2015-06-03 15:43 UTC, Gabriel Diosan
Details
GIMP move tool options (8.93 KB, image/png)
2015-06-10 20:58 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Jung 2015-06-03 12:44:45 UTC
1) These items would benefit from a "(check) Visible" context menu
2) If objects belongs to layers, why can I move an object from a layer if it belongs to a layer that is not the current one (at least, with no knowledge of Draw, that is what I expect)
Comment 1 Gabriel Diosan 2015-06-03 14:55:32 UTC
Hi Philippe

I had a look into the issues you raised.

1) Layers can be marked as "Visible" by double clicking on the layer tab (Layout, Controls, Dimension Lines or any other layer tab) and using the "Visible" checkbox in the window that opens.

2) I checked Inkscape to see how it deals with layers, and it allows you to move objects in other layers, even if that is not the layer that you have selected. 

I agree with you though that the three tabs at the bottom do not seem to add much value or push the user towards using layers. In addition, it is not immediately obvious that they are layers and that they can be made visible or not visible.

Perhaps this bug report should therefore focus more on making layers in Draw more useful and usable. I won't change the bug status just yet, as I would like to wait for someone else to chime in on this with their thoughts but at the least it will require input from the UX team.

Gabriel
Comment 2 Philippe Jung 2015-06-03 15:32:06 UTC
> 1) Layers can be marked as "Visible" by double clicking

Double click on a tab in not natural (at least for me). I left clicked & right clicked. 


> 2) I checked Inkscape to see how it deals with layers, and it allows you to
> move objects in other layers, even if that is not the layer that you have
> selected. 

I knew software where a layer can be protected: protected: objects don't move / cannot be selected.

> I agree with you though that the three tabs at the bottom do not seem to add
> much value or push the user towards using layers. 

The real question is why these layer names ? What use case are we supposed to handle?

To make it clear:
- in controls layer I expect to see only Buttons, Radio, Toolboxes, Fields,
- in dimension lines, I expect to see lines. Just lines. Lines can also displat length. I will accept that surfaces are displayed for rectangles and circles.

So reading these labels, I wondered if I was really in a drawing tool. 

> In addition, it is not
> immediately obvious that they are layers and that they can be made visible
> or not visible.

Other software tend to render layers as stack. It looks more like layers.

And thanks Gabriel :-)
Comment 3 Gabriel Diosan 2015-06-03 15:42:39 UTC
>I knew software where a layer can be protected: protected: objects don't move / >cannot be selected.

Yes, in Inkscape for example a layer can be locked and the objects within it cannot be modified until the layer is unlocked.

>The real question is why these layer names ? What use case are we supposed to >handle?

Not sure, but it should probably refer to layers more generally. Perhaps it should just read Layer 1, Layer 2 etc and let the user rename them as they wish.

>Other software tend to render layers as stack. It looks more like layers.

That's right. I have will attach a screenshot from Inkscape which shows its layer stack. A stack is more intuitive of how layers actually work (in my opinion).

>And thanks Gabriel :-)

No problem :)
Comment 4 Gabriel Diosan 2015-06-03 15:43:20 UTC
Created attachment 116261 [details]
Inkscape Layers Panel
Comment 5 Buovjaga 2015-06-10 14:54:12 UTC
I'm sold, let's set to NEW.
Comment 6 Gabriel Diosan 2015-06-10 15:44:20 UTC
Hi Beluga

I think this bug will need the UX team to provide input. Should we leave the component as "Draw" or change it to "UX advice"?

Gabriel
Comment 7 Buovjaga 2015-06-10 15:53:37 UTC
Ok let's set component to ux-advise.
Comment 8 Gabriel Diosan 2015-06-10 15:57:23 UTC
(In reply to Beluga from comment #7)
> Ok let's set component to ux-advise.

Thanks Beluga :)
Comment 9 Yousuf Philips (jay) (retired) 2015-06-10 20:58:14 UTC
Created attachment 116448 [details]
GIMP move tool options

(In reply to Philippe Jung from comment #0)
> 1) These items would benefit from a "(check) Visible" context menu

The context menu needs checkboxes for Visible and Locked for all layers (you can add more than the 3 default ones), which would reduce users from having to enter the 'Modify Layer' dialog. This is something that i proposed as an improvement to navigator (bug 90244).

> 2) If objects belongs to layers, why can I move an object from a layer if it
> belongs to a layer that is not the current one (at least, with no knowledge
> of Draw, that is what I expect)

This is the default state also for GIMP, but a user can change this setting temporarily by pressing shift, or permanently by changing the radio button option in the move tool options. Layers are an advanced feature in Draw and the not being able to click an object in Draw that is on another layer if you are not in it, would likely cause more problems than it would solve.
Comment 10 Regina Henschel 2015-06-11 18:44:08 UTC
The layer "Controls" is named that way, because a "control"-object is put on that layer as default.
The layer "Dimension Lines" is named that way, because a "dimension line"-object is put on that layer as default.
The name of the layers correspond exactly to their function.

Layers in Draw are a grouping tool. The stack of the objects is independent of the layer. For details see my comment and attachment to bug 90244.

In regard to handling of visible/printable/lock I refer to my suggestion in bug 89130, comment 2.

The "modify"-dialog has checkboxes for visible, printable and lock, there is no need for other checkboxes.

Do you got in touch with people, who use Draw in their profession?
Comment 11 Gabriel Diosan 2015-06-12 10:24:19 UTC
There seems to be a fair bit of overlap between bug 90244 and this one as they both relate to how layers are used in Draw. I am wondering whether we should mark this bug as a duplicate.

Anyone else have thoughts on this?

Gabriel
Comment 12 Yousuf Philips (jay) (retired) 2015-06-12 18:44:09 UTC
Bug 89130 covers the issue of adding checkboxes to the context menu, so there isnt a need to discuss that aspect here.
Comment 13 Robinson Tryon (qubit) 2016-08-25 05:39:25 UTC Comment hidden (obsolete)
Comment 14 Heiko Tietze 2018-01-11 10:26:22 UTC
Proposals how to improve the Navigator are in bug 90244 (or read this https://design.blog.documentfoundation.org/2016/07/31/how-the-navigator-may-support-object-handling-in-libreoffice-draw/). Moving an object from one layer to another should work intuitively by moving a tree node to another parent (with proper labels).

Let's continue the discussion there.

*** This bug has been marked as a duplicate of bug 90244 ***