Bug Hunting Session
Bug 91850 - Roundtripping drawing in .docx results in Mirror image in Word (but not Writer)
Summary: Roundtripping drawing in .docx results in Mirror image in Word (but not Writer)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX
  Show dependency treegraph
 
Reported: 2015-06-04 04:52 UTC by Luke
Modified: 2017-10-06 04:34 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Sample drawing that mirrored on roundtrip in Word (15.86 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2015-06-04 04:52 UTC, Luke
Details
Screenshot of Word vs Writer (189.69 KB, image/png)
2015-06-04 04:54 UTC, Luke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2015-06-04 04:52:48 UTC
Created attachment 116271 [details]
Sample drawing that mirrored on roundtrip in Word

Steps to reproduce:
1. Open Reverse Bug.docx in Writer
2. Save
3. Open in Word
Comment 1 Luke 2015-06-04 04:54:06 UTC
Created attachment 116272 [details]
Screenshot of Word vs Writer
Comment 2 steve -_- 2015-06-05 07:36:34 UTC
Nice finding. Thanks for the report Luke.

Confirmed on OSX with nightly from today. → NEW
Comment 3 Luke 2015-06-14 16:32:01 UTC
Adding Andras whose been improving the DrawingML export filters.
Comment 4 Luke 2016-02-04 05:29:04 UTC
Andras,
This appears to only affect grouped shapes. Are we dealing with two bugs here?
1) A FILESAVE double rotate bug like you fixed in Bug 92077
2) A FILEOPEN bug only applying one of the rotations for grouped shapes
Comment 5 Andras Timar 2016-02-04 07:41:40 UTC
(In reply to Luke from comment #4)
> Andras,
> This appears to only affect grouped shapes. Are we dealing with two bugs
> here?
> 1) A FILESAVE double rotate bug like you fixed in Bug 92077
> 2) A FILEOPEN bug only applying one of the rotations for grouped shapes

I agree that this bug is both an export and an import bug. I think that the fix of Bug 92077 does not help, because there are several code paths for exporting shapes, and it fixed one special case.
Comment 6 Luke 2017-09-27 16:00:16 UTC
This has been fixed sometime in the past month or so.

Works for me in  Version: 6.0.0.0.alpha0+ (x64)
Build ID: 892c719fffa06de4c7aeab497326cad7bae9e5c6