Bug Hunting Session
Bug 91890 - Impress Crash when click on Transition icon in sidebar
Summary: Impress Crash when click on Transition icon in sidebar
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.1.0.0.alpha0+ Master
Hardware: x86-64 (AMD64) Linux (All)
: medium critical
Assignee: Rishabh
URL:
Whiteboard: target:5.1.0 target:5.0.0.0.beta3
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2015-06-06 11:09 UTC by Philippe Jung
Modified: 2016-10-25 19:24 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Working slidetransitionspanel.ui (17.14 KB, text/plain)
2015-06-07 21:43 UTC, Philippe Jung
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Jung 2015-06-06 11:09:34 UTC
Editing the title of a slide
Open the Font size popup in the sidebar
While open click on the Transition icon to open the transition panel

soffice.bin: /home/philippe/src/git-repo/libreoffice/master/vcl/source/window/layout.cxx :1390 : virtual const vcl::Window* VclFrame::get_child() const:  l'assertion « GetChildCount() == 2 » a échoué.

Program received signal SIGABRT, Aborted.
0x00007ffff74ddcc9 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
56	../nptl/sysdeps/unix/sysv/linux/raise.c: Aucun fichier ou dossier de ce type.
(gdb) bt
#0  0x00007ffff74ddcc9 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
#1  0x00007ffff74e10d8 in __GI_abort () at abort.c:89
#2  0x00007ffff74d6b86 in __assert_fail_base (fmt=0x7fffde6db05f "%s%s%s :%u : %s%s l'assertion « %s » a échoué.\n%n", 
    assertion=assertion@entry=0x7ffff224f2c9 "GetChildCount() == 2", 
    file=file@entry=0x7ffff224f250 "/home/philippe/src/git-repo/libreoffice/master/vcl/source/window/layout.cxx", line=line@entry=1390, 
    function=function@entry=0x7ffff2252d60 <VclFrame::get_child() const::__PRETTY_FUNCTION__> "virtual const vcl::Window* VclFrame::get_child() const")
    at assert.c:92
#3  0x00007ffff74d6c32 in __GI___assert_fail (assertion=0x7ffff224f2c9 "GetChildCount() == 2", 
    file=0x7ffff224f250 "/home/philippe/src/git-repo/libreoffice/master/vcl/source/window/layout.cxx", line=1390, 
    function=0x7ffff2252d60 <VclFrame::get_child() const::__PRETTY_FUNCTION__> "virtual const vcl::Window* VclFrame::get_child() const") at assert.c:101
#4  0x00007ffff1c3ba7f in VclFrame::get_child (this=0x3aebb80) at /home/philippe/src/git-repo/libreoffice/master/vcl/source/window/layout.cxx:1390
#5  0x00007ffff1c3b400 in VclFrame::calculateRequisition (this=0x3aebb80) at /home/philippe/src/git-repo/libreoffice/master/vcl/source/window/layout.cxx:1306
#6  0x00007ffff1c351a9 in VclContainer::GetOptimalSize (this=0x3aebb80) at /home/philippe/src/git-repo/libreoffice/master/vcl/source/window/layout.cxx:35
#7  0x00007ffff1ce7bc2 in vcl::Window::get_ungrouped_preferred_size (this=0x3aebb80)
    at /home/philippe/src/git-repo/libreoffice/master/vcl/source/window/window2.cxx:1761
#8  0x00007ffff1ce7c97 in vcl::Window::get_preferred_size (this=0x3aebb80) at /home/philippe/src/git-repo/libreoffice/master/vcl/source/window/window2.cxx:1776
#9  0x00007ffff1c3573a in VclContainer::getLayoutRequisition (rWindow=...) at /home/philippe/src/git-repo/libreoffice/master/vcl/source/window/layout.cxx:118
#10 0x00007ffff1c35c3e in VclBox::calculateRequisition (this=0x1dd3570) at /home/philippe/src/git-repo/libreoffice/master/vcl/source/window/layout.cxx:190
#11 0x00007ffff1c351a9 in VclContainer::GetOptimalSize (this=0x1dd3570) at /home/philippe/src/git-repo/libreoffice/master/vcl/source/window/layout.cxx:35
#12 0x00007ffff1ce7bc2 in vcl::Window::get_ungrouped_preferred_size (this=0x1dd3570)
    at /home/philippe/src/git-repo/libreoffice/master/vcl/source/window/window2.cxx:1761
#13 0x00007ffff1ce7c97 in vcl::Window::get_preferred_size (this=0x1dd3570) at /home/philippe/src/git-repo/libreoffice/master/vcl/source/window/window2.cxx:1776
#14 0x00007ffff1c3573a in VclContainer::getLayoutRequisition (rWindow=...) at /home/philippe/src/git-repo/libreoffice/master/vcl/source/window/layout.cxx:118
#15 0x00007fffb85a5b1b in PanelLayout::GetOptimalSize (this=0x164f400) at /home/philippe/src/git-repo/libreoffice/master/svx/source/sidebar/PanelLayout.cxx:43
#16 0x00007fffb85a5d49 in PanelLayout::setPosSizePixel (this=0x164f400, nX=0, nY=0, nWidth=0, nHeight=0, nFlags=Size)
    at /home/philippe/src/git-repo/libreoffice/master/svx/source/sidebar/PanelLayout.cxx:89
#17 0x00007ffff1ce61c6 in vcl::Window::SetSizePixel (this=0x164f400, rNewSize=...)
    at /home/philippe/src/git-repo/libreoffice/master/vcl/source/window/window2.cxx:1420
#18 0x00007ffff1ce6315 in vcl::Window::SetOutputSizePixel (this=0x164f400, rNewSize=...)
    at /home/philippe/src/git-repo/libreoffice/master/vcl/source/window/window2.cxx:1433
#19 0x00007fffba06682a in sd::sidebar::PanelBase::Resize (this=0x3befd10) at /home/philippe/src/git-repo/libreoffice/master/sd/source/ui/sidebar/PanelBase.cxx:69
#20 0x00007ffff1c30286 in vcl::Window::ImplCallResize (this=0x3befd10) at /home/philippe/src/git-repo/libreoffice/master/vcl/source/window/event.cxx:457
#21 0x00007ffff1cf7a44 in vcl::Window::Show (this=0x3befd10, bVisible=true, nFlags=NONE) at /home/philippe/src/lodev/master/vcl/source/window/window.cxx:2386
#22 0x00007ffff4724cbd in sfx2::sidebar::SidebarPanelBase::SidebarPanelBase(rtl::OUString const&, com::sun::star::uno::Reference<com::sun::star::frame::XFrame> const&, vcl::Window*, com::sun::star::ui::LayoutSize const&) () from /home/philippe/src/lodev/master/instdir/program/libsfxlo.so
#23 0x00007ffff4724ee0 in sfx2::sidebar::SidebarPanelBase::Create(rtl::OUString const&, com::sun::star::uno::Reference<com::sun::star::frame::XFrame> const&, vcl::Window*, com::sun::star::ui::LayoutSize const&) () from /home/philippe/src/lodev/master/instdir/program/libsfxlo.so
#24 0x00007fffba06766c in sd::sidebar::PanelFactory::createUIElement (this=0x7fffc8180b70, rsUIElementResourceURL=..., rArguments=...)
    at /home/philippe/src/git-repo/libreoffice/master/sd/source/ui/sidebar/PanelFactory.cxx:154
#25 0x00007fffd69af9f4 in (anonymous namespace)::UIElementFactoryManager::createUIElement(rtl::OUString const&, com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> const&) () from /home/philippe/src/lodev/master/instdir/program/../program/libfwklo.so
#26 0x00007ffff47204cf in sfx2::sidebar::SidebarController::CreateUIElement(com::sun::star::uno::Reference<com::sun::star::awt::XWindowPeer> const&, rtl::OUString const&, bool, sfx2::sidebar::Context const&) () from /home/philippe/src/lodev/master/instdir/program/libsfxlo.so
#27 0x00007ffff4720e44 in sfx2::sidebar::SidebarController::CreatePanel(rtl::OUString const&, vcl::Window*, bool, sfx2::sidebar::Context const&) ()
   from /home/philippe/src/lodev/master/instdir/program/libsfxlo.so
Comment 1 Julien Nabet 2015-06-06 12:00:53 UTC
On pc Debian x86-64 with master sources updated today, I could reproduce this.
Comment 2 Philippe Jung 2015-06-07 15:55:28 UTC
Also happens in LO50
Comment 3 Philippe Jung 2015-06-07 20:20:58 UTC
Introduced by a7b926243b300daf195467111e10a7bd481828a0

Author: Rishabh Kumar <kris.kr296@gmail.com>
Date:   Wed May 27 19:26:43 2015 +0530

    tdf#87862: Rearranging the lower half of slide transition tab
    
    Follow up commit for the minor tweaks
    
    Change-Id: I9f274e38c7d0adfc431dc9a11000c3ce9fad3a3e
    Reviewed-on: https://gerrit.libreoffice.org/15929
    Reviewed-by: Yousuf Philips <philipz85@hotmail.com>
    Tested-by: Yousuf Philips <philipz85@hotmail.com>
Comment 4 Philippe Jung 2015-06-07 20:28:27 UTC
Caused by the <placeholder/> tag
Seems to be not supported by our framework
Comment 5 Yousuf Philips (jay) (retired) 2015-06-07 20:55:24 UTC
No crash for me. Of course with the drop down open, clicking on the transition icon requires 2 clicks to happen.

Version: 5.1.0.0.alpha1+
Build ID: 587006cac508616f486aea45e265a170bcccdc87
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-06-06_00:16:39
Comment 6 Philippe Jung 2015-06-07 21:43:39 UTC
Created attachment 116361 [details]
Working slidetransitionspanel.ui

Rishabh, the attached file works
Comment 7 Philippe Jung 2015-06-07 21:49:38 UTC
(In reply to Yousuf (Jay) Philips from comment #5)
> No crash for me. Of course with the drop down open, clicking on the
> transition icon requires 2 clicks to happen.
> 
> Version: 5.1.0.0.alpha1+
> Build ID: 587006cac508616f486aea45e265a170bcccdc87
> TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time:
> 2015-06-06_00:16:39

Crash because of assert => will only crash with debug build.
Comment 8 Commit Notification 2015-06-08 17:06:03 UTC
Rishabh Kumar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f6eb112faae4ba79616a40f34a90eec13093cc05

tdf#91890:Impress Crash when click on Transition icon in sidebar

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2015-06-08 18:12:22 UTC
Rishabh Kumar committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=15ba43a052a5e5cc842feed221e8e1cb43575731&h=libreoffice-5-0

tdf#91890:Impress Crash when click on Transition icon in sidebar

It will be available in 5.0.0.0.beta3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Philippe Jung 2015-06-09 05:54:58 UTC
Tested in lo50 and lo51
No more crash
Comment 11 steve -_- 2015-06-09 07:56:17 UTC
verified as of comment 10