Bug 91946 - Direct2D font rendering in Windows
Summary: Direct2D font rendering in Windows
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other Windows (All)
: high enhancement
Assignee: Not Assigned
URL: https://msdn.microsoft.com/en-us/libr...
Whiteboard: target:5.2.0 target:5.3.0
Keywords:
Depends on: HarfBuzz
Blocks: 46817 Font-Rendering 85290 85453 VCL-OpenGL
  Show dependency treegraph
 
Reported: 2015-06-08 19:55 UTC by Adolfo Jayme Barrientos
Modified: 2017-06-06 13:20 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Comparison between Direct2D (above) versus GDI+ (below): notice the smoother edges in D2D (26.02 KB, image/png)
2015-08-18 08:54 UTC, Adolfo Jayme Barrientos
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Adolfo Jayme Barrientos 2015-06-08 19:55:41 UTC
Users are expecting LibreOffice to render fonts more faithfully and with better antialiasing, so we need to move to newer APIs. DirectWrite/Direct2D is such an API, available since Windows Vista SP2 (Platform Update) and in every newer version of Windows, replacing the obsolete GDI++.

http://en.wikipedia.org/wiki/Direct2D#Uses_and_performance

This task could be turned into a GSoC project, maybe.
Comment 1 Adolfo Jayme Barrientos 2015-08-18 08:54:37 UTC
Created attachment 117991 [details]
Comparison between Direct2D (above) versus GDI+ (below): notice the smoother edges in D2D
Comment 2 Adolfo Jayme Barrientos 2016-03-09 05:19:36 UTC
https://cgit.freedesktop.org/libreoffice/core/commit/?id=64172644c898d4f5f29494b2f8b5fbcdc2cd9824

DirectWrite rendering for Graphite to work around ExTextOut bug
Comment 3 Xisco Faulí 2016-09-15 22:30:57 UTC
Hello,
Is this bug fixed?
If so, could you please close it as RESOLVED FIXED?
Comment 4 Volga 2017-04-15 05:05:41 UTC
Could you please checking checking it with vertical text layout?
Comment 5 V Stuart Foote 2017-06-06 06:04:42 UTC
Would say DirectWrite/Direct2D was implemented to support OpenGL rendering, but not fully.

Per ESC (2017-05-24) for the 5.5/6.0 build we will fully drop XP and Vista support. That decision now provides opportunity to fully refactor Windows graphics to DirectWrite/Direct2D rendering.

Khaled completed Akash's work on HarfBuzz Common Layout (bug 89870) in 5.3 and 5.4 they've routed more of the Windows rendering through DirectWrite calls expanding on work by Tor, Tim and Martin for Graphite support. 

But the DirectWrite/Direct2D implemented thus far was only a subset, it now needs refinement (bug 107521). And needs support for floating point positioning (bug 103322) to support sub-pixel rendering. While loss of grayscale mode antialiasing with our DirectWrite implementation is causing issues for non-OpenGL Windows users (bug 106990).

@Adolfo, you OK with closing this?

=-ref-=
https://msdn.microsoft.com/en-us/library/windows/desktop/hh802480(v=vs.85).aspx
Comment 6 Adolfo Jayme Barrientos 2017-06-06 09:03:13 UTC
Sure
Comment 7 Timur 2017-06-06 13:20:30 UTC
Adolfo, please confirm bug 107521 then.