Download it now!
Bug 92129 - FILEOPEN: .docx FORMATTING wrong paragraph numbering
Summary: FILEOPEN: .docx FORMATTING wrong paragraph numbering
Status: RESOLVED DUPLICATE of bug 97417
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX
  Show dependency treegraph
 
Reported: 2015-06-17 07:54 UTC by ebrian_dale
Modified: 2017-11-02 15:28 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
screen shot of original and wrongly converted page where it started (838.69 KB, application/pdf)
2015-06-17 07:54 UTC, ebrian_dale
Details
original document with substituted text (261.47 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2015-07-19 07:29 UTC, ebrian_dale
Details
pdf exported from LO opening original docx file (502.40 KB, application/x-download)
2015-07-19 07:37 UTC, ebrian_dale
Details
docx file as saved by LOW (174.91 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2015-07-19 07:42 UTC, ebrian_dale
Details
odt file as saved by LOW from original .docx (132.17 KB, application/vnd.oasis.opendocument.text)
2015-07-19 07:46 UTC, ebrian_dale
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ebrian_dale 2015-06-17 07:54:04 UTC
Created attachment 116600 [details]
screen shot of original and wrongly converted page where it started

Opening a Word document in .docx format in LO Writer adds numbering not present in the orginal to almost every paragraph after the start of a section about halfway through the document following a table (but not the first table in the document). This is not present in the original document when opened in Word 2007 SP3 or Word Viewer 2003 SP3. It remains wrong after saving as .odt and then reopening. I have attached a screen shot of part of the original Word document and part of the LO wrong conversion where the problem starts.  I cannot provide the entire document for public view.
Comment 1 raal 2015-06-17 11:57:09 UTC Comment hidden (obsolete)
Comment 2 ebrian_dale 2015-07-19 07:29:02 UTC
Created attachment 117323 [details]
original document with substituted text

This is the original document with as much identifying data removed as practicable, text replaced with "x"
Comment 3 ebrian_dale 2015-07-19 07:37:12 UTC
Created attachment 117324 [details]
pdf exported from LO opening original docx file

Opening the docx file in LO generates faulty paragraph numbering after the table numbered 5.2. This is an export of the file from LO as a pdf so you can see what it looks like to me in case you can't see this at first.
Comment 4 ebrian_dale 2015-07-19 07:42:33 UTC
Created attachment 117326 [details]
docx file as saved by LOW

This is a save in .docx format by LOW from the .docx file opened by LOW. It looks basically the same as the pdf export file attached above.
Comment 5 ebrian_dale 2015-07-19 07:46:17 UTC
Created attachment 117327 [details]
odt file as saved by LOW from original .docx

For completeness, this is the .odt file saved by LOW from the original.docx ie not from the LO saved .docx
Comment 6 ebrian_dale 2015-07-19 07:48:21 UTC
I have uploaded various files which demonstrate the problem I am seeing.
Comment 7 Buovjaga 2015-07-29 20:19:02 UTC
Compared with Word viewer and confirmed.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+ (x64)
Build ID: e92a8b92072284fd7c37d7bb3e1e8fe72a185f35
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-07-22_21:46:26
Locale: fi-FI (fi_FI)
Comment 8 ebrian_dale 2015-09-17 06:50:05 UTC
I have retested the original.docx file attached earlier by opening it with the latest released fresh version of LO 5.0.1.2 (Writer). Opening the .docx document displays the wrong numbering from page 57 onwards, starting with the table which was numbered 5.2 in the original (the same point where the problem occurred with earlier LO versions). (There is thus now no need to save the document to demonstrate the problem.)
Comment 9 QA Administrators 2016-09-20 10:32:05 UTC Comment hidden (obsolete, spam)
Comment 10 Justin L 2017-11-02 15:28:51 UTC
fixed in LO 5.1.1 by the fix for bug 97417

*** This bug has been marked as a duplicate of bug 97417 ***