Bug 97417 - DOCX import: paragraphs wrongly in a list in particular document
Summary: DOCX import: paragraphs wrongly in a list in particular document
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.6.2 release
Hardware: All All
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: target:5.2.0 target:5.1.1 target:5.4...
Keywords: bisected, regression
: 92129 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-01-28 16:07 UTC by Michael Stahl (CIB)
Modified: 2018-08-15 14:54 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Stahl (CIB) 2016-01-28 16:07:32 UTC
DOCX file: http://bugs.documentfoundation.org/attachment.cgi?id=120911

the main difference between a ODT file exported with and without the
commit below is that we get extra paragraph numbering since
the paragraph that starts with "Verze": now all following paragraphs
are numbered.

that also happens to trigger a layout crash, see bug 96172


2b78f2cd7b9e4bab0f3b3b9119238f36a1bbc7b2 is the first bad commit
commit 2b78f2cd7b9e4bab0f3b3b9119238f36a1bbc7b2
Author: Michael Stahl <mstahl@redhat.com>
Date:   Wed Mar 5 23:29:06 2014 +0100

    rhbz#988516: DOCX import: fix context stack when importing header/footer
    
    When a header/footer substream is parsed, a ParagraphGroup is started,
    but not ended; so the properties of the last paragraph in the
    header/footer are applied to a paragraph in the body.
    
    The obvious fix to add a call to endParagraphGroup() at the end of w:p
    element breaks table cells.  So add a call to endParagraphGroup() at
    the end of the "hdr"/"ftr" element.
    
    (The problem in the bugdoc became much more visible with commit
    ca555c596043c88894b964ac5e21f5a7271d5f3b, but was there before)
Comment 1 Michael Stahl (CIB) 2016-02-01 12:10:33 UTC
caused by a paragraph with a section break that has numbering applied.

fixed on master
Comment 2 Commit Notification 2016-02-01 12:11:23 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=57def64bec0853de7d6f4243e31e8e9650491914

writerfilter: tdf#97417: don't insert numbering on end-of-section

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Commit Notification 2016-02-02 12:08:18 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=71a8cac070a2c33bf6b66766d84b08c258a6aaf9&h=libreoffice-5-1

writerfilter: tdf#97417: don't insert numbering on end-of-section

It will be available in 5.1.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Adolfo Jayme 2016-12-21 06:54:57 UTC
https://cgit.freedesktop.org/libreoffice/core/commit/?id=893698741a78e56d74b87caff24f67742ddd892b

related to tdf#97417: fix unit test page count
Comment 5 Commit Notification 2016-12-21 07:06:46 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=893698741a78e56d74b87caff24f67742ddd892b

related to tdf#97417: fix unit test page count

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2016-12-21 07:18:12 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c829e01e973ac32fb625925ce83f843ad30d94db

related to tdf#97417: fix unit test's early para numbering

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2016-12-22 06:14:11 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7e38087bf2a4d9d9edd0c98f965531002e0be777&h=libreoffice-5-3

related to tdf#97417: fix unit test page count

It will be available in 5.3.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2016-12-22 07:45:05 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a21035c779167ec0e84ac21b9e5cdf6f2553ab30&h=libreoffice-5-3

related to tdf#97417: fix unit test's early para numbering

It will be available in 5.3.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Justin L 2017-11-02 15:28:51 UTC
*** Bug 92129 has been marked as a duplicate of this bug. ***