Bug 92158 - Input fields in editable protected section only partially editable
Summary: Input fields in editable protected section only partially editable
Status: RESOLVED DUPLICATE of bug 64432
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: x86 (IA32) Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-06-18 14:32 UTC by Jörg Nierhoff
Modified: 2015-10-14 08:37 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample document with input field in protected/editable section (9.38 KB, application/vnd.oasis.opendocument.text)
2015-06-18 14:32 UTC, Jörg Nierhoff
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jörg Nierhoff 2015-06-18 14:32:05 UTC
Created attachment 116625 [details]
Sample document with input field in protected/editable section

Input fields in protected and editable sections can not be edited with backspace or del keys. Marking parts of the content of the input field and overwriting the conent works as intended.

Steps to reproduce this Bug:

1. Create new writer document
2. Insert a input field (Insert -> Fields -> More Fields...)
3. Mark the area that contains the input field
4. Insert a section and set the section to protected: true and editable: true

The input field should be editable and all other parts of the section should be read-only. In the current 4.4.X builds you can type to the input field and it is possible to select content from the input field and overwrite the content. But it is not possible to delete content via backspace or delete keys.
Comment 1 Buovjaga 2015-06-19 19:29:11 UTC
Repro with steps from desc.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 437210d58f32177ef1829d704f7f4d2f1bbfbfdd
TinderBox: Win-x86@39, Branch:master, Time: 2015-06-18_07:21:56
Locale: fi-FI (fi_FI)
Comment 2 Kulo 2015-10-08 06:46:18 UTC
Also reproducible with Windows 7 Pro x64
Version: 5.0.2.2 (x64)
Build-ID: 37b43f919e4de5eeaca9b9755ed688758a8251fe
Gebietsschema: de-AT (de_AT)
Comment 3 Kulo 2015-10-14 08:37:18 UTC

*** This bug has been marked as a duplicate of bug 64432 ***