Bug 92168 - Wrong insert column/row icon in Writer
Summary: Wrong insert column/row icon in Writer
Status: RESOLVED DUPLICATE of bug 90790
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.0.0.beta3
Hardware: Other Linux (All)
: low trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-06-18 23:30 UTC by Francisco
Modified: 2015-06-21 16:26 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
wrong icon in LibO 5.0b3 (53.02 KB, image/png)
2015-06-20 21:24 UTC, Francisco
Details
Correct icon in LibO 4.4.3 (96.90 KB, image/png)
2015-06-20 21:28 UTC, Francisco
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Francisco 2015-06-18 23:30:48 UTC
As the title describes, the column toolbar shows an incorrect "insert columns right"/"insert row below" icon in Writer when using Oxygen or Breeze icon themes. I can't state about other themes, because I don't know them.

The PNG icons seems to be there, because I manually copied the images_breeze.zip file from my LibO 5.0b3 directory, into the 4.4.3 one. After creating an ODT with version 4.4.3, the icons are correct. Moreover, the icons are correct in Calc and Impress.


Steps
1) Create a new ODT document
2) Insert a table
3) See toolbar

Result:
Button icons for insert row/column doesn't follow the icon themes Oxygen nor Breeze.

Expected
Button icons should respect the icon theme, if they exist.
Comment 1 Francisco 2015-06-18 23:31:31 UTC
Version: 5.0.0.0.beta3
Build ID: 96345c15d8ab19c49014f055fe41ba8e1f421e5c
Locale: es-AR (es_AR.UTF-8)

OS: Kubuntu 12.04/14.04 x86_64
Comment 3 Adolfo Jayme 2015-06-20 19:47:43 UTC
Screenshots?

> […] because I manually copied the images_breeze.zip file from my LibO 5.0b3
> directory, into the 4.4.3 one

Now I’m confused. Is this bug about wrong icons in 4.4.3 or in 5.0? Note that if the icons display wrongly in 4.4.3, then this is NOTABUG, because the Breeze theme was not developed with 4.4.x in mind. The menus have changed in 5.0.x.
Comment 4 Francisco 2015-06-20 21:21:26 UTC
(In reply to Adolfo Jayme from comment #3)
> Screenshots?
> 
> > […] because I manually copied the images_breeze.zip file from my LibO 5.0b3
> > directory, into the 4.4.3 one
> 
> Now I’m confused. Is this bug about wrong icons in 4.4.3 or in 5.0? Note
> that if the icons display wrongly in 4.4.3, then this is NOTABUG, because
> the Breeze theme was not developed with 4.4.x in mind. The menus have
> changed in 5.0.x.

The bug is in 5.0... and I know it because I'm using Breeze, which is not present in the vanilla 4.4, and the shown icon is correct.
Comment 5 Francisco 2015-06-20 21:24:20 UTC
Created attachment 116688 [details]
wrong icon in LibO 5.0b3

This is how I see the "Insert Column/Row" butons using LibO 5.0b3
Comment 6 Francisco 2015-06-20 21:28:00 UTC
Created attachment 116689 [details]
Correct icon in LibO 4.4.3

This is how I see the "Insert Column/row" buttons in LibO 4.4.3
Comment 7 Yousuf Philips (jay) (retired) 2015-06-21 16:26:33 UTC
This is a problem with galaxy's links.txt not correctly doing as it should do.

*** This bug has been marked as a duplicate of bug 90790 ***