Bug 92384 - Search bar cannot be closed due to overlaid "search key not found" message (only with small window width)
Summary: Search bar cannot be closed due to overlaid "search key not found" message (o...
Status: CLOSED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.4.2.2 release
Hardware: x86-64 (AMD64) All
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 92816 100976 (view as bug list)
Depends on:
Blocks: Find-Toolbar
  Show dependency treegraph
 
Reported: 2015-06-27 13:51 UTC by David
Modified: 2020-09-09 15:15 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
92384 fixed in 7.0.0.1RC1 (328.89 KB, video/quicktime)
2020-07-06 19:47 UTC, steve
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David 2015-06-27 13:51:49 UTC
The search bar at the bottom of the screen cannot be closed by pressing the "X" when the window is smaller than all of the elements of the search bar after a search is declared "search key not found". The closeout button is squashed and overlays the search field as well. Once the entire window is expanded to a suitable size to fit all the search bar components, the close out "X" button works.

To reiterate, in order to reproduce the problem:
1.) Open a document in LibreOffice.
2.) Resize the LibreOffice window to less than half the screen
3.) press control + F
4.) Search for a word that is not contained in the document
5.) See that "search key not found" pops up above the search field
6.) Attempt to close search bar at bottom left corner by pressing on the "X" button.

To clear problem:
1.) Expand the window to a bigger size.
2.) press the "X" button.
Comment 1 David 2015-06-27 13:53:08 UTC
Correction. Whenever the window is resized, the "search key not found" dialog disappears and permits clicking of the "X"
Comment 2 Buovjaga 2015-07-02 10:41:01 UTC
Reproduced partially. I was able to "dig out" the X from under the message by hovering over its bottom part and it was clickable most of the time.

Win 7 Pro 64-bit, Version: 4.4.4.3
Build ID: 2c39ebcf046445232b798108aa8a7e7d89552ea8
Locale: fi_FI

Version: 5.1.0.0.alpha1+ (x64)
Build ID: 3a6ec53eeeec71312f5ea890689f9c2ee79c2aac
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-07-01_02:24:40
Locale: fi-FI (fi_FI)

Ubuntu 15.04 64-bit 
Version: 4.4.4.3
Build ID: 40m0(Build:3)
Locale: en_US.UTF-8
Comment 3 Buovjaga 2015-07-18 19:37:56 UTC
*** Bug 92816 has been marked as a duplicate of this bug. ***
Comment 4 Buovjaga 2015-07-18 19:39:35 UTC
Improved summary.
Comment 5 steve 2016-04-12 09:53:15 UTC
Gone in master. Rather odd, and there's a ton of remaining issues for search, but this specific issues is indeed no longer happening.

So I am closing this one as WORKSFORME. Please file new bugs for remaining issues (or search if they already exists). Thanks.
Comment 6 Buovjaga 2016-07-26 11:07:49 UTC
This is actually still happening. Note that you have to resize the width before making any search.

Win 7 Pro 64-bit Version: 5.3.0.0.alpha0+
Build ID: 62442d9066ea553a4b68b8a93fa54748cbe96e06
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-07-19_00:20:50
Locale: fi-FI (fi_FI); Calc: CL
Comment 7 Buovjaga 2016-07-26 11:08:41 UTC
*** Bug 100976 has been marked as a duplicate of this bug. ***
Comment 8 QA Administrators 2017-09-01 11:19:58 UTC Comment hidden (obsolete)
Comment 9 Raphael Matias 2019-06-03 19:43:58 UTC Comment hidden (spam)
Comment 10 steve 2020-07-06 19:47:30 UTC
Unless I am (again) mistaken this looks fixed to my eyes (see attached screencast).
Comment 11 steve 2020-07-06 19:47:47 UTC
Created attachment 162730 [details]
92384 fixed in 7.0.0.1RC1
Comment 12 Buovjaga 2020-07-07 08:01:15 UTC
Yes, the not found message now does not pop over anything, but is hidden at the end of the bar.
Comment 13 steve 2020-07-09 08:25:48 UTC
@Buovjaga: That would be a different and new bug as it is a different problem. Maybe for mobile version only since no one really works in a writer window that narrow.
Comment 14 Buovjaga 2020-07-09 09:02:31 UTC
(In reply to steve -_- from comment #13)
> @Buovjaga: That would be a different and new bug as it is a different
> problem. Maybe for mobile version only since no one really works in a writer
> window that narrow.

I didn't say it was a bug and I don't see it as a bug.
Comment 15 Fred Silva 2020-09-09 13:58:40 UTC Comment hidden (spam)