Bug 92471 - FILESAVE: New DOCX export of text with highlighting works not for all colors
Summary: FILESAVE: New DOCX export of text with highlighting works not for all colors
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.0.2 rc
Hardware: Other Windows (All)
: medium normal
Assignee: Tamás Zolnai
URL:
Whiteboard: target:5.1.0 target:5.0.0
Keywords:
Depends on:
Blocks:
 
Reported: 2015-07-01 08:52 UTC by ralf.krapf
Modified: 2018-09-29 19:27 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (190.65 KB, image/png)
2015-07-01 08:53 UTC, ralf.krapf
Details
Original odt file (9.78 KB, application/vnd.oasis.opendocument.text)
2015-07-01 08:53 UTC, ralf.krapf
Details
Exported docx file with LO5002 (4.90 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2015-07-01 08:54 UTC, ralf.krapf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ralf.krapf 2015-07-01 08:52:29 UTC
System: Win 7x64, LO 5.0.0.2

The new text-highlighting from LO 5 does not work for all colors.

For example:
RGB#666600 does work
RGB#6666ff does not work (appears gray in WinWord 2010 or after reopened in LO5)

See the attached files.

Possible related Bugs: 64490, 65403, 65404

Cheers
Comment 1 ralf.krapf 2015-07-01 08:53:07 UTC
Created attachment 116962 [details]
Screenshot
Comment 2 ralf.krapf 2015-07-01 08:53:37 UTC
Created attachment 116963 [details]
Original odt file
Comment 3 ralf.krapf 2015-07-01 08:54:16 UTC
Created attachment 116964 [details]
Exported docx file with LO5002
Comment 4 Buovjaga 2015-07-03 12:35:30 UTC
Confirmed the wrongess, when using the default export option: Highlighting.
However, if you choose Tools - Options - Load/save - MSO - Export as: Shading, it works ok!

Win 8.1 32-bit MSO 2013
Version: 5.0.0.2
Build ID: a26d58f11b99b6aeddf7f7884effea188cc6e512
Locale: fi-FI (fi_FI)
Comment 5 Tamás Zolnai 2015-07-04 18:54:27 UTC
Hi,

MSO Highlighting attribute allows only 15 colors which means LO Highlighting needs to be converted to these colors during export. Other options is to use Shading setting as Beluga wrote.
You can find more information about MSO highlighting / shading color selection here: http://blogs.technet.com/b/hub/archive/2011/04/05/how-to-select-more-highlight-colors-in-word.aspx

On the other hand as I see this conversion can be better. That blue color in the example should be converted to a some blue color and not a grey one. I will check how we can improve the conversion.
Comment 6 ralf.krapf 2015-07-13 19:37:03 UTC
I see. Because not everyone is an expert in exporting,
"Shading" would be possibly the better default setting?

Cheers
Comment 7 Commit Notification 2015-07-14 08:38:40 UTC
Zolnai Tamás committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=16f9cf57e20ffbe34cb184f694f465708250a578

tdf#92471: Improve color conversion to MSO highlighting

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Tamás Zolnai 2015-07-14 09:11:35 UTC
(In reply to ralf.krapf from comment #6)
> I see. Because not everyone is an expert in exporting,
> "Shading" would be possibly the better default setting?

Highlighting is the default, because it is called highlighting in both programs (MSO Word and LO Writer), so it can be expected that highlighting (LO) is exported as highlighting (MSO).
I read also some user problems about that users can't remove highlighting in Word, because it was actually shading (it seems highlighting feature is more familiar in Word than shading):
http://www.wordbanter.com/showthread.php?t=85055

I added a better conversion algorithm now which works much better with LO standard color palette, so hopefully the conversion during export won't be a problem.
Comment 9 Commit Notification 2015-07-23 18:53:08 UTC
Zolnai Tamás committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9bde8bdab1024b24a71d56a4355a5eacca720007&h=libreoffice-5-0

tdf#92471: Improve color conversion to MSO highlighting

It will be available in 5.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2015-07-31 00:25:27 UTC
Zolnai Tamás committed a patch related to this issue.
It has been pushed to "libreoffice-5-0-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5c3a4419d10f1645fc1dd4d160b674a0b274cf2e&h=libreoffice-5-0-0

tdf#92471: Improve color conversion to MSO highlighting

It will be available in 5.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.