Bug 92537 - send via bluetooth crashes LibreOffice
Summary: send via bluetooth crashes LibreOffice
Status: VERIFIED DUPLICATE of bug 92308
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.0.0.alpha0+ Master
Hardware: Other Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, regression
Depends on:
Blocks:
 
Reported: 2015-07-04 05:43 UTC by Justin L
Modified: 2015-12-15 11:03 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Justin L 2015-07-04 05:43:42 UTC
LibreOffice crashes (exits without an error message) when going to Writer's file menu -> send -> send via bluetooth  (does not crash when using calc).

Steps to reproduce:
1.) Open LibreOffice and create a new writer document
2.) go to file menu -> Send -> Send via bluetooth  ::crash::

 0d72ed4f5bfc65a7938e017f56993ef2f58ecfae is the first bad commit
commit 0d72ed4f5bfc65a7938e017f56993ef2f58ecfae
Author: Matthew Francis <mjay.francis@gmail.com>
Date:   Wed May 27 20:07:10 2015 +0800

    source-hash-0d97d25d56a5a8466d698e0f5831f2072c8e8baf
    
    commit 0d97d25d56a5a8466d698e0f5831f2072c8e8baf
    Author:     Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
    AuthorDate: Sat Mar 14 18:34:28 2015 +0100
    Commit:     Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
    CommitDate: Mon Mar 16 13:24:07 2015 +0100
    
        use SwIterator for typed iteration
    
        Change-Id: Icc1a04304e182687a306e9d08cbf7d46b0adbee6
# bad: [fae0e8583cf7a430582973a2209cbd27a98321df] source-hash-e3167924fd28c8b854f23139dbf49f53e6282ef7
# good: [5b9dd620df316345477f0b6e6c9ed8ada7b6c091] source-hash-2851ce5afd0f37764cbbc2c2a9a63c7adc844311
git bisect start 'constbug-before-zolnai-good' 'oldest'
# good: [0c834d3931284f7d7b31be52cdc13cc6a65d43c8] source-hash-2813632238380e0bfe40c0e6404a07102cde1398
git bisect good 0c834d3931284f7d7b31be52cdc13cc6a65d43c8
# good: [9b696476a5fea146e0397d1bbc295602793b0b66] source-hash-bccefa4b0bdb899a51793dbbe0ae8fb4a39b8f59
git bisect good 9b696476a5fea146e0397d1bbc295602793b0b66
# good: [d477ec3aff63ec5ceabbf6090d841e5c3e2226b5] source-hash-08a9452b677bc68f56fbac3638cfaeff9f90b1eb
git bisect good d477ec3aff63ec5ceabbf6090d841e5c3e2226b5
# good: [284c04a0b2338f8ed8513bc1432ecc5ebfcc3402] source-hash-a788eea404b71ddca24eb13506fd51ea41485a69
git bisect good 284c04a0b2338f8ed8513bc1432ecc5ebfcc3402
# good: [43cd112fee404597f19c32854227fd303defc4f0] source-hash-aa580276e5415bdf7c5e6eba445f812acd1cbe32
git bisect good 43cd112fee404597f19c32854227fd303defc4f0
# good: [c0952124b4a6c3a6921949c63c8f50214e542f23] source-hash-9537ddcfc6711d864f442f280f0a82a8ccb00f0a
git bisect good c0952124b4a6c3a6921949c63c8f50214e542f23
# good: [beb55abd6d8c483bbe8e9885742c23b5e85335d3] source-hash-2ba8f4d2c0e24bc356ab72e4f00e27560f471f16
git bisect good beb55abd6d8c483bbe8e9885742c23b5e85335d3
# bad: [dfc554b5db5524f4a3c4b0c9c74fceffb4b72308] source-hash-d4267231754c1e6b03c7723a6fecc46750e7c780
git bisect bad dfc554b5db5524f4a3c4b0c9c74fceffb4b72308
# good: [5e149beab420175bb00a116228daa251ca6dd21d] source-hash-13a06aad7c4696e0ae48bfdbdabab18eb9f81d38
git bisect good 5e149beab420175bb00a116228daa251ca6dd21d
# good: [90ba71b3edee53551b36d0c7f0e94cf358ad32d1]
Comment 1 Björn Michaelsen 2015-07-04 10:37:31 UTC
Likely the same root cause as as tdf#92308, which just got fixed on master and libreoffice 5.0
Comment 2 Björn Michaelsen 2015-07-04 11:07:25 UTC
Not reproducible anymore on master. Reproducible on master when reverting http://cgit.freedesktop.org/libreoffice/core/commit/?id=6cadfe0f07659235c6438c345d501eca89b411d5 thus marking as dupe.

*** This bug has been marked as a duplicate of bug 92308 ***
Comment 3 Justin L 2015-07-07 19:38:42 UTC
Thanks. I'm can confirm that bluetooth is fixed for me.
Comment 4 Robinson Tryon (qubit) 2015-12-15 11:03:24 UTC Comment hidden (obsolete)