Download it now!
Bug 92573 - Writer crash when attempting to open one file.
Summary: Writer crash when attempting to open one file.
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.0.1 rc
Hardware: All All
: highest major
Assignee: Not Assigned
URL:
Whiteboard: target:5.1.0 target:4.4.6 target:5.0.1
Keywords: haveBacktrace, regression
: 92597 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-07-06 14:47 UTC by Francisco
Modified: 2016-10-25 19:24 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Problematic file (deleted)
2015-07-06 14:47 UTC, Francisco
Details
Backtrace (5.35 KB, text/plain)
2015-07-09 16:20 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Francisco 2015-07-06 14:47:59 UTC
Created attachment 117081 [details]
Problematic file

Writer 5.0.0.2 crashes every time I try to open the attached file.

Steps:
Open the files attached with LibO 5.0.0.2

Results
Writer window appears
It is possible to see the content of the file for a fraction of time
Crash

Expected
No crash

This doesn't happen with LibO 4.4.4.3
Comment 1 Marc Kaulisch 2015-07-06 21:49:57 UTC
I can confirm this with 5.0.0.2 64bit on Win8.1

I get a LibreOffice 5.0 Fatal Error SEH Exception: ACCESS VIOLATION message.
Comment 2 Francisco 2015-07-07 01:36:08 UTC
Well, this affects also Windows, so I'm changing it to All. Moreover, it's a crash which happens consecutively in a fresh install, so I'm marking it as blocker, highest, and emailing a devoloper according to

https://wiki.documentfoundation.org/images/0/06/Prioritizing_Bugs_Flowchart.jpg
Comment 3 Robinson Tryon (qubit) 2015-07-09 14:08:08 UTC
(In reply to Francisco from comment #2)
> Well, this affects also Windows, so I'm changing it to All.

Francisco: Please make sure to list your OS in your initial comment so that we can quickly scan the bug and see which platforms are affected. I'm guessing that you're using a 64bit GNU/Linux distro?

> Moreover, it's a
> crash which happens consecutively in a fresh install, so I'm marking it as
> blocker, highest, and emailing a devoloper

Is the problem reproducible with any other documents, or just this one?
Comment 4 Francisco 2015-07-09 15:09:48 UTC
(In reply to Robinson Tryon (qubit) from comment #3)
> (In reply to Francisco from comment #2)
> > Well, this affects also Windows, so I'm changing it to All.
> 
> Francisco: Please make sure to list your OS in your initial comment so that
> we can quickly scan the bug and see which platforms are affected. I'm
> guessing that you're using a 64bit GNU/Linux distro?

Sorry, yes. I'm using Kubuntu 14.04 x86_64.
 
> > Moreover, it's a
> > crash which happens consecutively in a fresh install, so I'm marking it as
> > blocker, highest, and emailing a devoloper
> 
> Is the problem reproducible with any other documents, or just this one?

This specific bug (when opening a Writer doc), so far only this file. If I find another one I'll attache it here.
Comment 5 Timur 2015-07-09 16:18:48 UTC
*** Bug 92597 has been marked as a duplicate of this bug. ***
Comment 6 Timur 2015-07-09 16:20:52 UTC
Created attachment 117161 [details]
Backtrace

MODULE_NAME: swlo
IMAGE_NAME:  swlo.dll
FAILURE_BUCKET_ID:  NULL_CLASS_PTR_READ_c0000005_swlo.dll!lcl_CalcBorderRect
BUCKET_ID:  APPLICATION_FAULT_NULL_CLASS_PTR_READ_swlo!lcl_CalcBorderRect+2c3
Comment 7 Timur 2015-07-09 16:39:41 UTC
5.0 beta was OK, so regression from 5.0.0.1. But 5.1+ is OK.
Comment 8 Marc Kaulisch 2015-07-09 20:45:56 UTC
It looks like it is silently fixed in this version: 

Version: 5.0.0.2.0+ (x64)
Build-ID: 18d6d789cae7cd684156dbd41d473892bc17392c

So my guess is that is fixed in a publicly available 5.0.0.3 rc
Comment 9 Timur 2015-07-10 14:51:38 UTC
IN that case, I'll close as WFM. Please reopen if reproduced again.
Comment 10 Marc Kaulisch 2015-07-10 20:15:21 UTC
I updated now to 5.0.0.3 64bit on Win8.1 and I can open the document and scroll through it without any crash
it looks like to be good but maybe someone on Linux wants to check it

- any chance to delete the file from the repositories as it includes personal details?
Comment 11 Francisco 2015-07-10 20:20:41 UTC
(In reply to Marc Kaulisch from comment #10)
> I updated now to 5.0.0.3 64bit on Win8.1 and I can open the document and
> scroll through it without any crash
> it looks like to be good but maybe someone on Linux wants to check it

Hi Marc, 
Where would I may find the download files of version 5.0.0.3? I can only find 5.0.0.2 and 5.1.0.A1 in the nightly builds server.

> - any chance to delete the file from the repositories as it includes
> personal details?

Yes please if possible, I had forgot about it...
Comment 12 Robinson Tryon (qubit) 2015-07-10 22:18:15 UTC
(In reply to Francisco from comment #11)
> Where would I may find the download files of version 5.0.0.3? I can only
> find 5.0.0.2 and 5.1.0.A1 in the nightly builds server.

Hi Francisco,
Take a look under the pre-releases directory:
http://dev-builds.libreoffice.org/pre-releases/

> > - any chance to delete the file from the repositories as it includes
> > personal details?
> 
> Yes please if possible, I had forgot about it...

Francisco: If you'd like to have an attachment deleted, please email me the attachment URL using the email account connected with the Bugzilla account that uploaded the file (just to make it crystal clear about the deletion request). Thanks!
Comment 13 Commit Notification 2015-07-13 11:41:51 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7de992bcc66c973bb6b247184cac38f01cd1104a

fix a11y crash seen on close of tdf#92573

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 14 Robinson Tryon (qubit) 2015-07-13 14:16:46 UTC
The content of attachment 117081 [details] has been deleted for the following reason:

Uploader request
Comment 15 Commit Notification 2015-07-16 09:05:38 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=03e115e51e5102ffd9c8498f865ed9e768f4f490&h=libreoffice-4-4

fix a11y crash seen on close of tdf#92573

It will be available in 4.4.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2015-07-16 09:05:44 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c7d2270f86b2bd1f3c764d8461a40c903780ee56&h=libreoffice-5-0

fix a11y crash seen on close of tdf#92573

It will be available in 5.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.