Bug 92626 - Resetting a filter in Calc results in not every row being displayed
Summary: Resetting a filter in Calc results in not every row being displayed
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.4.3.2 release
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-07-08 14:47 UTC by Manfred
Modified: 2017-11-05 16:58 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
After reset filter - raws at bottom are closed (201.82 KB, image/png)
2015-07-09 10:05 UTC, Manfred
Details
2 but should look like this (225.79 KB, image/png)
2015-07-09 10:06 UTC, Manfred
Details
Test- Sheet (34.73 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-07-09 10:36 UTC, Manfred
Details
Location of Reset Filter in the menu (58.75 KB, image/png)
2015-07-12 11:28 UTC, Manfred
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Manfred 2015-07-08 14:47:11 UTC
A table with more than 15 columns, that collects data out of 8 included sheets:

Data in column A contains numbers in a format like 0S or 0,98H or 522S (for DATEV) or a formula that gives back 0 or a numeric format like 112,55.
Data in column E contains a date between 1.7.2014 and 30.6.2015 (West-Europe) in a format like 300615 or 220814 -  or no date.

Standardfilter to all 5000 lines:
E > 31.12.2014
A > 0,?

copy column A,B,C,D,E (e.q. 2000 raws)

select: reset filter

only 4000 raws are open, but not all…


ciao
Manfred
Comment 1 Manfred 2015-07-08 15:56:43 UTC
A little other behavior in Version 4.4.4.3, but not better:

After changing the filtered Area for copying only some, the entry "reset filter" is greyed out.
Comment 2 m.a.riosv 2015-07-09 09:06:03 UTC
Hi @Manfred, thanks for reporting.

Attaching a sample file, could make the test easier.
Comment 3 Manfred 2015-07-09 09:35:57 UTC
sorry, this is a company own file…
It is possible to send an empty one, but this would be worthless.
Comment 4 Manfred 2015-07-09 10:05:54 UTC
Created attachment 117155 [details]
After reset filter - raws at bottom are closed
Comment 5 Manfred 2015-07-09 10:06:45 UTC
Created attachment 117156 [details]
2 but should look like this
Comment 6 m.a.riosv 2015-07-09 10:19:16 UTC
Only with screenshots it's no possible to know what it's happening.

Are you sure the filter range cover all rows?

About the attachement, please see
https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F
for help on how to do so.
Comment 7 Manfred 2015-07-09 10:36:17 UTC
Created attachment 117157 [details]
Test- Sheet
Comment 8 Manfred 2015-07-09 10:38:23 UTC
Cursor in an arbitrary cell.

Standardfilter:
E < 1.1.2016
"and" A > 0,?

copy column A,B,C,D,E 
from only row 7 till row 146

(or just point the cursor to a cell outside the filtered area 
- reset filter is grayed out than …)

select: reset filter

The raws outside the marked area stay closed.
Comment 9 m.a.riosv 2015-07-09 11:35:26 UTC
Sorry, but which must be the filtered range?, I can't see any defined.
Comment 10 Manfred 2015-07-09 11:55:37 UTC
Row 7 till 212

Or you can mark only one cell.
It dosn’t matter.

!!
If you do not mark the same range again, 
"reset filter" will not open all rows !!

I find this is dangerous, because I have as result copied not all data to a separate sheet for my Tax counsel.
Comment 11 m.a.riosv 2015-07-09 21:26:48 UTC
If you don't define the data range for the filter it does a selection, but when not all cells have data, some of them are empty, it's easy that the auto-selection is not exactly what you need.

To avoid issues, better first define the range in Menu/Data/Define range.
Select the range in Menu/Data/Select range.
Then select the filter: Menu/Data/Filters/Standard filter

In the options of the standard filter you can set up directly where to copy the filter result.
Comment 12 Alex Thurgood 2015-07-12 08:00:57 UTC
(In reply to Manfred from comment #8)


> 
> (or just point the cursor to a cell outside the filtered area 
> - reset filter is grayed out than …)
> 
> select: reset filter
> 


Where / how does one find the command to reset the filter ? In 

LO 5.1 alpha, I don't see any toolbar button for this, nor any entry in the Tools menu.


Setting NEEDINFO
Comment 13 Alex Thurgood 2015-07-12 08:07:44 UTC
See also bug 77479
Comment 14 Alex Thurgood 2015-07-12 08:13:46 UTC
I can not reset the filter, it is greyed out in the Filter submenu, no matter which cell I choose, which is bug 76898
Comment 15 Alex Thurgood 2015-07-12 08:15:05 UTC
@Manfred,

Please provide step by step instructions.

You do not say whether you are using the Autofilter or the Filter > Standard / Advanced menu. I sued th Filter menu, not the Autofilter function.
Comment 16 Manfred 2015-07-12 11:25:15 UTC
@Alex,

excuse my english… and thanks for correcting the title.

All comments from me are about the Standard Filter, without any options.

Take the Test-Sheet I uploaded.

A)
Mark Lines 7 till 212
Choose: Data, Filter, Standard Filter...
Field E < 1.1.2016 AND
Field A > 0,?

after Lines are filtered, mark Range A7 till maybe G146 for copying

How will you reset the Filter now?
If you do it directly after copying, are Lines 190 till 212 visible?
If you do not know, what range was marked for filtering, how will you do it?


B)
Go to   Data, "Set Range" ?
Range is   $Tabelle1.$A$7:$AM$212, called "testrange"
Go to Data, "Choose Range" ?
Choose "testrange".
Choose: Data, Filter, Standard Filter...
Field E < 1.1.2016 AND
Field A > 0,?

after Lines are filtered, mark Range A7 till G146 for copying

How will you reset the Filter now?
Are Lines 190 till 212 visible, if you did it?
How did you do it?

C)
Let the range "testrange" still there…, but mark a range manually:
Mark Lines 7 till 212
Choose: Data, Filter, Standard Filter...
Field E < 1.1.2016 AND
Field A > 0,?

after Lines are filtered, mark Range A7 till G146 for copying

How will you reset the Filter now?

So many possibilities.
If one wants to "reset filter" they should be reseted easy with only one click…

Don’t know the english entry for "reset filter", upload a picture for the entry in the menu that I mean.

Manfred
Comment 17 Manfred 2015-07-12 11:28:01 UTC
Created attachment 117188 [details]
Location of Reset Filter in the menu
Comment 18 Alex Thurgood 2015-07-12 12:32:29 UTC
@Manfred : thanks for your explanations, I will test again. I hadn't realized that you were selecting a range of cells before you applied the filter, the rest I was doing as you had previously described.
Comment 19 Alex Thurgood 2015-07-12 12:34:40 UTC
Just for you information, the filter menu in LO5 has been changed, so there is now a separation between Data > Autofilter and Data > Filters > Standard filter, and Data > Filters > Advanced
Comment 20 Alex Thurgood 2015-07-12 12:42:49 UTC
(In reply to Manfred from comment #16)



> 
> after Lines are filtered, mark Range A7 till maybe G146 for copying
> 
> How will you reset the Filter now?

Under Data > More FIlters > I see the Reset filter entry


> If you do it directly after copying, are Lines 190 till 212 visible?

No, if I reset the filter after selecting A7:G146, lines 190 to 212 do not get redisplayed, and there is no further option to reset the filter again


Confirming bug.

Thanks for your help.
Comment 21 Alex Thurgood 2015-07-12 12:43:47 UTC
Confirmed on
Version: 5.1.0.0.alpha1+
Build ID: 9136f2344af88d524b6c10b6b2dfd6017bba60ec
Locale: fr-FR (fr.UTF-8)
OSX 10.10.4
Comment 22 QA Administrators 2016-09-20 10:14:13 UTC Comment hidden (obsolete)
Comment 23 eisa01 2017-11-05 16:58:17 UTC
I can not reproduce this, I'm able to show all rows again

What I did:
1. Mark cells A7 till E212
2. Choose: Data -> Filter -> Standard Filter
3. Column A > 0
4. Only row 191, 192, 194 shows
5. Mark cells A192 and A194 and select Data -> Filter -> Reset filter
6. Row 193 shows
7. Select cell A194 and reset filter -> Everything shows

As step 7 shows everything, I don't really see any bug here?

Version: 6.0.0.0.alpha1+
Build ID: 15dce20e8b97dbd0179f01910ca4d0027e80ff4e
CPU threads: 2; OS: Mac OS X 10.12.6; UI render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2017-10-20_06:46:46
Locale: en-US (en_US.UTF-8); Calc: group