Download it now!
Bug 92759 - #REF! when inserting rows or columns which exceeds max row and max column in formulae range
Summary: #REF! when inserting rows or columns which exceeds max row and max column in ...
Status: CLOSED DUPLICATE of bug 92779
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.0.0.3 rc
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-07-15 09:47 UTC by Óvári
Modified: 2015-12-10 07:49 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Óvári 2015-07-15 09:47:32 UTC
Version: 5.0.0.3 (x64)
Build ID: f79b5ba13f5e6cbad23f8038060e556217e66632

1. Open LibreOffice Calc
2. In cell A2 enter: =SUM($B2:B1048573)
3. Select rows 4 to 14
4. Right click on any row heading from 4 to 14
5. Insert Rows Above
6. Formula in cell A2 shows: =SUM($B2:B#REF!)
   Expected formula in cell A2: =SUM($B2:B1048576)

Unfortunately, bug also occurs when entering columns which exceed column limit.

May relate to bug 92751

Thank you
Comment 1 Eike Rathke 2015-07-15 11:15:23 UTC

*** This bug has been marked as a duplicate of bug 92751 ***
Comment 2 Óvári 2015-07-15 23:08:12 UTC
Thank you Eike for your comment.

Perhaps LibreOffice (LO) documentation user documentation could state that:
1. LO Calc operates differently to MS Excel as it does not check to ensure that the upper bound of a range is at most the maximum row/column of a spreadsheet and if the value exceeds the maximum bound automatic convert the upper range to the maximum row/column value; and
2. LO Calc produces an #REF! error, while MS Excel automatically ensures the upper bound of a range never exceeds the maximum row/column.
Comment 3 Óvári 2015-12-10 07:49:00 UTC
Fix in bug 92779 incorporates this bug. Thank you

*** This bug has been marked as a duplicate of bug 92779 ***