Bug 92858 - <100% Line height/spacing on first line of paragraph rendered as 100%
Summary: <100% Line height/spacing on first line of paragraph rendered as 100%
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.5.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: 79750
  Show dependency treegraph
 
Reported: 2015-07-21 16:12 UTC by Yousuf Philips (jay) (retired)
Modified: 2016-02-29 13:45 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2015-07-21 16:12:27 UTC
Steps:
1) Open attachment 100367 [details] from bug 79602
2) Look at paragraph which has "This is at a 60% proportional line height" as it isnt following the 60% line height, though it is set as so.

Regression as this works correctly in 4.2.8.

Version: 5.1.0.0.alpha1+
Build ID: 85ce6a2446deb0f4c01604b6188f969603de9b16
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-07-09_02:29:43
Comment 1 Gordo 2015-07-28 14:32:28 UTC
I can reproduce.

Copying the paragraphs to a new document displays the font at 60%.

Windows Vista 64
Version: 4.4.5.2
Build ID: a22f674fd25a3b6f45bdebf25400ed2adff0ff99
Comment 2 Matthew Francis 2015-08-11 08:44:01 UTC
The behaviour of this changed at the below commit.
Adding Cc: to mstahl@redhat.com; could you possibly take a look at this one? Thanks

(If this is correct behaviour from this commit, please close - but if I understand the comment correctly, shouldn't this presumably pre-existing document not have changed formatting?)


    commit 9605763e3dc8c85137787c77c31e8639553a35ed
    Author:     Michael Stahl <mstahl@redhat.com>
    AuthorDate: Thu Oct 30 15:12:33 2014 +0100
    Commit:     Michael Stahl <mstahl@redhat.com>
    CommitDate: Thu Oct 30 15:56:07 2014 +0100
    
        fdo#79602: sw: add new compatibiltiy flag PropLineSpacingShrinksFirstLine
    
        This is enabled by default, to get the new formatting where the first
        line of a paragraph is shrunk if a proportional line spacing < 100% is
        applied; existing OOo documents get the previous (before LO 3.3)
        formatting.  Since the formatting in LO releases is broken anyway, it
        does not matter much which way documents written by old LO get
        formatted.
    
        Change-Id: I0952f568a933c137bd03070759989cac3517d8b9
Comment 3 Yousuf Philips (jay) (retired) 2015-08-11 14:40:26 UTC
Quite strange that in the same document, that another paragraph that is set to 80%, which has the text "This is at an 80% line height. Check it out, pqgjjgpqjpgqpjg", works correctly.
Comment 4 Robinson Tryon (qubit) 2015-12-13 11:13:21 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]
Comment 5 Michael Stahl (allotropia) 2016-02-19 21:41:29 UTC
actually this is line spacing, not line height.

as the commit message in comment #2 tried to say, the proportional line
spacing before the first line of a paragraph is constrained to >=100% for
existing documents (LO < 4.3.4) and may also be <100% for new documents;
before the 2nd to last line of a paragraph, <100% line spacing
will be applied in all cases.

the paragraphs outside the table in the bugdoc all have only 1 line
so the spacing is 100%.

(this should also explains the observation in comment #3)

since the line spacing was very buggy in LO versions < 4.3.4
such that 60% was actually rendered as 36%, i don't see a
good reason to add extra code to handle documents written between
LO 3.3 and LO 4.3.3 specially, since they will look different anyway.
Comment 6 Michael Stahl (allotropia) 2016-02-29 13:45:00 UTC
> actually this is line spacing, not line height.

... actually it's only our UI that calls it line spacing, in ODF and XSL it is "line height"  :)