Download it now!
Bug 79750 - EDITING: text with less than 100% proportional line height
Summary: EDITING: text with less than 100% proportional line height
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on: 92858
Blocks: Paragraph-Line-Spacing Selection
  Show dependency treegraph
 
Reported: 2014-06-06 23:30 UTC by Yousuf Philips (jay) (retired)
Modified: 2018-10-14 02:57 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
selecting a line (10.18 KB, image/png)
2014-06-06 23:30 UTC, Yousuf Philips (jay) (retired)
Details
size of the cursor (8.99 KB, image/png)
2014-06-06 23:30 UTC, Yousuf Philips (jay) (retired)
Details
show it looks when you delete a few characters (9.96 KB, image/png)
2014-06-06 23:31 UTC, Yousuf Philips (jay) (retired)
Details
screenshot 4.4.5.2 (86.56 KB, image/png)
2015-07-28 14:42 UTC, Gordo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-06-06 23:30:00 UTC
Created attachment 100565 [details]
selecting a line

When viewing attachment 100367 [details] from bug 79602, i noticed that the cursor on a 60% proportional line height doesnt show its full length, so does highlight, or deleting characters.
Comment 1 Yousuf Philips (jay) (retired) 2014-06-06 23:30:31 UTC
Created attachment 100566 [details]
size of the cursor
Comment 2 Yousuf Philips (jay) (retired) 2014-06-06 23:31:14 UTC
Created attachment 100567 [details]
show it looks when you delete a few characters
Comment 3 Kevin Suo 2014-07-07 10:45:50 UTC
Confirmed, win xp sp3, version 4.3.0.2.
Set to NEW.
Comment 4 QA Administrators 2015-07-18 17:43:27 UTC Comment hidden (obsolete)
Comment 5 Gordo 2015-07-20 15:05:49 UTC
Could not reproduce.

Windows Vista 64
Version: 4.4.4.3
Build ID: 2c39ebcf046445232b798108aa8a7e7d89552ea8

4.3.7.2

Bug present in 4.2.8.2.

Changed to RESOLVED WORKSFORME.
Comment 6 Yousuf Philips (jay) (retired) 2015-07-21 16:13:22 UTC
Still present. It wont show up in the 60% paragraph due to bug 92858, but if you set the 80% paragraph to 60%, it will show there.

Version: 5.1.0.0.alpha1+
Build ID: 85ce6a2446deb0f4c01604b6188f969603de9b16
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-07-09_02:29:43
Comment 7 Gordo 2015-07-28 14:42:50 UTC
Created attachment 117500 [details]
screenshot 4.4.5.2

When I first looked at this I did not have the Overpass font installed.  When opening the document and setting the zoom to page width (I also have Navigator opened on the left), the text in the table is rendering incorrectly.

Windows Vista 64
Version: 4.4.5.2
Build ID: a22f674fd25a3b6f45bdebf25400ed2adff0ff99

It is not as extreme in master, but there is still extra space between the last two letters in “tidy” and “why”.
Windows Vista 64
Version: 5.1.0.0.alpha1+
Build ID: 6949629e35f308ce7efc890319ecf9a46a5f154c
TinderBox: Win-x86@39, Branch:master, Time: 2015-07-27_23:17:28
Comment 8 Yousuf Philips (jay) (retired) 2015-07-28 18:10:18 UTC
(In reply to Gordo from comment #7)
> When I first looked at this I did not have the Overpass font installed. 
> When opening the document and setting the zoom to page width (I also have
> Navigator opened on the left), the text in the table is rendering
> incorrectly.

I dont have overpass installed as well but that shouldnt cause such a problem that you are seeing, so you should likely file a bug report about this, as it maybe something that only shows up on Windows.
Comment 9 QA Administrators 2016-09-20 10:21:56 UTC Comment hidden (obsolete)
Comment 10 Yousuf Philips (jay) (retired) 2017-10-08 13:05:49 UTC
@Khaled: Any thoughts on this?
Comment 11 Khaled Hosny 2017-10-09 11:18:48 UTC
The cursor (also the clipping) probably is using the line height not the font ascender/descender, so with a 60% line height you get a 60% cursor (and 60% clipping rectangle).
Comment 12 Yousuf Philips (jay) (retired) 2017-10-13 00:53:23 UTC
(In reply to Khaled Hosny from comment #11)
> The cursor (also the clipping) probably is using the line height not the
> font ascender/descender, so with a 60% line height you get a 60% cursor (and
> 60% clipping rectangle).

So from your point of view is this a bug?
Comment 13 Khaled Hosny 2017-10-13 01:02:20 UTC
(In reply to Yousuf Philips (jay) from comment #12)
> (In reply to Khaled Hosny from comment #11)
> > The cursor (also the clipping) probably is using the line height not the
> > font ascender/descender, so with a 60% line height you get a 60% cursor (and
> > 60% clipping rectangle).
> 
> So from your point of view is this a bug?

Not sure about the cursor size, there is a point in basing it on line height as the alternative (text bounding box) would mean cursor size changes according to characters in the font which is not good.

Clipping, on the other hand, should always use the text bounding box IMHO.
Comment 14 QA Administrators 2018-10-14 02:57:53 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug