Bug 92992 - Viewing: Text rendering is corrupted in particular .odt
Summary: Viewing: Text rendering is corrupted in particular .odt
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.5.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-07-28 23:39 UTC by Gordo
Modified: 2015-08-15 19:47 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gordo 2015-07-28 23:39:50 UTC
1. Download attachment 100367 [details] from bug 79602.
2. Install Overpass font if it is not already installed.
3. Open attachment—zoom is set at 160%.
4. Set zoom to page width.  I had Navigator open on the left so it was 111% after.
Result:
Text rendering is corrupted in the table.  See screenshot in attachment 117500 [details] from bug 79750.

Windows Vista 64
Version: 4.4.5.2
Build ID: a22f674fd25a3b6f45bdebf25400ed2adff0ff99

It is not as extreme in master, but there is still extra space between the last two letters in “tidy” and “why”.
Windows Vista 64
Version: 5.1.0.0.alpha1+
Build ID: 6949629e35f308ce7efc890319ecf9a46a5f154c
TinderBox: Win-x86@39, Branch:master, Time: 2015-07-27_23:17:28
Comment 1 tommy27 2015-07-29 12:55:01 UTC
I don't reproduce this under Win7x64 using LibO 4.4.5.1 and 5.1.0.0.alpha1+ (x64)
Build ID: e92a8b92072284fd7c37d7bb3e1e8fe72a185f35
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-07-22_21:46:26
Locale: it-IT (it_IT)

it looks fine at any zoom level.
did you have the chance to test it on another Windows O/S rather than Vista?
Comment 2 Gordo 2015-07-29 13:22:38 UTC
I only have access to the one machine atm.

4.4.5.2 was a clean install.  I had deleted everything before installing.  I even tested this on an earlier version (might have been 4.3.7.2 portable) and got the same result.

Surely this is a coincidence that this is happening right after I cracked bug 48851.

Try saving the document at a higher zoom level and close the application.  Open Writer then close blank document and drag document into start centre.  Shouldn't matter but that is how I opened it the first time.

While typing this I tried again and it did not happen except for a small amount of space between the last letters.  I then remembered that I was trying to discover the spacing in the table.  I right clicked on the first paragraph in the first cell and opened the Paragraph dialogue -> Indents & Spacing and cancelled out of it.  Now it is happening again.
Comment 3 Jean-Baptiste Faure 2015-07-30 04:59:56 UTC
No problem under Linux Ubuntu 15.04 x86-64.

Best regards. JBF
Comment 4 Gordo 2015-07-31 12:57:11 UTC
See bug 57999 comment 23.  Create that document and open that first before the attachment in this bug.  Then set the zoom to page width.
Comment 5 Jean-Baptiste Faure 2015-07-31 14:41:12 UTC
(In reply to Gordo from comment #4)
> See bug 57999 comment 23.  Create that document and open that first before
> the attachment in this bug.  Then set the zoom to page width.

Please, only one problem per bug report.

Best regards. JBF
Comment 6 Gordo 2015-07-31 15:47:27 UTC
Okay, I have figured out how this happened orginally.  I had only installed Overpass Regular font and there was corruption when looking at the file.  While looking at other bugs I realised that I did not have Overpass Bold installed so I installed that.  The problem was that while looking at bug 79643, that causes corruption on other other documents that use font substitution.  I distilled that other bug down to what is currently in comment 23 of bug 57999.

Ignoring those other bugs, I cannot get any corruption when only working with this document now that the bold font is installed.

This report is now just an example of how those other bugs can cause corruption in other documents.
Comment 7 tommy27 2015-08-01 04:42:59 UTC
so should we close this as a duplicate?
Comment 8 Timur 2015-08-13 17:50:14 UTC
I'll close this one. If you feel that's inappropriate, feel free to reopen.
Comment 9 Jean-Baptiste Faure 2015-08-15 19:47:02 UTC
WorksForMe seems more appropriate than invalid.

Best regards. JBF