Bug 57999 - VIEWING: Font selector without preview and/or TrueType icon
Summary: VIEWING: Font selector without preview and/or TrueType icon
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.4.0.0.beta1
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 61848 62904 65876 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-12-07 21:12 UTC by Rainer Bielefeld Retired
Modified: 2017-02-16 23:35 UTC (History)
12 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshots (155.57 KB, application/pdf)
2012-12-07 21:12 UTC, Rainer Bielefeld Retired
Details
4.0 Beta 2 Fonts ComboBox (28.90 KB, image/png)
2012-12-21 13:59 UTC, vitriol
Details
LO Version: 4.2.4.1 on Win 7 x64 (18.87 KB, image/png)
2014-05-06 09:27 UTC, Dominik
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-12-07 21:12:41 UTC
Created attachment 71157 [details]
Screenshots

Steps how to reproduce [Reproducible] with parallel installation of  "LOdev  4.0.0.0.alpha1+   -  ENGLISH UI / German Locale  [Build ID:d6579884752c298a18b7cdfcc7d1614b55c9c7c)]"  {tinderbox: Win-x86@6, pull time 2012-12-06 02:46:58} on German WIN7 Home Premium (64bit) with own separate User Profile:
1. open new Writer Document from LibO Start Center
2. In format Toolbar use pulldown of font selector
   Expected: Truetype fonts name shown "WYSYWIG" in selector, switch back to
             Name in default font when selection has been done
   Actual: Most fonts are only shown in standard font view.
           (See Comparison in Screenshots)

I will have to check when that started.
For me that's already broken with 3.6.4,  may bee more early
Comment 1 Rainer Bielefeld Retired 2012-12-07 22:25:44 UTC
Seems there is something broken with Menu 'Tools -> Options -> LibO -> View - Show preview of fonts'

With unchecked option it looks like in 3.5.7.2 with unchecked option.
With checked option spacing between lines in font selector increases (as in 3.5.7.2), but icons left from font name do not appear and font name in pulldown remains shown in standard font instead of named font.
Comment 2 Joel Madero 2012-12-11 16:58:48 UTC
Can't reproduce in Linux, either it's been fixed or it's Windows only problem.
Comment 3 Rainer Bielefeld Retired 2012-12-21 12:26:41 UTC
Still [Reproducible] with parallel installation of  "LOdev  4.0.0.0.beta2   -  GERMAN UI / German Locale  [Build ID: 4104d660979c57e1160b5135634f732918460a0)]"  {tinderbox: @6, pull time 2012-12-20} on German WIN7 Home Premium (64bit) with separate /4 User Profile for Master Branch. Not related to Profile.

@vitriol:
Can you confirm my observations?
Comment 4 vitriol 2012-12-21 13:50:26 UTC
(In reply to comment #3)

> @vitriol:
> Can you confirm my observations?

No, I can't confirm. It seems OK on my installation.
Tested version:
Versione 4.0.0.0.beta2 (Build ID: 4104d660979c57e1160b5135634f732918460a0), fresh profile. QuickStart not installed:
SO:
Win 7 HP 64 bit SP1, full patched.
Comment 5 vitriol 2012-12-21 13:59:23 UTC
Created attachment 71935 [details]
4.0 Beta 2 Fonts ComboBox
Comment 6 vitriol 2012-12-21 14:00:47 UTC
(In reply to comment #4)
> (In reply to comment #3)

> No, I can't confirm.

Hoverer there is not the "A" TrueType icon, and the ComboBox is too narrow.
See attached PNG,
Comment 7 Rainer Bielefeld Retired 2012-12-21 17:06:08 UTC
Some more observations: I see a preview for "New Times Roman", "DejaVu Sans", Wegoe UI" and 2  chinese looking fonts, all in the font name. All other font names are shown in system font without extra preview.

NEW because of confirmed TrueType icon problem, I am pretty sure that these problems are related.

This was still ok for me with Server-installation of Master "3.7.0.alpha0+  – ENGLISH UI [Build ID: f2e622]" {tinderbox: Win-x86@16, pull time 2012-10-06 09:31:39} on German WIN7 Home Premium (64bit) UserInstallation=$SYSUSERCONFIG/LOdev/3

@vitriol
Thx. for testing. I can't reproduce the "ComboBox is too narrow" problem for "Times New Roman", but som fonts with long names like "Simplified Arabic Fixed" or "Bitstream Vera Sans Mono". And my screenshots seem th show that width of that selector has decreased. Can you please submit an extra bug (if not already in Bugzilla) for some fine tuning there?

@Bibisecters:
I wonder whether this can bei bibisected under WIN
Comment 8 Joel Madero 2012-12-21 18:48:23 UTC
Bibisect is Linux only from my understanding
Comment 9 Rainer Bielefeld Retired 2012-12-21 19:00:30 UTC
Yes, most people think so, because it's not mentioned on <https://wiki.documentfoundation.org/Bibisect>. But please see
<http://lists.freedesktop.org/archives/libreoffice-qa/2012-October/002724.html>.
I do not know whether this has been developed in between.
Comment 10 Joel Madero 2012-12-21 19:06:25 UTC
adding Bjoern as he'll be the one who has the answers :)

Bjoern: Can we bibisect on Windows?
Comment 11 Jorendc 2013-03-20 12:24:51 UTC
*** Bug 61848 has been marked as a duplicate of this bug. ***
Comment 12 Jorendc 2013-04-09 09:29:47 UTC
*** Bug 62904 has been marked as a duplicate of this bug. ***
Comment 13 Horst 2013-04-22 01:03:08 UTC
Cannot confirm this on Win7 64-bit US locale (Win and LO) with admin install of 4.0.1, 4.0.2 or 4.0.3.1.
Comment 14 Joel Madero 2013-04-24 21:28:03 UTC
Removing bibisectrequest as it is indeed Linux only right now
Comment 15 Jorendc 2013-06-25 22:53:00 UTC
*** Bug 65876 has been marked as a duplicate of this bug. ***
Comment 16 bugquestcontri 2013-06-29 14:25:44 UTC
Update 
Originally I filed bug Version 4.0.4.2 (Build ID: 9e9821abd0ffdbc09cd8c52eaa574fa09eb08f2)

This bug appeared when I installed 4.0.4.2 while 3.6.6.2 was installed.

I then removed 3.6 but kept the user profile files under "3" and installed 4.0.4.2. 

Now the font are displayed correct but for Chinese fonts the number of Chinese Character is only 1, For Korean there are 2, and for Japanese only hiragana and katakana characters are shown. The kanji characters (more important, looking like Chinese characters) are not shown.

Additional observation:

In Writer the basic font for Japanese is MS Mincho. This font name is shown when I open a new Writer file also Default language is English. 

This font is shown only as long as there is no change in Japanese fonts because thereafter the MS Mincho is not displayed in the font window  when it is rolled down..
Comment 17 Dominik 2014-05-06 08:26:55 UTC
Also found on Version: 4.2.4.1
Build ID: d4c441391e20647b3d2e8dde4d20aa868e77e515
Windows 7 pro x64

Preview works for Liberation {Sans|Serif|Mono|...} and two Arial's, the rest is displayed with a default font.
Comment 18 Dominik 2014-05-06 09:27:23 UTC
Created attachment 98545 [details]
LO Version: 4.2.4.1 on Win 7 x64
Comment 19 QA Administrators 2015-06-08 14:42:56 UTC Comment hidden (obsolete)
Comment 20 Bugcruncher 2015-06-14 16:08:03 UTC
Dear QA Administrators, it is really annoying to have to read such a novel like Comment 19 with nothing useful in it. For such standard texts you can use a simple link to a wiki page or something else instead of useless filling comments with search strings what will make queries rather useless some day. Here we at least have "responding"; "read"; "message"; "focus"; "change"; "detail"; "help"; what also are popular search string for queries - 2015-06-08 you contaminated 229 bug reports, so that they also will be listed if a user uses these terms in a query. Be parsimonious, but effective with words! 

And now new information: yes, the bug still exists for Version: 4.4.4.1.0+
Build-ID: 24c5f9979e61fde7b098af60756a4890e5713390 Gebietsschema: de_DE (did not test for a year or more in between).

Problem also has been discussed at <http://www.libreoffice-forum.de/viewtopic.php?f=5&t=13090&start=10> without a solution.
Comment 21 elucubra 2015-06-26 20:38:11 UTC
A few days back, my LibreOffice install (4.4.x, Win 8.1) has stopped displaying most font previews. I checked in Tools>Options>View, and the option was checked.

I uninstalled, ran Glary, re-installed, and nothing. Installed 4.3.x. Nothing Installed 5.0. RC. Nothing.

I'm at wits end. It looks like something broke and was left in my system preventing new installs from working properly.

BTW, I have a 4.4.x install in a Windows 10 VM in the same machine and the font preview works fine.

Has anyone seen this?
Comment 22 Joel Madero 2015-06-26 22:46:07 UTC
Please don't change the version field - a big warning comes up when you do that says it is the "earliest" version - not the latest confirmed.
Comment 23 Gordo 2015-07-31 12:54:07 UTC
This may be related to font substitution.

1. New Text Document.
2. Insert → Special Character → Font:  SimSun and Subset: Mathematical Operators.
3. Select U+222A (it looks like a U) and Insert.
4. Select the character and right click → Character → Font tab → Style:  Bold.
Note:
Between the language and the preview it will say, “This font style will be simulated or the closest matching style will be used.”
5. Still in Character dialogue, change Font to Times New Roman and keep Style as Bold.
Note:
Times New Roman does not have this glyph.
6. Save document.
7. Close LO.
8. Open Writer and close blank document to Start Centre.
9. Open saved document.
Result:
Character is a block and Font Name dropdown in toolbar does not display the fonts correctly.  In the Special Characters dialogue, many of the glyphs will be blocks as well.  Any new document during this session will have the buggy Font Name dropdown.

If another document is opened first before this document then the character will display “correctly”.

When Writer is first opened, the saved document can be opened from the recent list in the toolbar and the character will be a block.  Opening other documents from the dropdown in the toolbar may result in other documents not displaying correctly for the session (bug 92992). I have had greater success in seeing the corruption in bug 48851 with this method.  Even though it might not be related, this bug might exacerbate that one.

Windows Vista 64
Version: 4.4.5.2
Build ID: a22f674fd25a3b6f45bdebf25400ed2adff0ff99
Comment 24 Horst 2015-10-01 20:55:23 UTC
System Win7 Home 64bit, LO4.4.5.2 (standart install), LO5.0.1.2 and LO5.02.2 (Admin install).
I have 2 test files 
F1=my cookbook, only font is Arial
F2=emoji test file, main font Arial, 2.Font Segue UI Emoji.

When I start a LO session in any of the 3 versions with F1 it shows all fonts in fontlist as "WYSYWIG", F2 loaded after that is also ok. Same behavior if I start a new document in LO5.0.2.2.

When I start a LO session in any of the 3 versions with F2 it shows all fonts in fontlist with Arial except Arial Unicode MS and Symbol. Switching to F1 does not change the font list display.

I hope this info helps somebody.
Comment 25 Bugcruncher 2016-01-30 16:58:29 UTC
Still a problem in Version: 5.0.4.2 
Build-ID: 2b9802c1994aa0b7dc6079e128979269cf95bc78

Most fonts without any realistic preview
Font "DF中太楷書体" only shows white spaces line (=nothing)
Comment 26 خالد حسني 2016-11-02 16:37:09 UTC
This might be related to bug 71603.
Comment 27 V Stuart Foote 2016-11-02 20:05:35 UTC
OPs issue of the Salable font icon not showing in the font preview was removed with https://cgit.freedesktop.org/libreoffice/core/commit/?id=a4e2e50c4d6422fe49f345409b6f94cbc43d3d09

The font preview, when set active (Tools -> Options -> View: Font Lists preview), now reliably renders either the font name or a sample of the font, or both. Including issue of comment 16, which also appears to be fixed.

Believe commits for bug 71603 resolved this as well:

http://cgit.freedesktop.org/libreoffice/core/commit/?id=03bff1b6b953e4b7a54d2fb7bbf366bea7e959d9

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5d39c2013374727b1c8f147b8b99d54402a7ff02

Version: 5.3.0.0.alpha1+
Build ID: 5d39c2013374727b1c8f147b8b99d54402a7ff02
CPU Threads: 8; OS Version: Windows 6.2; UI Render: GL; Layout Engine: old OR new;
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-11-02_01:01:09
Locale: en-US (en_US); Calc: CL