Bug 92875 - KDE Screensaver appears during slideshow
Summary: KDE Screensaver appears during slideshow
Status: RESOLVED FIXED
Alias: None
Product: Impress Remote
Classification: Unclassified
Component: General (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.1.0
Keywords:
Depends on:
Blocks:
 
Reported: 2015-07-22 17:36 UTC by Callegar
Modified: 2022-10-13 08:27 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Callegar 2015-07-22 17:36:28 UTC
When you do a presentation, controlling it with the keyboard or the mouse, the systems sees activity and provided that you change slides frequently enough does not lock screen dim screen or start the screen saver.

Hence, provided that you have sane enough delays for lock screen/dim screen/screensaver, you can happily do a presentation without any need to disable any of the above.

However, if you use the remote, the system does not see any activity and after a few slides locks the screen.

The remote backend in Libreoffice should be able to communicate to the system that some activity is going on (e.g. by simulating keypresses corresponding to slide changes).
Comment 1 Andrzej Hunt 2015-10-20 20:41:47 UTC
What OS, desktop, and distribution are you using?

We should actually be completely inhibiting screensavers/lockers, and display power management when running presentations - until now this was only supported on Windows, OSX, Gnome (if you ran into this issue on one of those then this bug is still present), and a limited selection of specialist Linux screensavers. As of the commits listed below we should also support KDE, Mate, XFCE (possibly more) - if you ran into this issue in those environments, then it would be helpful to test with a nightly build to ensure that the problem no longer exists.

http://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=3021a25b6d38e7de2e7a512c06adfea04a5394ec..68570131013cfcf29f4c934a727053c2903e35b1
Comment 2 Callegar 2015-10-20 20:51:13 UTC
I'm on Kubuntu 15.04 with KDE Plasma 5.3.2 and LibO 5.0.3.1

To prevent screen locking/dimming during a presentation, I need to explicitly disable power management in KDE (from the battery indicator in the system tray).

Inhability of LibO to block screen locking/dimming on the platform may well be an issue in KDE since Plasma 5 is still a big mess.
Comment 3 Andrzej Hunt 2015-10-22 10:35:47 UTC
This is fixed in:

Implement org.freedesktop.ScreenSaver inhibition
http://cgit.freedesktop.org/libreoffice/core/commit/?id=3021a25b6d38e7de2e7a512c06adfea04a5394ec


(Note: just about every Linux desktop has it's own screensaver inhibition API, if you discover further desktops where screensaver inhibition doesn't work please open a separate bug for this, but only AFTER testing a daily build, since support for multiple desktops has been added for LibreOffice 5.1.)

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds