Bug 93041 - UI: missing import bitmap button
Summary: UI: missing import bitmap button
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.0.0.beta3
Hardware: All All
: high normal
Assignee: Stephan Bergmann
URL:
Whiteboard: target:5.1.0 target:5.0.1
Keywords: regression
: 93340 93616 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-07-31 04:45 UTC by water.qian
Modified: 2016-10-25 19:24 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
screen capture (75.19 KB, image/jpeg)
2015-07-31 04:45 UTC, water.qian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description water.qian 2015-07-31 04:45:09 UTC
Created attachment 117550 [details]
screen capture

Import bitmap is missing.

1. Format > page
2. Select Area Tab
3. Select bitmap from Fill.
4. Import bitmap from file is missing.

Version: 5.0.0.4
Build ID: cf112dc905650fb985306a7a03d2fe3fcc6c978f
Locale: zh-CN (zh_CN)
Comment 1 MM 2015-07-31 10:53:19 UTC
Unconfirmed with v4.4.5.2 under mint 17.2 x64.
Confirmed with v5.0.0.4 under mint 17.2 x64.

Set to All, Regression.
Comment 2 V Stuart Foote 2015-08-01 23:32:35 UTC
Yep the "Import Graphic" dialog launch button went missing between 5.0.0beta2 and 5.0.0beta3. So in the range...

http://cgit.freedesktop.org/libreoffice/core/log/?h=libreoffice-5-0&qt=range&q=0a16c3dda4150008d9be6f24cbd15ac198d116d3..900960d3e4220f7e04f45c9bf45a1cd92cd06a

Maybe Philippe J.'s work on tpbitmap.cxx and tparea.cxx?

=-Ref-=
http://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-5-0&id=1379e2feaad6344999358bbfb271edbaea66ce2a
Comment 3 Philippe Jung 2015-08-02 16:42:05 UTC
(In reply to V Stuart Foote from comment #2)

> 
> Maybe Philippe J.'s work on tpbitmap.cxx and tparea.cxx?
> 

These changes were related to how dialogs are created / launched because of VclPtr conversion. So I would say probably not related.
Comment 4 Philippe Jung 2015-08-02 18:08:20 UTC
Search in progress. Not finished for the moment, so I leave a trace of what I found, if someone get a quick idea.

In tparea.cxx, PageCreated, in the case where pOfferImportItem is null, if I set mbOfferImportButton to true, the button appears.
Only way of setting this to true is from 
    SFX_ITEMSET_ARG (&aSet, pOfferImportItem, SfxBoolItem, SID_OFFER_IMPORT, false);

When debugging,

aSet contains SFX_ITEMS_NONE for nWhich = 11143 (SID_OFFER_IMPORT)


#4  0x00007fffaed943b3 in SvxAreaTabPage::PageCreated (this=0x4781000, aSet=...) at /home/philippe/src/lodev/master/cui/source/tabpages/tparea.cxx:2449
#5  0x00007fffaf44ee82 in SwTemplateDlg::PageCreated (this=0x466cee0, nId=3, rPage=...) at /home/philippe/src/lodev/master/sw/source/ui/fmtui/tmpdlg.cxx:605
#6  0x00007ffff4156c88 in SfxTabDialog::ActivatePageHdl (this=0x466cee0, pTabCtrl=0x477b820) at /home/philippe/src/lodev/master/sfx2/source/dialog/tabdlg.cxx:1182
#7  0x00007ffff4154d4a in SfxTabDialog::Start_Impl (this=0x466cee0) at /home/philippe/src/lodev/master/sfx2/source/dialog/tabdlg.cxx:610
#8  0x00007ffff41548c9 in SfxTabDialog::Execute (this=0x466cee0) at /home/philippe/src/lodev/master/sfx2/source/dialog/tabdlg.cxx:540
#9  0x00007fffaf3b9dac in AbstractTabDialog_Impl::Execute (this=0x46e89b0) at /home/philippe/src/lodev/master/sw/source/ui/dialog/swdlgfact.cxx:104
#10 0x00007fffb326a9d2 in SwDocShell::Edit (this=0x3c3b900, rName=..., rParent=..., nFamily=8, nMask=0, bNew=false, sPage=..., pActShell=0x41d0bc0, bBasic=false)
    at /home/philippe/src/lodev/master/sw/source/uibase/app/docst.cxx:800
#11 0x00007fffb326c87d in SwDocShell::FormatPage (this=0x3c3b900, rPage=..., rPageId=..., rActShell=...) at /home/philippe/src/lodev/master/sw/source/uibase/app/docst.cxx:1319
#12 0x00007fffb337c672 in SwBaseShell::ExecDlg (this=0x4375480, rReq=...) at /home/philippe/src/lodev/master/sw/source/uibase/shells/basesh.cxx:2395


In sw, SID_OFFER_IMPORT is mentioned only in http://opengrok.libreoffice.org/xref/core/sw/source/ui/frmdlg/frmdlg.cxx whereas code goes through /home/philippe/src/lodev/master/sw/source/ui/fmtui/tmpdlg.cxx
Comment 5 Stephan Bergmann 2015-08-04 16:02:08 UTC
The culprit is <http://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-5-0&id=c0e07bc592b7fe270514ae392eacb6ebde3df879> "tdf#88276: toolbar|sidebar button for text background colour" adding

  #define SID_ATTR_CHAR_BACK_COLOR ( SID_SVX_START + 1143 )

whose value (11143) clashes with the existing SID_OFFER_IMPORT, and an SfxItemInfo mapping from SID_ATTR_CHAR_BACK_COLOR to EE_CHAR_BKGCOLOR is added to the pool, so SFX_ITEMSET_ARG(..., SID_OFFER_IMPORT, ...) now internally maps from 11143 to 4044 (EE_CHAR_BKGCOLOR) and fails.
Comment 6 Commit Notification 2015-08-04 16:48:19 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4275056a90eb9e178062276cc104ac2b94db13ca

tdf#93041: Resolve clashing SID_OFFER_IMPORT vs. SID_ATTR_CHAR_BACK_COLOR

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2015-08-05 08:11:39 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ff7410fe4bc7518787afef5bd8a43760cb3d633c&h=libreoffice-5-0

tdf#93041: Resolve clashing SID_OFFER_IMPORT vs. SID_ATTR_CHAR_BACK_COLOR

It will be available in 5.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 water.qian 2015-08-06 11:37:01 UTC
Tested latest master and the button shows properly now.

Version: 5.1.0.0.alpha1+
Build ID: 08aab3de3ac9d2d284ebfbddb92874853451ddb0
TinderBox: Win-x86@39, Branch:master, Time: 2015-08-06_07:18:38
Locale: zh-CN (zh_CN)
Comment 9 Maxim Monastirsky 2015-08-12 09:00:13 UTC
*** Bug 93340 has been marked as a duplicate of this bug. ***
Comment 10 sophie 2015-08-24 10:24:46 UTC
*** Bug 93616 has been marked as a duplicate of this bug. ***