Bug 93054 - EDITING: dragging and dropping selected cells doesn't work (GTK3 only)
Summary: EDITING: dragging and dropping selected cells doesn't work (GTK3 only)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.1.0.0.alpha0+ Master
Hardware: Other Linux (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:5.2.0 target:5.1.1
Keywords: bisected
: 92653 93232 93383 94387 94567 95720 97053 97970 97971 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-07-31 17:39 UTC by Michael Weghorn
Modified: 2016-10-25 19:09 UTC (History)
14 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Weghorn 2015-07-31 17:39:13 UTC
Drag and drop using the mouse does not work in Calc for selected cells. It did work before.

Steps to reproduce:
1) create a new Calc sheet
2) insert some text into the cells A1 and A2
3) select the two cells using the mouse
4) click into the selection and keep the left mouse button pressed
5) move the mouse to different cells and release the left mouse button

Result:
Nothing happens. The cells A1 and A2 remain unchanged. Nothing is inserted at the place where the mouse button was released.

Expected result:
The content of the cells A1 and A2 should be moved to the cells where the left mouse button was released.


Version I use where the bug occurs (currently latest version in the "lo-linux-dbgutil-daily" bibisect repository):
Version: 5.1.0.0.alpha1+
Build ID: 2d9db406d301d722649ca539cacad823b89191ca
Locale: en-GB (en_GB.utf8)

However, drag and drop does still work with the following version (also from the current "lo-linux-dbgutil-daily" bibisect repository):
Version: 4.4.0.0.alpha2+
Build ID: d273a60bfdbf9bb7623bed38667ec0647753157c
Locale: en_GB

I am using Debian Jessie.
Comment 1 m.a.riosv 2015-08-01 00:12:49 UTC
Hi @Michael, thanks for reporting.

I can not reproduce.
Win7x64
Version: 5.1.0.0.alpha1+ (x64) Build ID: 303b7758e90e11aedef95e4ab51b74398cd2ce0a
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-07-30_23:48:31
Comment 2 tommy27 2015-08-01 04:45:47 UTC
me neither...

tested under Win8.1 x64 using LibO 5.1.0.0.alpha1+
Build ID: 62e2fae93e8894f73560a30ae1e752cbd4c001ad
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-07-29_04:40:44
Locale: it-IT (it_IT)
Comment 3 Michael Weghorn 2015-08-01 06:50:52 UTC
I just checked it again.
The problem is still there for me with the version of today from the "lo-linux-dbgutil-daily" bibisect repository - commit fdedb282817a9a1d6bf840e8020ac00eabde6f71; Version: 5.1.0.0.alpha1+; Build ID: 512b782cf466a19ed77d818fa660e1a0dc74fc35; Locale: en-GB (en_GB.utf8).

It also happens for me with my own build of commit 9ffdcc76858bc01150727345de4dfd0ef40ed8c0 on master.

In case this might be relevant: I am using Debian Jessie with Xfce on both computers on which I tested this.
Comment 4 Maxim Monastirsky 2015-08-01 19:44:32 UTC
Confirmed with gtk3 vclplug under Fedora 22. Does work with SAL_USE_VCLPLUGIN=gtk. The build is from commit 5f321b5011c619e88e19018ff05ed3ca2cdd5851.
Comment 5 Michael Weghorn 2015-08-06 14:33:57 UTC
The problem occurs since the following commit. If I revert it, dragging and dropping the cells works again.

commit 031a347668e56c1b38c0539d30e9a1cbb808ca02
Author: Caolán McNamara <caolanm@redhat.com>
Date:   Wed Jun 17 16:25:47 2015 +0100

    use gtk3 vclplug by default under GNOME3 if available
    
    Change-Id: I4efe8bdfb7080365094306aee9db6b69a7f9e86a


@Caolan: Could you possibly have a look at this?
Comment 6 Caolán McNamara 2015-08-07 08:04:20 UTC
if it never worked under the gtk3 vclplug then its not a regression, so clearing that flag
Comment 7 Maxim Monastirsky 2015-08-07 11:51:37 UTC
*** Bug 93232 has been marked as a duplicate of this bug. ***
Comment 8 Maxim Monastirsky 2015-08-12 14:19:15 UTC
*** Bug 93383 has been marked as a duplicate of this bug. ***
Comment 9 Maxim Monastirsky 2015-09-20 21:01:16 UTC
*** Bug 94387 has been marked as a duplicate of this bug. ***
Comment 10 Maxim Monastirsky 2015-09-28 17:45:49 UTC
*** Bug 94567 has been marked as a duplicate of this bug. ***
Comment 11 Maxim Monastirsky 2015-10-03 18:31:56 UTC
*** Bug 92653 has been marked as a duplicate of this bug. ***
Comment 12 Friedrich Strohmaier 2015-10-08 14:51:12 UTC
archlinux bugtracker:
https://bugs.archlinux.org/task/46315
Comment 13 Maxim Monastirsky 2015-11-10 09:26:05 UTC
*** Bug 95720 has been marked as a duplicate of this bug. ***
Comment 14 Maxim Monastirsky 2016-01-11 21:44:15 UTC
*** Bug 97053 has been marked as a duplicate of this bug. ***
Comment 15 Commit Notification 2016-01-26 13:26:53 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0b354d18ccfc05e7c2582f851d9201e2aa353d7d

Related: tdf#93054 gtk3: implement enough dnd to be dragged into...

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2016-01-27 13:16:53 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a5b4f6e456bfb735385e8d3d6945ea8f3be1ba94

Resolves: tdf#93054 gtk3: implement drag and drop

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Commit Notification 2016-01-28 10:43:40 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=237ebf91c17f8c20304ebd4f7cf8bd058bc6f7c7&h=libreoffice-5-1

Resolves: tdf#93054 gtk3: implement drag and drop

It will be available in 5.1.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Maxim Monastirsky 2016-02-18 10:23:30 UTC
*** Bug 97971 has been marked as a duplicate of this bug. ***
Comment 19 Maxim Monastirsky 2016-02-18 10:23:52 UTC
*** Bug 97970 has been marked as a duplicate of this bug. ***